Contar el número de palabras de una celda o rango en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

En muchas ocasiones necesitamos contar el número de palabras de una celda o rango en Excel.

Contar el número de palabras de una celda o rango en Excel

En el rango A2:A10 disponemos de las celdas que deseamos contar sus palabras.

  • NÚMERO DE PALABRAS EN CELDA
  1. Ir a: Celda B1 / Escribir:

    =SI(A2="";0;LARGO(ESPACIOS(A2))-LARGO(SUSTITUIR(A2;" ";""))+1)
  2. Copiar la celda B2 / Pegar en el rango B3:B9.

Rango B3:B9 con el número de palabras de las celdas
 
  • NÚMERO DE ESPACIOS EN CELDA
  1. Ir a: Celda C1 / Escribir:

    =LARGO(ESPACIOS(A2))-LARGO(SUSTITUIR(A2;" ";""))
  2. Copiar la celda C2 / Pegar en el rango C3:C9.

Rango C3:C9 con el número de espacios de las celdas
 
  • NÚMERO DE PALABRAS EN UN RANGO
  1. Ir a: Celda E2 / Escribir:

    Excel

    Como la palabra deseada a contar en el rango A2:A10.

  2. Ir a: Celda F2 / Escribir:

    =CONTAR.SI(A2:A10;"*"&E2&"*")

    O también escribir (la palabra en la función):

  3. =CONTAR.SI(A2:A10;"*Excel*")
Celda con el número de palabras del rango
Nivel de dificultad: Avanzado Excel Avanzado

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.