Contar valores únicos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En ocasiones deseamos contar el número de valores numéricos únicos que tenemos en un rango (Contar valores únicos en Excel).

Contar valores únicos en Excel
La hoja Excel dispone de la columna B que muestra la referencia de los clientes y deseamos conocer, el número total de clientes a los que hemos realizado un presupuesto.
Contar valores únicos en Excel: Hoja Excel con columna B mostrando la referencia del cliente.

Emplearemos las siguientes funciones:

  • Función SUMAPRODUCTO. Suma los productos del rango.

  • Función CONTAR.SI. Cuenta las celdas de la condición dada.

Función anidada =SUMAPRODUCTO(1/CONTAR.SI(B2:B10;B2:B10))
  1. Ir a: Celda F1 / Escribir:

    =SUMAPRODUCTO(1/CONTAR.SI(B2:B10;B2:B10))

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Matemáticas y trigonométricas / SUMAPRODUCTO.

  2. Mostrará 4 como el número de clientes sin repetidos del rango B2:B10.

Celda F1 anidada: =SUMAPRODUCTO(1/CONTAR.SI(B2:B10;B2:B10))
También podemos obtener el valor mediante las funciones: SUMA, SI y FRECUENCIA.
  • Función SUMA. Suma todos los números en un rango de celdas.

  • Función SI. Comprueba si se cumple una condición.

  • Función FRECUENCIA. Devuelve una distribución de frecuencia como una matriz vertical.

Contar valores únicos en Excel: Función anidada =SUMA(SI(FRECUENCIA(B2:B10;B2:B10)>0;1))
  1. Ir a: Celda F2 / Escribir:

    =SUMA(SI(FRECUENCIA(B2:B10;B2:B10)>0;1))

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Matemáticas y trigonométricas / SUMA.

  2. Mostrará 4 como el número de clientes sin repetidos del rango B2:B10, saltando las celdas vacías y se aplica a valores numéricos.

Contar valores únicos en Excel: Celda F1 anidada =SUMA(SI(FRECUENCIA(B2:B10;B2:B10)>0;1))

Mediante funciones podemos contar valores únicos en Excel por cualquiera de los métodos.

Nivel de dificultad: Avanzado Excel Avanzado

4 comentarios en “Contar valores únicos en Excel

  • Apreciaré mucho si me pueden ayudar con el problema que tengo para contar registros únicos que cumplan con alguna regla….me explico:
    – En la columna “A” tengo una lista de profesores
    – En la Columna “B” tengo códigos alfanuméricos que representan las secciones que les fueron asignadas a cada profesor, pero dichas secciones se repiten, ya que hay un registro por cada día de la semana en que dicha sección tiene clase, de manera que las secciones que tienen clases 2 veces por semana, aparecen en 2 registros (uno por cada día) repitiendo así el código de la sección.
    – En la columna “C” tengo el día de la semana que se dicta la clase (Lunes, martes, Miércoles….etc)
    – Lo que necesito es que el Excel me ayude a saber cuántas secciones tiene asignadas cada profesor, para lo cual debe contar los registros únicos de las secciones que están asignadas a cada profesor.

  • buenos dias,

    una duda, ¿con esta funcion puedo incluir distintas condiciones y con ello que cuente en funcion de distintos parametros?

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *