Contar valores repetidos en una columna Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Cuando necesitamos contar valores repetidos en una columna Excel, podemos recurrir a funciones.

Contar valores repetidos en una columna Excel

Disponemos en la columna A diferentes países con el valor repetido y en la columna B deseamos que muestre el número de veces que se encuentra repetido.

 AB
1PaísNº Repetido
2España 
3Francia 
4México 
5España 
6Perú 
7Colombia 
8Francia 
9Francia 
  1. Ir a: Celda B2 / Escribir:

    =CONTAR.SI($A$2:$A$9;A2)

    O también, para toda la columna:

    =CONTAR.SI(A:A;A2)
  2. Copiar la celda B2 / Pegar en el rango B3:B9.

  3. Verificar como muestra el número de veces que se repite el valor en la columna.

Celda B2 mostrando 2 como el número de valores repetidos
 
  • REPETIDOS POR POSICIÓN
  1. Ir a: Celda C2 / Escribir:

    = CONTAR.SI($A$2:$A2;A2)
  2. Copiar la celda C2 / Pegar en el rango C3:C9.

  3. Verificar como se muestran los países repetidos con el número de posición que ocupa en la columna.

Celda C92 mostrando 3 como el número de posición del número de veces repetido

  

Nivel de dificultad: Avanzado Excel Avanzado

22 comentarios en “Contar valores repetidos en una columna Excel

  • Quiero sumar los valore repetidos de un rango que se encuentra en la hoja uno, pero el resultado lo quiero en la hoja dos, que formula ocuparia.

  • Hola, muy buen día, necesito contar las celdas repetidas y multiplicarlas por el valor de la celda de al lado, por decir:
    tengo una columna con muchos vehículos, otra con el tipo de neumáticos que usan y otra con la cantidad de neumático que requieren (esto varía de acuerdo al uso y tipo de vehículo), necesito establecer celdas repetidas y cuantos neumáticos se requieren para satisfacer la demanda. De antemano muchas gracias por su atención.

  • Necesito contar cuántos números telefónicos se repiten en una base de datos.
    Por ejemplo; tengo en una columna los números telefónicos, en otra la hora en que fue, y en otro el día,mes,año.
    Lo que debo hacer es separar por día o por mes cuántas veces se repite un mismo número.
    Cómo hago esto sin desarmar la base de datos por día o mes? por favor ayuda.

  • Buena Noche una pregunta cómo puedo contar cuantas veces se repita el texto “0-“ en un rengo de celdas, los datos en las celdas son textos que puede ser como por ejemplo “0-20” o “0-35”

  • Hola, muchas gracias por el aporte, está muy bueno!

    tengo una consulta: tengo una Tabla en una hoja de Excel que está dividida por negocio: negocio A, Negocio B y negocio C.

    Cada negocio puede tener el producto X varias veces en la lista.

    Yo necesito contar en otra columna cuáles (no cuantos) negocios tienen el producto X, independientemente si hay 5 productos X en un negocio, o 20 en el otro negocio.

    Lo que necesito es que me diga que el producto X lo hay en 2 negocios (por ejemplo) ¿cómo pudiera ser? Muchas gracias

  • Hola, como puedo sumar los datos de unas columnas no datos duplicados, es decir en la columna A tengo el numero de cedulas y en la culumba B datos numericos, se supone que la suma debe estos datos para cada persona debe dar 100. gracias

  • Buenas!
    Tengo una tabla con datos, donde en la columna A se repiten valores que ya tengo localizados con "Duplicar Valores". Ahora necesito un grafico (por ejemplo) donde se refleje el % del total de la columna de datos repetidos. Esto es...de 100 datos, se repiten 20...se están repitiendo el 20% de los datos. Con un volumen mayor de datos, ¿hay alguna formula que lo refleje?

  • Hola que tal y si quisiera hacer exactamente lo mismo pero sobre las columnas, es decir contar cuantas veces se repite el mismo valor en las diferentes columnas

  • Hola tengo una columna con rucs repetidos, como puedo hacer que solo cuente los que no se repiten, es decir si hay 5 de esos mismos rucs, que solo me salga 1. gracias

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.