Contar valores repetidos en una columna Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Cuando necesitamos contar valores repetidos en una columna Excel, podemos recurrir a funciones.

Contar valores repetidos en una columna Excel

Disponemos en la columna A diferentes países con el valor repetido y en la columna B deseamos que muestre el número de veces que se encuentra repetido.

 AB
1PaísNº Repetido
2España 
3Francia 
4México 
5España 
6Perú 
7Colombia 
8Francia 
9Francia 
  1. Ir a: Celda B2 / Escribir:

    =CONTAR.SI($A$2:$A$9;A2)

    O también, para toda la columna:

    =CONTAR.SI(A:A;A2)
  2. Copiar la celda B2 / Pegar en el rango B3:B9.

  3. Verificar como muestra el número de veces que se repite el valor en la columna.

Celda B2 mostrando 2 como el número de valores repetidos
  • REPETIDOS POR POSICIÓN

  1. Ir a: Celda C2 / Escribir:

    = CONTAR.SI($A$2:$A2;A2)
  2. Copiar la celda C2 / Pegar en el rango C3:C9.

  3. Verificar como se muestran los países repetidos con el número de posición que ocupa en la columna.

Celda C92 mostrando 3 como el número de posición del número de veces repetido

  

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *