Vencimiento bianual en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Disponemos de un listado de fechas, donde si el mes esta comprendido entre enero y junio nos muestre el año anterior y el actual, y sí se encuentra entre julio y diciembre muestre el año actual y el siguiente, es decir, el vencimiento bianual en Excel.

Emplearemos las siguientes funciones anidándolas:

  • Función SI. Comprueba si se cumple la condición, enero a junio o julio a diciembre.

  • Función MES. Convierte un número en el mes correspondiente.

  • Función AÑO. Convierte un número en el año correspondiente.

Vencimiento bianual en Excel: Función anidada, =SI(MES(A2)<7;AÑO(A2)-1&'' — ''&AÑO(A2);AÑO(A2)&'' — ''&AÑO(A2)+1)

Disponemos del rango A2:A5 con el origen de los datos. En el rango B2:B5 deseamos obtener el año del vencimiento bianual.

 AB
1FechaVencimiento
212/06/2013
305/02/2014
412/11/2012
501/05/2018
  1. Ir a: Celda A2 / Escribir: 12/06/2013. O la fecha deseada para la que deseamos obtener el vencimiento.

  2. Ir a: Celda B2 / Escribir:

    =SI(MES(A2)<7; AÑO(A2)-1&” – ”&AÑO(A2); AÑO(A2)&” – ”&AÑO(A2)+1)

    El operador & (And persons) permite concatenar (unir) las expresiones.

     

  3. Mostrará: 2012 – 2013. Al ser el mes de junio, deberá de mostrar el año anterior y el actual (condición deseada para el vencimiento bianual).

    Vencimiento bianual en Excel: Celda B2 mostrando 2012-2013, al ser el mes junio.
  4. Copiar la celda B2. Celda que contiene la fórmula aplicada.

  5. Seleccionar el rango B3:B5 / Pegar como fórmula. Obteniendo el vencimiento bianual en Excel para las fechas en el rango deseado.

Permitiendo así obtener el vencimiento bianual en Excel de una fecha, mediante las funciones de Excel SI, MES y AÑO.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *