Valor existente en un rango de Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Podemos comprobar si disponemos de un valor existente en un rango de Excel.

En el rango A1:C7, disponemos de las provincias de nuestros clientes y deseamos buscar si el valor de F1 se encuentra incluido en el rango.
Valor existente en un rango de Excel: Rango de búsqueda A1:C7 y valor repetido en F1.
  • EL VALOR EXISTE (Método 1). Devuelve VERDADERO si el valor está repetido y FALSO si no lo está.

Emplearemos la siguiente función:

– Función O. Devuelve VERDADERO si algún argumento es VERDADERO.

  1. Ir a: Celda B11 / Escribir:

    =O(A1:C7=F1)
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=O(A1:C7=F1)}.

Valor existente en un rango de Excel: Celda B11 con fórmula {=O(A1:C7=F1)}, mostrando VERDADERO

  • EL VALOR EXISTE (Método 2). Devuelve REPETIDO si el valor está repetido y NO REPETIDO si no lo está.

Emplearemos las siguientes funciones, anidándolas:

– Función SI. Especifica un texto lógico para ejecutar.

– Función O. Devuelve VERDADERO si algún argumento es VERDADERO.

  1. Ir a: Celda B12 / Escribir:

    =SI(O(A1:C7=F1);"REPETIDA";"NO REPETIDA")
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SI(O(A1:C7=F1);"REPETIDO";"NO REPETIDO")}.

Valor existente en un rango de Excel: Celda B12 con fórmula {=SI(O(A1:C7=F1);"REPETIDA";"NO REPETIDA"))}, mostrando REPETIDA
  • EL VALOR EXISTE (Método 3). Devuelve REPETIDO si el valor está repetido y NO REPETIDO si no lo está.

Emplearemos las siguientes funciones, anidándolas:

– Función SI. Especifica un texto lógico para ejecutar.

– Función SUMAPRODUCTO. Devuelve la suma de los productos de los componentes de la matriz correspondiente.

  1. Ir a: Celda B13 / Escribir:

    =SI(SUMAPRODUCTO(–(A1:C4=F1))>=1;"REPETIDO";"NO REPETIDO")
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SI(SUMAPRODUCTO(–(A1:C4=F1))>=1;"REPETIDO";"NO REPETIDO")}.

Valor existente en un rango: Celda B13 con fórmula =SI(SUMAPRODUCTO(--(A1:C4=F1))>=1;"REPETIDA";"NO REPETIDA"), mostrando REPETIDA

  • EL VALOR EXISTE EN UNA COLUMNA. Devuelve REPETIDO si el valor está repetido y NO REPETIDO si no lo está.

Emplearemos las siguientes funciones, anidándolas:

– Función ESERROR. Devuelve VERDADERO si el valor es cualquier valor de error.

– Función BUSCARV. Busca en la primera columna de una matriz y se mueve en la fila para devolver el valor de una celda.

  1. Ir a: Celda B14 / Escribir:

    =SI(ESERROR(CONSULTAV(F1;A1:C7;1;FALSO));"NO REPETIDO";"REPETIDO")
Valor existente en un rango de Excel: Celda B14 con fórmula =SI(ESERROR(CONSULTAV(F1;A1:C7;1;FALSO));"NO REPETIDA";"REPETIDA"), mostrando REPETIDA
  • EL VALOR EXISTE ES IDÉNTICO. Devuelve VERDADERO si el valor está repetido y es idéntico y FALSO si no está repetido y no ese idéntico (mayúscula y minúscula).

Emplearemos las siguientes funciones, anidándolas:

– Función O. Devuelve VERDADERO si algún argumento es VERDADERO.

– Función IGUAL. Comprueba si dos valores de texto son exactamente iguales.

  1. Ir a: Celda B16 / Escribir:

    =O(IGUAL(A1:C7;F1))
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=O(IGUAL(A1:C7;F1))}.

Valor existente en un rango: Celda B16 con fórmula {=O(IGUAL(A1:C7;F1))}, mostrando VERDADERO
  • NÚMERO DE REPETIDOS. Devuelve el número de valores distintos repetidos.

Emplearemos la siguiente función:

– Función CONTAR.SI. Cuenta el número de celdas que no están en blanco dentro de un rango que coincida con los criterios especificados.

  1. Ir a: Celda B18 / Escribir:

    =CONTAR.SI(A1:C7; F1)
Valor existente en un rango: Celda B18 con fórmula =CONTAR.SI(A1:C7; F1), mostrando 2.
  • VALORES NO REPETIDOS. Devuelve el número de valores no repetidos en el rango.

Emplearemos las siguientes funciones, anidándolas:

– Función SUMA. Suma todos los números en un rango de celdas.

– Función CONTAR.SI. Cuenta el número de celdas que no están en blanco dentro de un rango que coincida con los criterios especificados.

  1. Ir a: Celda B20 / Escribir:

    =SUMA(1/CONTAR.SI(A1:C7;A1:C7))
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(1/CONTAR.SI(A1:C7;A1:C7))}.

Valor existente en un rango: Celda B20 con fórmula {=SUMA(1/CONTAR.SI(A1:C7;A1:C7))}, mostrando 17.
  • NÚMERO DE FILA PRIMER VALOR REPETIDO. Devuelve el número de de la fila del primer valor encontrado.

Emplearemos la siguiente función:

– Función SIERROR. Devuelve un valor que se especifica si una fórmula lo evalúa como un error; de lo contrario, devuelve el resultado de la fórmula.

– Función COINCIDIR. Busca los valores en una referencia o matriz.

  1. Ir a: Celda B23 / Escribir:

    = SIERROR(COINCIDIR(F1;A1:A7;0); SIERROR(COINCIDIR(F1;B1:B7;0); SIERROR(COINCIDIR(F1;C1:C7;0); "NO REPETIDA")))
Valor existente en un rango: Celda B22 con fórmula = SIERROR(COINCIDIR(F1;A1:A7;0);SIERROR(COINCIDIR(F1;B1:B7;0);SIERROR(COINCIDIR(F1;C1:C7;0);"NO REPETIDA"))), mostrando 1

Así en Excel podemos comprobar si un valor existe en un rango.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *