Traducir al inglés las funciones Excel de nuestra hoja

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En muchas ocasiones necesitamos traducir al inglés las funciones Excel de nuestra hoja.

Traduce al inglés las funciones Excel

Disponemos en la columna A el valor que queremos sumar y nos traduzca la función al inglés.

 AB
1Valores      
212
314
415

 

  • CREAR LA FUNCIÓN

  1. Con Excel abierto.

  2. Pulsar la tecla Alt y mantener pulsada /Pulsar la tecla F11. Mostrará el editor de Visual Basic.

  3. Ir a: Barra de Menú / Insertar / Módulo. Mostrará la ventana del módulo donde escribiremos la función.

    Function Traduce_Ingles (Valor As Range)

    Traduce_Ingles = Valor.Formula

    End Function

  4. Guardar el libro con la extensión *.xlsm. Libro habilitado para macros.

  • INSERTAR LA FUNCIÓN DESEADA

Función SUMA que deseamos traducir al inglés (SUM).

  1. Ir a: Celda C1 / Escribir:

    =SUMA(A2:A4)
Celda C1 con la función en español que deseamos traducir =SUMA(A2:A4)
  • TRADUCIR LA FUNCIÓN

  1. Seleccionar la celda D1. Celda donde insertar la función que deseamos traducir.

  2. Ir a: Cinta de opciones /Pestaña: Fórmulas / Grupo: Biblioteca de funciones / Insertar función. Mostrará la ventana de mostrar función.

    Ventana insertar función con categoría definida por el usuario
  3. Ir a: O seleccionar una categoría / Seleccionar: Definida por el usuario. Categoría deseada de nuestra función.

  4. Ir a: Seleccionar una función / Clic sobre Traduce_Ingles. Función deseada.

  5. Pulsar el botón Aceptar. Cierra la ventana y muestra la ventana de argumentos.

    Ventana argumentos de función Traduce_Ingles
  6. Ir a: Valor / Clic sobre la celda C1. Celda que incluye la función que deseamos traducir al inglés.

  7. Pulsar el botón Aceptar. Cierra la ventana e inserta la función.

    O también, Escribir:

    =Traduce_Ingles(C1)
  8. Verificar como la celda D1 muestra la función de C1 traducida al inglés =SUM(A2:A4).

Celda D1 con el valor traducido de la celda C1, =SUM(A2:A4)

  

Nivel de dificultad: Experto VBA-Macros Excel Experto VBA – Macros

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *