Todos los métodos para evitar insertar valores repetidos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En ocasiones es importante asegurarnos que no se inserte el mismo valor en una celda, para ello te presentamos todos los métodos para evitar insertar valores repetidos en Excel.

Todos los métodos para evitar insertar valores repetidos en Excel
  • EN UNA COLUMNA

Evitamos insertar valores repetidos en un rango en columna.

  1. Seleccionar el rango: A2:A9. Rango donde escribir los valores no repetidos.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$A$9;A2)=1
  3. Ir a la pestaña: Configuración.

  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$A$9;A2)=1
  6. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

    Ventana validación de datos mensaje de error
  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error en valor insertado.

  9. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos en una columna
  11. Verificar como en el rango A2:A9 no admite un valor repetido.

  • EN UNA FILA

Evitamos insertar valores repetidos en un rango en fila.

  1. Seleccionar el rango: A2:F2. Rango donde escribir los valores no repetidos.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$F$2;A2)=1
  3. Ir a la pestaña: Configuración.

  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$F$2;A2)=1
  6. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error en valor insertado.

  9. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos en una fila
  11. Verificar como en el rango A2:F2 no admite un valor repetido.

  • ENTRE COLUMNAS

Evitamos insertar valores repetidos en el rango columna B, con origen de los valores en columna A.

  1. Ir al Rango A2:A9 / Escribir los países deseados. O el valor deseado que no deseamos repetir.

  2. Seleccionar el rango: B2:B9. Rango donde escribir los valores no repetidos.

  3. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$A$9;B2)<>1
  4. Ir a la pestaña: Configuración.

  5. Ir a: Permitir / Seleccionar: Personalizada.

  6. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$A$9;B2)<>1
  7. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  8. Ir a: Estilo / Seleccionar: Detener.

  9. Ir a: Título / Escribir: Error en valor insertado.

  10. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido.

  11. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos entre columnas
  12. Verificar como en el rango B2:B9 no admite un valor repetido.

  • EN COLUMNA SEGÚN UNA CELDA

Evitamos insertar valores repetidos en el rango columna B, con origen en la celda A2.

  1. Ir a: Celda A2 / Escribir: España. O el valor deseado.

  2. Seleccionar el rango: B2:B9. Rango donde escribir el valor no repetido.

  3. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI(A2;B2:B9)<>1
  4. Ir a la pestaña: Configuración.

  5. Ir a: Permitir / Seleccionar: Personalizada.

  6. Ir a: Fórmula / Escribir:

    =CONTAR.SI(A2;B2:B9)<>1
  7. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  8. Ir a: Estilo / Seleccionar: Detener.

  9. Ir a: Título / Escribir: Error en valor insertado.

  10. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido.

  11. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos en columna según una celda
  12. Verificar como en el rango B2:B9 no admite un valor repetido.

  • ENTRE CELDAS

Evitamos insertar el mismo valor entre dos celdas.

  1. Ir a: Celda A2 / Escribir: España. O el valor deseado.

  2. Seleccionar la celda: B2. Celda donde escribir el valor no repetido.

  3. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =B2<>A2
  4. Ir a: Fórmula / Escribir:

    =B2<>A2
  5. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  6. Ir a: Estilo / Seleccionar: Detener.

  7. Ir a: Título / Escribir: Error en valor insertado.

  8. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido.

  9. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos entre celdas
  10. Verificar como en el rango A2:B2 no admite un valor repetido.

  • EN UN RANGO

Evitamos insertar valores repetidos en un rango.

  1. Seleccionar el rango: A2:D9. Rango donde escribir los valores no repetidos.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$D$9;A2)=1
  3. Ir a la pestaña: Configuración.

  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$D$9;A2)=1
  6. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error en valor insertado.

  9. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos en un rango
  11. Verificar como en el rango A2:D9 no admite un valor repetido.

Nivel de dificultad: Avanzado Excel Avanzado

8 comentarios en “Todos los métodos para evitar insertar valores repetidos en Excel

  • Hola buenos días
    Saludos

    En una hoja tengo la columna b para no permitir datos repetidos, si lo ago desde la misma hoja si me funciona, pero si lo que hago es que mando a copiar desde otra hoja no me da ningún error ni mensaje y inserta el dato repetido. ¿Que puedo hacer?

  • Hola, gracias por la info es muy útil.
    Tengo un problema que aún no resuelvo.
    quiero que evite introducir valores duplicados en un rango, pero quiero que considere las palabras con acento como iguales y así si un usuario introduce una palabra con acento y después vuelva a introducir esa misma palabra con acento, que Excel reconozca que ya hay una coincidencia y evite introducir.
    =CONTAR.SI($A$1:$A$5,SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(A1,"á","a"),"é","e"),"í","i"),"ó","o"),"ú","u"))=1
    Si hace la sustitución, por ejemplo de mamá --> mama, si cuenta que existe 2 veces la palabra mama, pero cuando esperaría que evite la introducción, simplemente si me deja escribir mamá.
    Te agradezco mucho de antemano si me das una opinion al respecto.

    • Hola Alfredo,

      La función que indicas con sustituir te muestra falso cuando existe una tílde, por lo que no es operativo.

      Y realmente tampoco estás comparando cada valor del rango A1:A5; =CONTAR.SI($A$2:$A$5;A2)=1

      Lo mejor es que lo apliques en columnas diferentes.

      Saludos

  • Buenos días.

    Estoy añadiendo datos a una tabla a través de formulario. Si escribo el dato duplicado en la tabla directamente con la fórmula de validación =CONTAR.SI(A:A;A2)<=1, me sale el mensaje de error, correcto. Pero si escribo en el formulario, me acepta el duplicado y no sale el mensaje de error. ¿Cómo puedo subsanar esto?

    Gracias anticipadas,

    Josep Mª Jolis

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.