Todos los métodos para evitar insertar valores repetidos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En ocasiones es importante asegurarnos que no se inserte el mismo valor en una celda, para ello te presentamos todos los métodos para evitar insertar valores repetidos en Excel.

Todos los métodos para evitar insertar valores repetidos en Excel
  • EN UNA COLUMNA

Evitamos insertar valores repetidos en un rango en columna.

  1. Seleccionar el rango: A2:A9. Rango donde escribir los valores no repetidos.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$A$9;A2)=1
  3. Ir a la pestaña: Configuración.

  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$A$9;A2)=1
  6. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

    Ventana validación de datos mensaje de error
  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error en valor insertado.

  9. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos en una columna
  11. Verificar como en el rango A2:A9 no admite un valor repetido.

  • EN UNA FILA

Evitamos insertar valores repetidos en un rango en fila.

  1. Seleccionar el rango: A2:F2. Rango donde escribir los valores no repetidos.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$F$2;A2)=1
  3. Ir a la pestaña: Configuración.

  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$F$2;A2)=1
  6. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error en valor insertado.

  9. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

  11. Demostración de la validación de datos en una fila
  12. Verificar como en el rango A2:F2 no admite un valor repetido.

  • ENTRE COLUMNAS

Evitamos insertar valores repetidos en el rango columna B, con origen de los valores en columna A.

  1. Ir al Rango A2:A9 / Escribir los países deseados. O el valor deseado que no deseamos repetir.

  2. Seleccionar el rango: B2:B9. Rango donde escribir los valores no repetidos.

  3. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$A$9;B2)<>1″ width=”422″ height=”319″ class=”aligncenter size-full wp-image-27380″ /></div></li><li><p>Ir a la <strong>pestaña: Configuración.</strong></p></li><li><p>Ir a: <strong>Permitir / Seleccionar: Personalizada.</strong></p></li><li><p>Ir a: <strong>Fórmula / Escribir:</strong></p><div
class= =CONTAR.SI($A$2:$A$9;B2)<>1
  4. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  5. Ir a: Estilo / Seleccionar: Detener.

  6. Ir a: Título / Escribir: Error en valor insertado.

  7. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido.

  8. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

  9. Demostración de la validación de datos entre columnas
  10. Verificar como en el rango B2:B9 no admite un valor repetido.

  • EN COLUMNA SEGÚN UNA CELDA

Evitamos insertar valores repetidos en el rango columna B, con origen en la celda A2.

  1. Ir a: Celda A2 / Escribir: España. O el valor deseado.

  2. Seleccionar el rango: B2:B9. Rango donde escribir el valor no repetido.

  3. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI(A2;B2:B9)<>1″ width=”422″ height=”319″ class=”aligncenter size-full wp-image-27382″ /></div></li><li><p>Ir a la <strong>pestaña: Configuración.</strong></p></li><li><p>Ir a: <strong>Permitir / Seleccionar: Personalizada.</strong></p></li><li><p>Ir a: <strong>Fórmula / Escribir:</strong></p><div
class= =CONTAR.SI(A2;B2:B9)<>1
  4. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  5. Ir a: Estilo / Seleccionar: Detener.

  6. Ir a: Título / Escribir: Error en valor insertado.

  7. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido.

  8. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos en columna según una celda
  9. Verificar como en el rango B2:B9 no admite un valor repetido.

  • ENTRE CELDAS

Evitamos insertar el mismo valor entre dos celdas.

  1. Ir a: Celda A2 / Escribir: España. O el valor deseado.

  2. Seleccionar la celda: B2. Celda donde escribir el valor no repetido.

  3. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =B2<>A2″ width=”422″ height=”319″ class=”aligncenter size-full wp-image-27384″ /></div></li><li><p>Ir a: <strong>Fórmula / Escribir:</strong></p><div
class= =B2<>A2
  4. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  5. Ir a: Estilo / Seleccionar: Detener.

  6. Ir a: Título / Escribir: Error en valor insertado.

  7. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido.

  8. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos entre celdas
  9. Verificar como en el rango A2:B2 no admite un valor repetido.

  • EN UN RANGO

Evitamos insertar valores repetidos en un rango.

  1. Seleccionar el rango: A2:D9. Rango donde escribir los valores no repetidos.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana validación de datos con fórmula =CONTAR.SI($A$2:$D$9;A2)=1
  3. Ir a la pestaña: Configuración.

  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$D$9;A2)=1
  6. MENSAJE DE ERROR. Pulsar sobre la pestaña: Mensaje de error.

  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error en valor insertado.

  9. Ir a: Mensaje / Escribir: El valor insertado ya existe, asegúrate de escribir un valor no repetido. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato condicional.

    Demostración de la validación de datos en un rango
  11. Verificar como en el rango A2:D9 no admite un valor repetido.

 

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *