Todos los métodos para contar celdas vacías y con datos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Mediante el uso de funciones, te mostramos todos los métodos para contar celdas vacías y celdas con datos en Excel.

Todos los métodos para contar celdas vacías y con datos en Excel

En el rango A2:A10 disponemos de celdas con valores y celdas vacías y deseamos contar el número de ellas.

  • CELDAS VACÍAS O EN BLANCO

Mediante diferentes funciones podemos obtener el número de celdas vacías o en blanco del rango A1:A10.

Rango D1:H1 con el número 2 de celdas vacías en Excel
  1. Ir a: Celda D1 / Escribir:

    =CONTAR.BLANCO(A2:A10)
  2. Verificar como muestra 2 como el número de celdas vacías del rango A2:A10.

     
  3. O también, ir a: Celda E1 / Escribir:

    =CONTAR.SI(A2:A10;"")
     
  4. O también, ir a: Celda F1 / Escribir:

    =CONTAR.SI(A2:A10;"="&"")
     
  5. O también, ir a: Celda G1 / Escribir:

    =CONTAR.SI.CONJUNTO(A2:A10;"=")
     
  6. O también, ir a: Celda H1 / Escribir:

    =SUMAPRODUCTO((A2:A10="")*(A2:A10=""))
 
  • CELDAS CON DATOS

Mediante diferentes funciones podemos obtener el número de celdas con datos del rango A1:A10.

Rango D2:F2 con el número 7 de celdas con datos en Excel
  1. Ir a: Celda D2 / Escribir:

    =CONTAR.SI(A2:A10;"<>"&"")
  2. Verificar como muestra 7 como el número de celdas vacías del rango A2:A10.

     
  3. O también, ir a: Celda E2 / Escribir:

    =CONTAR.SI.CONJUNTO(A2:A10;"<>""";A2:A10;"<>")
     
  4. O también, ir a: Celda F2 / Escribir:

    =SUMAPRODUCTO((A2:A10<>"")*(A2:A10<>""))
Nivel de dificultad: Avanzado Excel Avanzado

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.