Todos los errores al escribir fórmulas y funciones en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Perdemos mucho tiempo revisando anomalías, te mostramos todos los errores al escribir fórmulas y funciones en Excel.

Todos los errores al escribir fórmulas y funciones en Excel
  • NO SE CALCULA LA FÓRMULA

Al cambiar los valores de las celdas, el cálculo de la fórmula no se actualiza al disponer de cálculo manual.

  1. Ir a: Cinta de opciones / Pestaña: Archivo / Opciones.

  2. Ir a: Fórmulas / Opciones de cálculo / Activar la opción: Automático.

Ventana de opciones de Excel
 
  • NO MUESTRA EL CÁLCULO

Al escribir una fórmula no se muestra el valor del cálculo, mostrándose en la celda la fórmula escrita.

  1. Ir a: Cinta de opciones / Pestaña: Fórmulas / Grupo: Auditoría de fórmulas / Mostrar fórmulas. Cambiará la fórmula por el valor calculado.

Celda con fórmula sin mostrar cálculos
 
  • FÓRMULA SIN EL SIGNO DE IGUAL (=)

En ocasiones al escribir una fórmula o función no comienza por el signo de igual, no realizándose ningún cálculo en la celda y mostrándose la sintaxis de ella.

En el ejemplo se quería escribir la fórmula =A1+B1 (A1+B1).

Fórmula Excel sin símbolo de igual
 
  • REFERENCIAS CIRCULARES

Una referencia circular se produce cuando una fórmula hace referencia a la celda en la que se encuentra.

La solución es mover la fórmula a otra celda o cambiar la sintaxis de la fórmula, una que evite las referencias circulares. Sin embargo, en algunos escenarios es posible que necesite referencias circulares porque hacen que las funciones de iteración, se repitan hasta que se cumpla una condición numérica específica.

En el ejemplo se quiere sumar el rango A1:A3 y en la celda A4, con el total, figura =SUMA(A1:A4).

Función SUMA con referencia circular
  1. Ir a: Cinta de opciones / Pestaña: Fórmulas / Grupo: Auditoría de fórmulas / Comprobar fórmulas / Referencias circulares. Mostrará las referencias circulares existentes.

- Ampliar información: La referencia circular en Excel.

 
  • SÍMBOLO INCORRECTO AL MULTIPLICAR Y DIVIDIR

Es habitual representar la multiplicación con el operador (x) en lugar de asterisco (*) y la división con el operador (:) en lugar de barra inclinada (/). Recordar que (:) hace referencia a un rango.

En el ejemplo queremos multiplicar =A1*B1 y se inserta como =A1xB1; y también queremos dividir =A1/B1 y se inserta =A1:B1.

Fórmula con error por símbolo x e :
 
  • EXCESIVAS FUNCIONES ANIDADAS

En Excel podemos anidar hasta 64 niveles de funciones en una fórmula, es decir insertar una función dentro de otra y de otra...

En el ejemplo se incluyen 90 anidaciones, mostrando mensaje de error.

Mensaje de error con problema de anidación de funciones
 
  • NOMBRE DE LA HOJA

Al incluir la referencia a celdas de otra hoja el nombre está mal escrito por:

a. Tener en cuenta espacios, acentos, etc. (las mayúsculas y minúsculas no se tienen en consideración).

b. La referencia a la hoja está escrita con dobles comillas en lugar de sin ellas o con comilla simple.

En el ejemplo la celda D3 está escrita ='Ventas Enero'!D3 (también, =Ventas Enero!D3) de forma correcta en lugar de ="Ventas Enero"!D3.

Referencia Excel a hoja con comilla simple
 
  • POCOS O EXCESIVOS ARGUMENTOS EN LA FUNCIÓN

Las funciones de Excel necesitan argumentos para realizar el cálculo, por lo que deberá de tener todos los argumentos necesario y en la posición correcta.

Algunas funciones no requieren argumentos, por ejemplo HOY().

En el ejemplo su utiliza la función DIAS que tiene 2 argumentos, y se escribe =DIAS(01/01/2019) con un solo argumento.

Función Excel mensaje de error de pocos argumentos
 
  • NÚMERO DE PARÉNTESIS

Al insertar funciones anidadas, cada paréntesis de apertura necesita uno de cierre.

Por lo general Excel muestra mensaje y corrige el error.

En el ejemplo se escribe la función como =SI( Y(A1=0 ; A2=1; "Bien" ;"Mal") en lugar de =SI(Y(A1=0;A2=1);"Bien";"Mal").

Función Excel mensaje de error en paréntesis
 
  • SÍMBOLO PARA LOS ARGUMENTOS

Según el idioma empleado el símbolo es diferente.

Para separar los argumentos de una función en español se utiliza el punto y coma (;) y en inglés la coma (,).

En el ejemplo, en español se inserta la función =SI( A1>100; "Bien"; "Mal") y la expresión =SI(A1>100,"Bien","Mal") muestra error al ser en inglés.

Función Excel con mensaje de problema en fórmula
 
  • VÍNCULOS ERRÓNEOS

Al abrir un libro que contiene referencias a otras hojas o libros Excel nos permite que se actualice las referencias o no mediante una barra emergente.

Si el libro de referencia se borra o cambia el nombre el vinculo no se actualizará.

En el ejemplo se incluye un vínculo entre libros con la expresión: ='C:\Users\ a\ Desktop\ [libro1.xlsx] Hoja4' !$A$1

Hoja Excel con mensaje de advertencia

Para deshabilitar el mensaje de inicio:

  1. Ir a: Cinta de opciones / Pestaña: Archivo / Opciones.

  2. Ir a: Avanzadas / General / Desactivar: Consultar al actualizar vínculos automáticos.

 
  • REFERENCIA A DATOS ELIMINADOS

En ocasiones al borrar una celda con fórmula, una columna o una hoja el resultado muestra el error #¡REF!

También se produce al copiar o cortar el contenido de una celda, deseamos pegar el valor y no la fórmula subyacente que se muestra en la barra de fórmulas.

En el ejemplo la fórmula esta en la columna B con referencia a valores de la columna A; al cortar u eliminar la columna A, se muestra el error.

Fórmula Excel con error #¡REF!

- Ampliar información: El error #¡REF!.

 
  • TEXTO CON COMILLAS

Algunas funciones requieren insertar los argumentos de texto con comillas, mientras que los números y fechas no lo requieren.

En español se utilizan las dobles comillas con apertura y cierre (") mientras que en inglés se utiliza la comilla simple (').

En el ejemplo de manera correcta se escribe: =SI( A1="España" ;"Venta" ;5)donde el texto va entre dobles comillas y los números sin ellas.

Función SI con texto entre dobles comillas
 
  • NOMBRE DE LA FUNCIÓN

Cuando escribimos el nombre de la función mal, por ejemplo, SUMAR en lugar de SUMA, mostrará el error #¿NOMBRE?, que hace referencia a un nombre de función, de celda o rango.

Función Excel con error #¡NOMBRE?
 
  • DIVIDIR ENTRE CERO

Al dividir una celda por otra que contiene cero (0) o ningún valor, aparecerá el error #¡DIV/0!.

En el ejemplo, se inserta la función =A1/A2, donde A2 es 0.

Fórmula Excel con error #¡DIV/0!

Para evitar este error, puede tener acceso a ella directamente y comprobar la existencia del denominador =SI(A2;A1/A2;0).

- Consultar:

El error #¡DIV/0!

 

Nivel de dificultad: Básico Excel Básico

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.