Te mostramos todos los métodos para restar horas en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Seguro que habrás tenido problemas, por ello te mostramos todos los métodos para restar horas en Excel.

En la celda A2 disponemos de la hora de entrada y en la celda B2 la hora de salida.

  • MÉTODO 1
  1. Ir a: Celda C2 / Escribir:

    =A2-B2
  2. Mostrará ########## al no poder representar Excel la resta de horas.

  • MÉTODO 2
  1. Ir a: Celda C3 / Escribir:

    =-1*(A2-B2)
  2. Mostrará 12:30 como la diferencia horaria.

  • MÉTODO 3
  1. Ir a: Celda C4 / Escribir:

    =SI(B2>A2;-1*(A2-B2);A2-B2)
  2. Mostrará 12:30 como la diferencia horaria.

  • MÉTODO 4
  1. Ir a: Celda C5 / Escribir:

    =SI(A2>B2;A2-B2;B2-A2)
  2. Mostrará 12:30 como la diferencia horaria.

  • MÉTODO 5
  1. Ir a: Celda C6 / Escribir:

    =TEXTO(MAX(A2:B2)-MIN(A2:B2);"H::MM")
  2. Mostrará 12:30 como la diferencia horaria.

  • MÉTODO 6
  1. Ir a: Celda C7 / Escribir:

    =TEXTO(MAX(A2:B2)-MIN(A2:B2);"-H::MM")
  2. Mostrará -12:30 como la diferencia horaria (igual al anterior pero con signo menos).

  • MÉTODO 7
  1. Ir a: Celda C8 / Escribir:

    =TEXTO(ABS(A2-B2);"hh:mm")
  2. Mostrará 12:30 como la diferencia horaria.

  • MÉTODO 8
  1. Ir a: Celda C9 / Escribir:

    =SI(A2-B2<0;"-"&TEXTO(ABS(A2-B2);"hh: mm");A2-B2)
  2. Mostrará -12:30 como la diferencia horaria (igual al anterior pero con signo menos).

  • MÉTODO 9
  1. Ir a: Celda C10 / Escribir:

    =SI(A2<B2;TEXTO(B2-A2;"hh:mm");TEXTO(A2-B2;"hh:mm"))
  2. Mostrará 12:30 como la diferencia horaria.

  • MÉTODO 10
  1. Ir a: Celda C11 / Escribir:

    =SI(A2<B2;"-"&TEXTO(B2-A2;"hh:mm");TEXTO(A2-B2;"hh:mm"))
  2. Mostrará -12:30 como la diferencia horaria (igual al anterior pero con signo menos).

  • MÉTODO 11
  1. Ir a: Celda C12 / Escribir:

    =SI(B10< A10;"-"&TEXTO(A10-B10;"DD hh:mm");TEXTO(B10-A10;"DD hh:mm"))
  2. Mostrará -01 01:00 como los días (-01) y horas:minutos (01:00) como la diferencia horaria.

  • MÉTODO 12

Aplicamos sistema de fecha basado en 1904 (Compatibilidad Lotus).

  1. Ir a: Cinta de opciones / Pestaña: Archivo / Opciones. Mostrará ventana de opciones Excel.

    Ventana de opciones de Excel
  2. Pulsar el grupo: Avanzadas / Sección: Al calcular este libro / Activar la casilla: Usar sistema de fechas 1904.

  3. Ir a: Celda C2 / verificar como muestra 12:30 en lugar de ########.

Nivel de dificultad: Básico Excel Básico

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.