Sumar valores positivos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Disponemos de un rango de celdas con valores numéricos positivos y negativos, deseamos sumar valores positivos en Excel únicamente.

Sumar valores positivos en Excel
En la columna A (rango A2:A9) disponemos de los valores deseamos evaluar.
 AB
1Valor 
220 
3-10 
4-5 
510 
630 
7-10 
8-5 
912 

Podemos aplicar dos métodos para sumar valores positivos:

– Función SUMAR.SI.

– Función SUMA y SI como fórmula matricial.

  • FUNCIÓN SUMAR.SI

  1. Ir a: Celda D1 / Escribir:

    =SUMAR.SI(A2:A9;">0";A2:A9)

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Matemáticas y trigonométricas / SUMAR.SI.

  2. Mostrará 72 como la suma de los valores positivos.

Sumar valores positivos: Celda D1 con fórmula =SUMAR.SI(A1:A9;">0";A1:A9)
  • FÓRMULA MATRICIAL

  1. Ir a: Celda D2 / Escribir:

    =SUMA(SI(A1:A9>0;A1:A9;0))

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Matemáticas y trigonométricas / SUMA.

  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(SI(A1:A9>0;A1:A9;0))}.

  3. Mostrará 72 como la suma de los valores positivos.

Sumar valores positivos en Excel: Celda D1 con fórmula matricial {=SUMA(SI(A1:A9>0;A1:A9;0))}

Así podemos sumar valores positivos en Excel.

Nivel de dificultad: Básico Excel Básico

10 comentarios en “Sumar valores positivos en Excel

  • Muy buen post, pero tengo una duda….

    Si quisieras contar los valores positivos con la funcion subtotales, de que forma seria la sintaxis de la formula

  • Buenas noches si lo que deseo es contar y no sumar como lo puedo hacer? es decir tengo estos numeros (1,5,8,4) y los cuento son 4 numeros en total.

    Necesito hacerlo con los positivos y negativos por separado

    Sera que me puedes ayudar?

    Gracias

  • Si necesito sumar sólo los valores positivos de las celdas que estén de un “X” color específico como lo puedo hacer?

  • Si en la Columna de la cual se está aplicando la fórmula de el valor sumar.si contara con subtotales…y quiero obtener suma de valores positivos y negativos Se podría aplicar la misma fórmula? … O acumulará los valores subtotales también??

  • No puedo encontrar una formula acorde,
    tengo que sumar los valores perteneciente a una matriz.
    uso la formula sumar.si(c2:c28;”A2″;D2:D28), me busca todo los valores iguales a “A2″ que se encuentran en C2:C28 y me toma los valores de D2:D28, hasta ahi la formula esta bien, pero necesito que me sume solo aquellos valores de D2:D28 que son positivos (dentro de esta columna tengo positivos y negativos).

    Si uso sumar si conjunto(c2:c28;d2:d28;”A2″;d2:d28;”>0″), me da #¡VALOR!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *