Sumar valores positivos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Disponemos de un rango de celdas con valores numéricos positivos y negativos, deseamos sumar valores positivos en Excel únicamente.

Sumar valores positivos en Excel
En la columna A (rango A2:A9) disponemos de los valores deseamos evaluar.
 AB
1Valor 
220 
3-10 
4-5 
510 
630 
7-10 
8-5 
912 

Podemos aplicar dos métodos para sumar valores positivos:

– Función SUMAR.SI.

– Función SUMA y SI como fórmula matricial.

  • FUNCIÓN SUMAR.SI

  1. Ir a: Celda D1 / Escribir:

    =SUMAR.SI(A2:A9;">0";A2:A9)

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Matemáticas y trigonométricas / SUMAR.SI.

  2. Mostrará 72 como la suma de los valores positivos.

Sumar valores positivos: Celda D1 con fórmula =SUMAR.SI(A1:A9;">0";A1:A9)
  • FÓRMULA MATRICIAL

  1. Ir a: Celda D2 / Escribir:

    =SUMA(SI(A1:A9>0;A1:A9;0))

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Matemáticas y trigonométricas / SUMA.

  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(SI(A1:A9>0;A1:A9;0))}.

  3. Mostrará 72 como la suma de los valores positivos.

Sumar valores positivos en Excel: Celda D1 con fórmula matricial {=SUMA(SI(A1:A9>0;A1:A9;0))}

Así podemos sumar valores positivos en Excel.

Nivel de dificultad: Básico Excel Básico

4 comentarios en “Sumar valores positivos en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *