Sumar por filtro comodín en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Podemos sumar valores filtrados por una condición mediante funciones (Sumar por filtro en Excel).

Sumar por filtro comodín en Excel

- Podemos crear consultas personalizadas mediante el uso del comodín asterisco (*), que sustituye su posición por cualquier palabra o palabras.

- Podemos crear consultas personalizadas mediante el uso del comodín carácter único (?), que sustituye su posición por un único carácter.

En la columna A se muestra el nombre del cliente y en la columna B el valor a sumar por filtro según el criterio deseado.
 AB
1NombreValor
2Jose100
3José Luis150
4Juan José100
5Rosa100
6Emilio100
7Emilia150
8Emiliano125
9José200
10Juan130

Emplearemos la siguiente función:

- Función SUMAR.SI. Suma los valores en un rango que cumple los criterios especificados.

Función =SUMAR.SI(rango; criterio; rango_suma)
 
  • ES IGUAL
  1. Ir a: Celda E1 / Escribir: José

  2. Ir a: Celda F1 / Escribir:

    =SUMAR.SI(A2:A9;E1;B2:B9)

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Matemáticas y trigonométricas / SUMAR.SI.

  3. Mostrará 200 como la suma de un resultado (José con acento).

Sumar por filtro en Excel: Celda F1 con fórmula =SUMAR.SI(A2:A9;E1;B2:B9)
 
  • COMIENZA POR
  1. Ir a: Celda E2 / Escribir: José*

  2. Ir a: Celda F2 / Escribir:

    =SUMAR.SI(A2:A9;E2;B2:B9)
  3. Mostrará 350 como la suma de los nombres que comienzan por José (con acento), José y José Luis.

 
  • TERMINA CON
  1. Ir a: Celda E3 / Escribir: *José

  2. Ir a: Celda F3 / Escribir:

    =SUMAR.SI(A2:A9;E3;B2:B9)
  3. Mostrará 300 como la suma de los nombres que terminan con José (con acento), Juan José y José.

 
  • CONTIENE
  1. Ir a: Celda E4 / Escribir: *Jos*

  2. Ir a: Celda F4 / Escribir:

    =SUMAR.SI(A2:A9;E4;B2:B9)
  3. Mostrará 550 como la suma de los nombres que contienen José con acento y sin él. Jose, José Luis, Juan José y José.

Sumar por filtro en Excel: Rango F1:F4 con diferentes sumas de filtros
 
  • OTROS CASOS (SUMA POR FILTRO)
FiltroEscribir (ejemplo)ResultadoDescripción
Es igualJose100No muestra José con acento.
Pepe0Al no existir nombre con el literal.
Comienza por:Jos*450Muestra los nombres que comienzan por Jos (Jose, José Luis y José).
Jose*100Muestra el nombre Jose sin acento.
José*350Muestra los nombres que comienzan por José con acento (José Luis y José).
Jose *0Muestra 0 al no existir ningún nombre que comienza por Jose sin acento y que sea compuesto.
José *150Muestra los nombres que comienzan por José con acento y sea compuesto (José Luis).
Emili*375Muestra los nombres que comienzan por Emili (Emilio, Emilia y Emiliano).
Termina con:*o225Muestra los nombres que terminan con la letra o (Emilio y Emiliano).
*no125Muestra los nombres que terminan en no (Emiliano).
*José300Muestra los nombres que terminan en José (Juan José y José).
* José100Muestra los nombres que terminan en espacio y José (Juan José).
Contiene:*Jos*550Muestra los nombres que contienen Jos (José con acento y sin él).
*Jose*100Muestra los nombres que contienen Jose sin acento (Jose).
Emili?250Muestra los nombres que contienen y un carácter más (Emilio y Emilia).
Emili???125Muestra los nombres que contienen y tres caracteres más (Emiliano).

Así podemos sumar por filtro en Excel los valores en la hoja.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.