Sumar las filas pares o impares en Excel

Compatibilidad: Excel 365 2021 2019 2016

Al importar datos, en ocasiones necesitamos sumar las filas pares o impares en Excel.

Sumar las filas pares o impares en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMA. Suma todos los números del rango indicado.

  • Función RESIDUO. Devuelve el residuo después de dividir un número por un divisor.

  • Función FILA. Devuelve el número de fila de la referencia.

En el rango A2:A10 disponemos de los valores que deseamos sumar según la fila sea para o impar.

  • SUMAR FILAS PARES

  1. Ir a: Celda D1 / Escribir:

    =SUMA((RESIDUO(FILA(A2:A10);2)=0)*A2:A10)
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Ctrl y mantenerla pulsada / Pulsar la tecla Mayús y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA((RESIDUO(FILA(A2:A10);2)=0)*A2:A10)}.

  3. Verificar como muestra 25. Como la suma de las filas 2, 4, 6, 8 y 10.

Celda D1 mostrando 25 como la suma de las filas pares
  • SUMAR FILAS IMPARES

  1. Ir a: Celda D2 / Escribir:

    =SUMA((RESIDUO(FILA(A2:A10);2)=1)*A2:A10)
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Ctrl y mantenerla pulsada / Pulsar la tecla Mayús y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA((RESIDUO(FILA(A2:A10);2)=1)*A2:A10)}.

  3. Verificar como muestra 20. Como la suma de las filas 3, 5, 7 y 9.

Celda D2 mostrando 20 como la suma de las filas impares
Nivel de dificultad: Avanzado Excel Avanzado

3 comentarios en “Sumar las filas pares o impares en Excel

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.