Sumar fechas por meses en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En nuestros informes es habitual tener que sumar fechas por meses en Excel.

Sumar fechas por meses en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMAR.SI.CONJUNTO. Aplica criterios a las celdas en varios rangos y cuenta cuántas veces se cumplen dichos criterios.

  • Función FIN.MES. Devuelve el número correspondiente al último día del mes, que es un número determinado de meses anterior o posterior a la fecha inicial.

  • Función SUMAPRODUCTO. Devuelve la suma de los productos de los componentes de la matriz correspondiente.

  • Función MES. Convierte un número en el mes correspondiente.

En la columna A disponemos de las fechas y en la columna B el importe a sumar.

 AB
1Fecha Importe
201/01/20171.500
302/01/20173.400
403/01/20173.500
501/05/20164.570
605/01/200012.200
706/03/20179.750
  • SUMA DEL MES POR AÑO

  1. Ir a celda D2 / Escribir:

    01/01/2017

    El mes se escribe en formato dd/mm/aaaa, correspondiente a enero 2017.

  2. Ir a celda E2 / Escribir:

    =SUMAR.SI.CONJUNTO(B2:B7;A2:A7;”>=”&D2;A2:A7;”<="&FIN.MES(D2;0))
  3. Verificar como muestra 8.400 como la suma de enero de 2017 (fila 2, 3 y 4).

  • SUMA DEL MES IGNORANDO AÑO

  1. Ir a celda D3 / Escribir:

    enero
  2. Ir a celda E3 / Escribir:

    =SUMAPRODUCTO((MES(A2:A7)=1)*B2:B7)
  3. Verificar como muestra 20.600 como la suma de enero de todos los años (fila 2, 3, 4 y 6).

     

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *