Sumar fechas por meses en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En nuestros informes es habitual tener que sumar fechas por meses en Excel.

Sumar fechas por meses en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMAR.SI.CONJUNTO. Aplica criterios a las celdas en varios rangos y cuenta cuántas veces se cumplen dichos criterios.
  • Función FIN.MES. Devuelve el número correspondiente al último día del mes, que es un número determinado de meses anterior o posterior a la fecha inicial.
  • Función SUMAPRODUCTO. Devuelve la suma de los productos de los componentes de la matriz correspondiente.
  • Función MES. Convierte un número en el mes correspondiente.

En la columna A disponemos de las fechas y en la columna B el importe a sumar.

AB
1Fecha Importe
201/01/20171.500
302/01/20173.400
403/01/20173.500
501/05/20164.570
605/01/200012.200
706/03/20179.750
  • SUMA DEL MES POR AÑO
  1. Ir a celda D2 / Escribir:

    01/01/2017

    El mes se escribe en formato dd/mm/aaaa, correspondiente a enero 2017.

  2. Ir a celda E2 / Escribir:

    =SUMAR.SI.CONJUNTO(B2:B7;A2:A7;">="&D2;A2:A7;"<="&FIN.MES(D2;0))
  3. Verificar como muestra 8.400 como la suma de enero de 2017 (fila 2, 3 y 4).

  • SUMA DEL MES IGNORANDO AÑO
  1. Ir a celda D3 / Escribir:

    enero
  2. Ir a celda E3 / Escribir:

    =SUMAPRODUCTO((MES(A2:A7)=1)*B2:B7)
  3. Verificar como muestra 20.600 como la suma de enero de todos los años (fila 2, 3, 4 y 6).

Nivel de dificultad: Avanzado Excel Avanzado

7 comentarios en “Sumar fechas por meses en Excel

  • Hola, espero les este yendo de lo mejor, tengo una duda
    Tengo una base de datos con los siguientes campos (Columnas):
    Código, Descripción, y Cantidad
    A estas columnas quiero agregar las siguientes columnas
    Enero (Entradas), Enero (Salidas)........hasta diciembre

    En otra Hoja de Excel tengo registrados los movimientos de entradas y salida, es decir
    Entradas y cuenta con las siguientes columnas
    Hoja, Código, Fecha, Cantidad
    En la misma hoja también tengo las Salidas y tiene las mismas columna.

    Actualmente el archivo lo estoy llenando con una hoja de datos y otra de movimientos por mes (es decir una hoja para enero... diciembre), utilizando para las columnas de cada mes la función Sumas.Si

    Ahora mi pregunta es
    Existe alguna manera que pueda sumar la cantidad de movimiento de acuerdo al producto por mes,
    Es decir:
    En vez de generar una hoja para cada mes, solo alimentar una sola hoja con los movimientos de entrada y salida con su respectiva fecha, y de todo este listado se pueda sumar unicamente las cantidad de entrada de un producto en determinado periodo
    Ejemplo
    Codigo Fecha Cantidad
    ID0001 01/01/2020 10
    ID0001 15/01/2020 12
    ID0001 30/01/2020 3
    ID0001 12/02/2020 7
    ID0001 27//02/2020 15

    Quiero que en mi columna de enero únicamente me sume lo que pertenece a Enero es decir 25, obviamente hay mas códigos, son 50 códigos, es una tabla pequeña,

    Ojala Me puedan ayudar!
    Gracias!
    =)

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.