Simular comodín en función SI de Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Si buscamos un elemento específico y no recordamos exactamente cómo se escribe, podemos emplear un carácter comodín en una consulta, no todas las funciones admiten el uso del comodín, para ello te proponemos simular comodín en función SI de Excel.

Los caracteres comodín son caracteres especiales que pueden representar caracteres desconocidos en un valor de texto y son prácticos para encontrar varios elementos con datos similares pero no idénticos. Los caracteres comodín también permiten obtener datos basados en la coincidencia de un patrón específico.

Simular comodín en función SI de Excel

En la columna A disponemos de diferentes nombres y deseamos comprobar si se cumple una condición. El comodín de asterisco no es reconocido en todas las funciones de Excel. En nuestro caso la función SI no reconoce el comodín por lo que tenemos que recurrir a otras funciones anidándolas para simularlo.

 ABCD
1José   
2Juan José   
3José Antonio   
4Josefina   
5Luis Antonio   
  • COMIENZA POR: JOS

Deseamos evaluar si el nombre comienza por "Jos", mostrando "Bien" si cumple la condición y "Mal" si no la cumple.

  1. Ir a: Celda B1 / Escribir:

    =SI(IZQUIERDA(A1;3)="Jos";"Bien";"Mal")

    IZQUIERDA(A1;3) devuelve 3 caracteres de la celda A1 desde la izquierda.

  2. Copiar la celda B1.

  3. Pegar como fórmula en el rango B2:B5. Para evaluar el rango A2:A5.

  4. Verificar como muestra 3 resultados como Bien al tener 3 valores que comienzan por "Jos": José, José Antonio y Josefina.

Hoja Excel con celda B1 mostrando BIEN al cumplirse la condición de la función al comenzar por JOS
  • FINALIZA POR: JOSÉ

Deseamos evaluar si el nombre finaliza por "José", mostrando "Bien" si cumple la condición y "Mal" si no la cumple.

  1. Ir a: Celda C1 / Escribir:

    =SI(DERECHA(A1;4)="José";"Bien";"Mal")

    DERECHA(A1;4) devuelve 4 caracteres de la celda A1 desde la derecha.

  2. Copiar la celda C1.

  3. Pegar como fórmula en el rango C2:C5. Para evaluar el rango A2:A5.

  4. Verificar como muestra 2 resultados como Bien al tener 2 valores que finalizan por "José": José, Juan José .

Hoja Excel con celda C1 mostrando BIEN al cumplirse la condición de la función al finalizar por JOSÉ
  • COMIENZA POR: JOSÉ Y FINALIZA POR: NIO

Deseamos evaluar si el nombre comienza por "José" y finaliza por "nio", mostrando "Bien" si cumple la condición y "Mal" si no la cumple.

  1. Ir a: Celda D1 / Escribir:

    =SI(Y(IZQUIERDA(A1;4)="José";DERECHA(A1;3)="nio");"Bien";"Mal")

    IZQUIERDA(A1;4) devuelve 4 caracteres de la celda A1 desde la izquierda y DERECHA(A1;3) devuelve 3 caracteres de la celda A1 desde la derecha.

  2. Copiar la celda D1.

  3. Pegar como fórmula en el rango D2:D5. Para evaluar el rango A2:A5.

  4. Verificar como muestra 1 resultado como Bien al tener 1 valores que comienza por José y finaliza por "nio": José Antonio.

Hoja Excel con celda D1 mostrando MAL al no cumplirse la condición de la función al comenzar por JOSÉ y finalizar por NIO
Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “Simular comodín en función SI de Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *