Realizar rifas y sorteos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Si necesitas realizar rifas y sorteos en Excel, te proponemos utilizar funciones o macros.

Realizar rifas y sorteos en Excel

Disponemos del siguiente rango de datos donde se muestran los participantes y su ciudad.

 AB
1ParticipantesCiudad
2ANAEspaña
3LUISColombia
4MARÍAEspaña
5GEMAPerú
6ANTONIOMéxico
7ROSAColombia
8JAVIERChile
9EVAArgentina
10ÁNDRESPerú
  1. Ir a: Hoja2. Hoja donde mostraremos el ganador del sorteo.

  2. Ir a: Celda B2 / Escribir:

    =INDICE(Hoja1!A2:A10;ALEATORIO.ENTRE(1;CONTARA(Hoja1!A2:A10)))

    Mostrará el nombre generado aleatoriamente del ganador.

  3. Ir a: Celda B3 / Escribir:

    =BUSCARV(B2;Hoja1!A2:B10;2;FALSO)

    Mostrará la ciudad del ganador.

  4. Al pulsar F9 o al realizar cualquier cambio en la hoja se actualizará el valor.

Celda B2 mostrando el nombre del ganador del sorteo
  • SORTEO CON MACROS

La macro insertará las funciones en las celdas B2 y B3, mostrando unas líneas horizontales que simula la carga, antes de mostrar el nombre.

  1. Pulsar la tecla Alt y mantener pulsada / Pulsar la tecla F11. Mostrará el editor de Visual Basic.

  2. Ir a: Barra de Menú / Insertar / Módulo. Mostrará la ventana del módulo donde escribimos la macro.

  3. Escribir el código de la macro Sorteo:

    Sub Sorteo()

    Application.Wait (Now + TimeValue(“00:00:01”))
    Range(“B2”).FormulaLocal = “¯”

    Application.Wait (Now + TimeValue(“00:00:01”))
    Range(“B2”).FormulaLocal = “-“

    Application.Wait (Now + TimeValue(“00:00:01”))
    Range(“B2”).FormulaLocal = “_”

    Application.Wait (Now + TimeValue(“00:00:01”))
    Range(“B1”).FormulaLocal = “¡El GANADOR es!”

    Application.Wait (Now + TimeValue(“00:00:01”))
    Range(“B2”).FormulaLocal = “=INDICE (Hoja1!A2:A10; ALEATORIO.ENTRE (1; CONTARA(Hoja1!A2:A10 )))”
    Range(“B3”).FormulaLocal = “=BUSCARV(B2; Hoja1!A2:B10; 2; FALSO)”

    End Sub

    Application.Wait (Now + TimeValue(“00:00:01”)). Aplicará un retardo de 1 segundo en mostrar el valor.

    FormulaLocal. Inserta la fórmula en la celda.

  4. Escribir el código de la macro para borrar el ganador:

    Sub Borrar()

    Range(“B1:B3”).ClearContents

    End Sub

  5. Insertar un botón para asignarlo a la macro Sorteo. Ejecuta la macro mostrando el nombre y ciudad del ganador.

  6. Insertar un botón para asignarlo a la macro Borrar. Ejecuta la macro borrando el nombre y la ciudad mostrada.

  7. Aplicar formato a las celdas y a la fuente.

Hoja de Excel con simular de rifas y sorteos

  

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *