Porcentaje de dos valores numéricos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Necesitamos obtener el porcentaje de dos valores numéricos en Excel para mostrar la diferencia que representan.

Porcentaje de dos valores numéricos en Excel

Emplearemos las siguientes funciones, anidándolas:

  • Función SI.ERROR. Evalúa la expresión y se produce un error muestra un valor.

  • Función SI. Comprueba si se cumple una condición y devuelve un valor si es VERDADERO y otro si es FALSO.

  • Función Y. Comprueba si todos los argumentos son Verdaderos, devolviendo verdadero si todos son verdaderos.

  •  

En la columna A disponemos de los países donde realizamos ventas, la columna B, muestra las ventas en el año 2016 y la columna C, muestra las ventas en el año 2017.

 ABCD
120162017Resultado
2España10.000,0010.000,00
3Mexico6.000,0012.000,00
4Colombia16.000,008.000,00
5Perú-2.000,002.000,00
6Chile2.000,00-2.000,00
  1. Ir a: Celda D2 / Escribir:

    =SI.ERROR(SI(Y(B3<0;C3<0;C3>B3);-((C3-B3)/B3);
    SI(Y(B3<0;C3<0;C3<0;C3>0);-((C3-B3)/B3);((C3-B3)/B3))));0)
  2. FORMATO PORCENTAJE. Seleccionar la celda D2 / Botón derecho del ratón (menú contextual) / Formato de celdas. Mostrará la ventana de formato.

    Ventana de formato de celdas / Número / Categoría: Porcentaje
  3. Ir a Pestaña: Número / Categoría: Porcentaje / Posición decimales: 2.

  4. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato de porcentaje.

  5. Verificar como muestra 0,00%. Al ser el valor de 2016 (B2) igual al de 2017 (C2).

    porcentajevalores01
  6.  

  7. Copiar la celda D2. Celda que incluye la fórmula deseada.

  8. Seleccionar el rango D3:D6 / Pegar como fórmula. Mostrará el porcentaje en el rango.

  

Nivel de dificultad: Avanzado Excel Avanzado

 

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *