Plantilla control de horas de los trabajadores en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Para la gestión de nuestra empresa necesitamos una plantilla control de horas de los trabajadores en Excel.

Plantilla control de horas de los trabajadores en Excel

En España el Real Decreto-ley 8/2019, de 8 de marzo, de medidas urgentes de protección social y de lucha contra la precariedad laboral en la jornada de trabajo, indica "el deber de la empresa de garantizar el registro diario de jornada, que deberá incluir el horario concreto de inicio y finalización de la jornada de trabajo de cada persona trabajadora, sin perjuicio de la flexibilidad horaria existente".

La empresa está obligada a implantar un sistema de control que registre diariamente el horario que ha cumplido un trabajador, independientemente de su jornada y de si la cumple en el lugar de trabajo o por teletrabajo. Se exigen las siguientes consideraciones:

- Registro diario y permanentemente actualizado.
- También se deben registrar los descansos, las vacaciones y el horario de comida.
- Se debe emplear un método fiable y no manipulable, ya sea en papel o digital.
- Si el registro es en papel, debe llevar la firma del trabajador.
- Debe ser un método que se pueda comprobar en el lugar de trabajo por parte de la Inspección de Trabajo.
- Se ha de mantener informado al trabajador de las horas realizadas. Los datos deben almacenarse durante cuatro años.

 
  • ORIGEN DE DATOS

En la hoja Datos disponemos:

  1. Columna A. Nombre del trabajador.

  2. Columna B. Número de horas semanales de trabajo.

  3. Columna C. Número de horas de descanso semanales.

Columna A, B y C con origen de datos
 
  • RÓTULOS Y ENCABEZADOS
  1. Ir a: Celda Q3 / Escribir: Número de semana.

  2. Ir a: Celda D5 / Escribir: H. Entrada.

  3. Ir a: Celda E5 / Escribir: H. Salida.

  4. Seleccionar las celdas D5:E5 / Pegar en el rango F5:M5.

  5. Ir a: Celda N5 / Escribir: Horas trabajo semana.

  6. Ir a: Celda O5 / Escribir: Horas descanso.

  7. Ir a: Celda P5 / Escribir: Total horas.

  8. Ir a: Celda Q5 / Escribir: Horas trabajadas.

  9. Ir a: Celda R5 / Escribir: Horas extras.

Hoja Excel con los rótulos y encabezados Excel
 
  • FECHAS
  1. COMBINAR CELDAS. Seleccionar las celdas D3:E3 / Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Alineación / Combinar y centrar. Combinará las 2 celdas.

  2. Seleccionar las celdas D3:E3 / Copiar / Pegar en el rango D3:M4.

  3. Ir a: Celda F3 / Escribir:

    =D3+1
  4. Copiar la celda F3 / Pegar en el rango H3:L3

  5. Ir a: Celda D4 / Escribir:

    =TEXTO(D3;"dddd")
  6. Copiar la celda D4 / Pegar en el rango F4:L4

  7. Ir a: Celda D3 / Escribir: 22/04/2019. O la fecha inicial de la semana.

  8. Ir a: Celda R3 / Escribir:

    =NUM.DE.SEMANA(D3;1)
  9. Como el número de semana del año.

Hoja Excel con los datos de fechas
 
  • TRABAJADORES
  1. VALIDACIÓN DE DATOS. Seleccionar el rango C6:C10 Permite seleccionar el nombre del trabajador.

  2. Ir a: cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos. Mostrará ventana de validación.

  3. Ir a: Permitir / Seleccionar: Lista.

  4. Ir a: Origen / Escribir: =Datos!$A:$A.

  5. Pulsar el botón Aceptar. Cierra la ventana y aplica la validación.

Hoja Excel con los datos de trabajadores
 
  • HORAS TRABAJO SEMANA
  1. VALIDACIÓN DE DATOS. Seleccionar el rango N6:N10 Permite seleccionar las horas de trabajo.

  2. Ir a: cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos. Mostrará ventana de validación.

  3. Ir a: Permitir / Seleccionar: Lista.

  4. Ir a: Origen / Escribir: =Datos!$B:$B.

  5. Pulsar el botón Aceptar. Cierra la ventana y aplica la validación.

Hoja Excel con los datos de horas de trabajo semanal
 
  • HORAS DESCANSO SEMANA
  1. VALIDACIÓN DE DATOS. Seleccionar el rango O6:O10 Permite seleccionar las horas semanales de descanso.

  2. Ir a: cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos. Mostrará ventana de validación.

  3. Ir a: Permitir / Seleccionar: Lista.

  4. Ir a: Origen / Escribir: =Datos!$O:$O.

  5. Pulsar el botón Aceptar. Cierra la ventana y aplica la validación.

Hoja Excel con los datos de horas de descanso semanal
 
  • TOTAL HORAS
  1. Ir a: Celda P6 / Escribir:

    =(E6-D6)+(G6-F6)+(I6-H6)+(K6-J6)+(M6-L6)
  2. Copiar la celda P6 / Pegar en el rango: P7:P10.

Hoja Excel con el total de horas
 
  • HORAS TRABAJADAS
  1. Ir a: Celda Q6 / Escribir:

    =((E6-D6)+(G6-F6)+(I6-H6)+(K6-J6)+(M6-L6))-O6
  2. Copiar la celda Q6 / Pegar en el rango: Q7:Q10.

Hoja Excel con las horas trabajadas
 
  • HORAS EXTRAS
  1. Ir a: Celda R6 / Escribir:

    =P6-N6-O6
  2. Copiar la celda R6 / Pegar en el rango: R7:R10.

Hoja Excel con las horas extras
 
  • TOTAL
  1. HORAS TRABAJO SEMANA. Ir a: Celda N12 / Escribir:

    =SUMA(N6:N10)
  2. HORAS DESCANSO. Ir a: Celda O12 / Escribir:

    =SUMA(O6:O10)
  3. TOTAL HORAS. Ir a: Celda P12 / Escribir:

    =SUMA(P6:P10)
  4. HORAS TRABAJADAS. Ir a: Celda Q12 / Escribir:

    =SUMA(Q6:Q10)
  5. HORAS EXTRAS. Ir a: Celda R12 / Escribir:

    =SUMA(R6:R10)
Hoja Excel con las horas totales
 
  • FORMATO CONDICIONAL: HORAS EXTRAS Y TRABAJADOR
  1. HORAS EXTRAS. Seleccionar el rango: R6:R10. Rango donde aplicar el formato condicional para indicar que tiene horas extras.

  2. Ir a: Cinta de Opciones / Pestaña: Inicio / Grupo: Estilos / Formato condicional / Nueva regla. Mostrará la ventana de nueva regla de formato.

    Ventana de editar regla de formato condicional
  3. Ir a: Seleccionar un tipo de regla / Clic sobre: Utilice una fórmula que determine las celdas para aplicar formato.

  4. Ir a: Dar formato a los valores donde esta fórmula sea verdadera / Escribir:

    =R6>0,001
  5. Pulsar el botón Formato / Aplicar el color de relleno deseado.

  6. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato de celda.

  7. Pulsar el botón Aceptar. Cierra la ventana del administrador de reglas y aplica el formato condicional.

  8. TRABAJADOR. Seleccionar el rango: C6:C10. Rango donde aplicar el formato condicional para indicar el trabajador que tiene horas extras.

  9. Ir a: Cinta de Opciones / Pestaña: Inicio / Grupo: Estilos / Formato condicional / Nueva regla. Mostrará la ventana de nueva regla de formato.

  10. Ir a: Seleccionar un tipo de regla / Clic sobre: Utilice una fórmula que determine las celdas para aplicar formato.

  11. Ir a: Dar formato a los valores donde esta fórmula sea verdadera / Escribir:

    =R6>0,001
  12. Pulsar el botón Formato / Aplicar el color de relleno deseado.

  13. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato de celda.

  14. Pulsar el botón Aceptar. Cierra la ventana del administrador de reglas y aplica el formato condicional.

 
  • FORMATO PLANTILLA
  1. Aplicar formato a celdas, texto, bordes, etc.

  2. Añade una columna para la firma e incluye tus necesidades.

  3. Insertar la hora de entrada y de salida de cada trabajador, las horas de trabajo y las horas de descanso

Hoja Excel con Plantilla control de horas de los trabajadores
Nivel de dificultad: Básico Excel Básico

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.