Ordenar texto mediante funciones en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En ocasiones nos interesa ordenar texto mediante funciones en Excel de manera automática y ascendente de la A a la Z.

Necesitamos añadir nuevos datos en un rango y que se ordenen de manera automática, manteniéndose listo para imprimir o analizar los datos.

Ordenar texto mediante funciones en Excel

Disponemos de los siguientes datos insertados en el rango A1:C8 y deseamos se muestren en otro rango u otra hoja de manera ordenada por nombres, mediante funciones en Excel.

 ABC
1       NombreProvincia
2 Ana PérezMadrid
3 Ana GómezSevilla
4Luis CamposMadrid
5Fernando GilToledo
6María SánchezPontevedra
7Zacarías RuizMadrid
8Pedro SecoMálaga
9Verónica GarcíaOviedo
10Carlos SotoMadrid
11Francisco RamosOviedo
12Tomás SanzSegovia
13Miguel GómezToledo
14
  • NÚMERO DE ORDEN

Insertamos mediante funciones un número de orden que se actualizará según el nombre escrito y que nos servirá para relacionarlo con el rango de datos ordenado (Número de fila).

  1. Ir a: Celda A2 / Escribir:

    =CONTAR.SI($B$2:$B$14;"<="&B2)

    O también, escribir para no mostrar #N/A si el valor de la columna B está vacío.

    =SI.ERROR(CONTAR.SI($B$2:$B$14;"<="&B2);"")
  2. Copiar la celda A2 / Pegar en el rango A3:A14.

    Hoja Excel con fórmula anidada en A2, mostrando posición de fila
  3. Mostrará un número de orden para relacionarlo con el rango de datos ordenado.

  • NOMBRE ORDENADO

Insertamos BUSCARV, para buscar el número de fila (Número de orden) y nos muestre el nombre ordenado.

  1. Ir a: Celda F2 / Escribir:

    =BUSCARV(FILA()-FILA($F$1);$A$2:$B$14;2;FALSO)

    O también, escribir para no mostrar #N/A si el valor de la columna B está vacío.

    =SI.ERROR(BUSCARV(FILA()-FILA($F$1);$A$2:$B$14;2;FALSO);"")
  2. Copiar la celda F2 / Pegar en el rango F3:F14.

    Hoja Excel con fórmula anidada en F2, mostrando el nombre ordenado

     

  3. Ir a: Celda G2 / Escribir:

    =BUSCARV(F2;$B$2:$C$14;2;0)

    O también, escribir para no mostrar #N/A si el valor de la columna B está vacío.

    =SI.ERROR(BUSCARV(F2;$B$2:$C$14;2;0);"")
  4. Copiar la celda G2 / Pegar en el rango G3:G14.

    Hoja Excel con fórmula en G2, mostrando la provincia del nombre ordenado
  • COMPROBAR FUNCIONAMIENTO

  1. Ir a: Celda B14 / Escribir: Gregorio Cortes.

  2. Ir a: Celda C14 / Escribir: Madrid.

  3. Proceso de ordenar texto mediante funciones Excel
  4. Verificar como el nombre insertado Gregorio Cortes se inserta en la fila 6 al incluir la G (después de la letra F y antes de la letra L.

 

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *