Notas y Calificaciones para examen de alumnos en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Si eres profesor o maestro, seguro que te será muy útil la plantilla de Notas y Calificaciones para examen de alumnos en Excel.

La plantilla permite convertir en texto la calificación obtenida por los alumnos, de los diferentes examenes.

Notas y Calificaciones para examen de alumnos en Excel

En nuestro caso aplicamos el siguiente rango para obtener la calificación o nota, recordar que cada país aplica rangos y descripciones diferentes.

NotaRango
Matricula de Honor10
Sobresaliente9 a 9,9
Notable7 a 8,9
Bien6 a 6,9
Suficiente5 a 5,9
Insuficiente0 a 4,9

Emplearemos las siguientes funciones anidándolas:

  • Función SI.ERROR Oculta el erro en las funciones al tener la celda valor vacío.

  • Función PROMEDIO Devuelve el promedio (media aritmética) de los valores.

  • Función SI Comprueba si se cumple una condición y devuelve un valor se se cumple y otro si no se cumple.

En la columna disponemos del nombre del alumno, las columnas B a F incluye las diferentes calificaciones, la columna G obtendrá la media de las diferentes notas y en la columna H se mostrará la calificación como texto.

 ABCDEFGH
1NombreNota 1Nota 2Nota 3Nota 4Nota 5MediaNota
2        
3        
4        
5        
6        
7        
8        
  • MEDIA DE LAS NOTAS

  1. Ir a: Celda G2 / Escribir:

    =SI.ERROR(PROMEDIO(B2:F2);"")

    – SI.ERROR. Función que oculta mensajes de error #¡DIV/0! si no existen notas.
    – PROMEDIO. Función que muestra la media del rango B2:F2.

  2. Copiar la celda G2 / Pegar en el rango: G3:G8. O en el rango deseado.

  3. Insertar valores de prueba en el rango B2:F8 y verificar como aplica la media de las notas.

Hoja Excel mostrando la media de las notas
  • CALIFICACIÓN EN TEXTO

  1. Ir a: Celda H2 / Escribir:

  2. Copiar la celda H2 / Pegar en el rango: H3:H8. O en el rango deseado.

    =SI.ERROR(SI(G2="";"";SI(G2=10;"Matricula de Honor"; SI(G2>=9;"Sobresaliente"; SI(G2>=7;"Notable"; SI(G2>=6;"Bien"; SI(G2>=5;"Suficiente"; SI(G2>=0;"Insuficiente";"")))))));"")

    – SI.ERROR. Función que oculta mensajes de error #¡DIV/0! si no existen notas.
    – PROMEDIO. Función que muestra la media del rango B2:F2.

  3. Verificar como muestra las calificaciones en texto.

Hoja Excel mostrando la calificación de las notas
  • VALIDACIÓN DE NOTAS

Podemos aplicar una validación de datos que evite insertar notas no válidas, por ejemplo 21, -5, etc.

  1. Seleccionar el rango B2:G8. Rango donde escribir las notas individuales del alumno.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de la validación.

    Ventana de validación Excel para la nota
  3. Ir a: Pestaña: Configuración / Permitir: Seleccionar: Decimal / Datos: Seleccionar: Entre / Mínimo: Escribir: 0 / Máximo: Escribir: 10. Para limitar los valores válidos.

  4. Pulsar el botón Aceptar. Para cerrar la ventana y aplicar la validación.

  5. Verificar como en el rango B2:G8, cualquier valor comprendido fuera de 0 a 10 no es válido.

  • INMOVILIZAR PANELES

Al inmovilizar paneles bloqueamos el nombre del alumno por si disponemos de muchas columnas podamos mostrarle.

  1. Seleccionar la columna B. Columna sobre la que inmovilizar el panel.

  2. Ir a: Cinta de opciones / Pestaña: Vista / Grupo: Ventana / Inmovilizar / Inmovilizar paneles.

  3. Verificar como al desplazarnos las columnas a la derecha, permanece fijo el nombre del alumno.

Columna A bloqueado panel en hoja Excel
  • VALIDACIÓN NOMBRE ALUMNO

Para evitar escribir el nombre del alumno podemos aplicar una lista que permita seleccionarlo de otro origen (rango u hoja).

  1. Seleccionar el rango A2:A8. Rango donde mostrar el nombre del alumno.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de la validación.

    Ventana de validación de datos tipo lista
  3. Ir a: Pestaña: Configuración / Permitir: Seleccionar: Lista / Origen: Escribir =$O$1:$O$7.O el lugar donde se encuentran los nombres de los alumnos.

  4. Pulsar el botón Aceptar. Para cerrar la ventana y aplicar la validación.

  5. Verificar como al seleccionar la celda A2, muestra la lista para seleccionar el nombre deseado.

Celda A2 con validación lista para seleccionar el nombre del alumno Excel
Nivel de dificultad: Avanzado Excel Avanzado

4 comentarios en “Notas y Calificaciones para examen de alumnos en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *