Mostrar los datos con barra de desplazamiento (scroll) en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Cuando realizamos informes, paneles de control, etc. necesitamos mostrar los datos con barra de desplazamiento (scroll) en Excel.

Mostrar los datos con barra de desplazamiento (scroll) en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función INDICE. Devuelve un valor o referencia de la celda en la intersección de una fila y columna de un rango.

  • Función FILA. Devuelve el número de fila de una referencia.

  • Función COLUMNAS. Devuelve el número de columnas de una matriz o referencia.

 
  1. En la Hoja1 disponemos de los datos que deseamos representar.

    Origen de datos hoja1, rango A1:H7
  2. Ir a: Hoja2. Donde insertar los datos con control scroll.

  3. Ir a: Celda A2 / Escribir: España.

    =Hoja1!A2
  4. Copiar la celda A2 / Pegar en el rango A3:A7. Mostrará el encabezado de los países.

    Rango A2:A7 con encabezado de filas
  5. Ir a celda B1 / Escribir:

    =INDICE(Hoja1!$B$1:$H$7;FILA();Hoja1!$A$1+COLUMNAS(Hoja2!$B$1:B1)-1)
  6. Copiar la celda B1 / Pegar en el rango B1:D7. Para obtener los datos de los años.

Rango B1:D7 con los datos de hoja1
 
  • CONTROL: BARRA DE DESPLAZAMIENTO (SCROLL)

Mediante la barra de desplazamiento podemos descubrir el resto de columnas con datos.

  1. Mostrar la pestaña de desarrollador en la cinta de opciones (ver proceso).

  2. Ir a: Cinta de opciones / Pestaña: Desarrollador / Grupo: Controles / Insertar / Controles de formulario: Barra de desplazamiento / Clic sobre la hoja Excel. Insertará la barra de desplazamiento.

  3. Clic sobre el control / Adecuar el tamaño y la posición deseada.

    Hoja Excel con control de desplazamiento
  4. Situar el cursor del ratón sobre el control / Botón derecho del ratón / Formato de control. Mostrará la ventana del control.

    Ventana de propiedades del control Excel
  5. Ir a Pestaña: Control.

  6. Valor actual / Escribir: 1.

  7. Valor mínimo / Escribir: 1.

  8. Valor máximo / Escribir: 5.

  9. Incremento / Escribir: 1.

  10. Cambio de página / Escribir 3.

  11. Vincular con la celda / Clic sobre la celda A1 de Hoja1.

  12. Pulsar el botón Aceptar. Cierra la ventana y aplica las propiedades.

Proceso de mostrar los datos con barra de desplazamiento (scroll) en Excel
Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.