Método numérico Bisección en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

El método numérico Bisección en Excel se basa en el teorema de Bolzano y es el método más elemental y antiguo para determinar las raíces de una ecuación.

Un método numérico es un procedimiento mediante el cual se obtiene, casi siempre de manera aproximada, la solución de ciertos problemas realizando cálculos puramente aritméticos y lógicos (operaciones aritméticas elementales, cálculo de funciones, consulta de una tabla de valores, cálculo preposicional, etc.).

En general, al emplear estos instrumentos de cálculo se introducen errores llamados de redondeo.

Método numérico Bisección en Excel

El método numérico Bisección en Excel consiste en partir de un intervalo [x0, x1] tal que f(x0) f(x1) < 0, por lo que sabemos que existe, al menos, una raíz real. A partir de este punto se va reduciendo el intervalo sucesivamente hasta hacerlo tan pequeño como exija la precisión que hayamos decidido emplear.

El procedimiento se inicia cuando se localiza un cambio de signo de la función f(x) entre dos valores x1 y x2. El intervalo se divide, sucesivamente, en dos y se evalúa la ecuación hasta obtener un f(x)=0 o bien un valor que satisfaga la tolerancia deseada.

  • Si la solución existe, el método la encontrará.

  • El método es lento, se necesitan a veces muchas iteraciones para lograr encontrar la solución, especialmente si los extremos están muy separados.

  • El método de bisección es menos eficiente que el método de Newton, pero es mucho más seguro para garantizar la convergencia.

  1. Deseamos resolver la ecuación por el método numérico Bisección

    Método numérico Bisección en Excel: Ecuación, x^3-x-1+0=0

    Esta ecuación de acuerdo al teorema fundamental del álgebra tiene 3 raíces y según la regla de signos de Descartes solamente una raíz real.

    Aplicando valuación se encuentran los puntos de cambio de signo,o bien división sintética, se obtiene que la ecuación tiene un cero entre 1 y 2. Se construye la siguiente tabla de datos:

  2. CAMBIO DE SIGNO. Obtenemos el cambio de signo de la función f(x) entre los dos valores para el límite inferior y superior.

  3. Ir a: Celda A2 / Escribir: -10.

  4. Ir a: Celda A2 / Situar el cursor en el punto inferior derecho / arrastrar hasta la celda A22 o la deseada.

  5. Ir al botón de opciones / Clic sobre relleno. Mostrará los valores positivos y negativos entre -10 y 10.

  6. Ir a: Celda B2 / Escribir: =A2^3-A2-1. Fórmula para la ecuación: x3 – x – 1 + 0 = 0

  7. Copiar la celda B2 / Pegar en el rango B3:B22 como fórmula.

  8. Observamos que el cambio de signo se produce entre -1 (Celda B13) y 5 (celda B14), límite inferior aplicamos 1 (celda A13) y el límite superior 2 (celda A14).

    Método numérico Bisección en Excel: Celda B2 con fórmula =A2^3-A2-1
  9. ITERACIONES. Aplicamos el número de iteraciones deseado.

  10. Ir a: Celda D2 / Escribir: 1.

  11. Ir a: Celda D2 / Situar el cursor en el punto inferior derecho / arrastrar hasta la celda D22 o la deseada.

  12. Ir al botón de opciones / Clic sobre relleno. Mostrará la serie del 1 al 21.

  13. LIMITE INFERIOR. Aplicamos el número inferior para las iteraciones.

  14. Ir a: Celda E2 / Escribir: 1. Comenzamos con el valor inferior obtenido en celda A13.

  15. Ir a: Celda E2 / Escribir: =SI(H2>0;E2;G2).

  16. Copiar la celda E2 / Pegar en el rango E3:E22.

  17. LIMITE SUPERIOR. Aplicamos el número superior para las iteraciones.

  18. Ir a: Celda F2 / Escribir: 2. Comenzamos con el valor inferior obtenido en celda A14.

  19. Ir a: Celda F2 / Escribir: =SI(H2>0;G2;F2).

  20. Copiar la celda F2 / Pegar en el rango F3:F22.

    Método numérico Bisección: Celda F2 con fórmula =SI(H2>0;G2;F2)
  21. PUNTO MEDIO. Aplicamos el algoritmos de la bisección

  22. Ir a: Celda G2 / Escribir: =(E2+F2)/2. Algoritmo para el método.

    Método numérico Bisección, Algoritmo bisección P<sub>n</sub>=a<sub>n</sub>+b<sub>n</sub>/2
  23. Copiar la celda G2 / Pegar en el rango G3:G22.

  24. FUNCIÓN (PUNTO MEDIO). Aplicamos la ecuación para el punto medio.

  25. Ir a: Celda H2 / Escribir: =G2^3-G2-1.

  26. Copiar la celda H2 / Pegar en el rango H3:H22.

    Método numérico Bisección en Excel: Celda H2 con fórmula =G2^3-G2-1
  27. TOLERANCIA. Insertamos la tolerancia deseada y el mensaje de la solución.

  28. Ir a: Celda L1 / Escribir: 0,00001. Como el margen de tolerancia deseado.

  29. Ir a: Celda I2 / Escribir: =SI(ABS(H2)<$L$1;"SOLUCIÓN";"Calculando...").

  30. Ir a: Celda I3 / Escribir: =SI(ABS(H3-H2)<$L$1;"SOLUCIÓN";"Calculando...").

  31. Copiar la celda I3 / Pegar en el rango I4:I22.

    Método numérico Bisección en Excel: Celda I20 mostrando SOLUCIÓN (Valor 1,32471848, celda F20)
  32. La solución obtenida es x= 1,32471848 (Celda F20). Según la tolerancia aplicada (L1), podemos obtener una solución con menos iteraciones.

Así podemos resolver ecuaciones por el método numérico Bisección en Excel.

Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “Método numérico Bisección en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *