Los tres valores mayores en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En un conjunto de datos sin ordenar, podemos obtener los valores más altos, por ejemplo, los tres valores mayores en Excel.

Los tres valores mayores en Excel

Emplearemos la siguiente función:

  • Función K.ESIMO.MAYOR Devuelve el k-ésimo mayor valor de un conjunto de datos, es decir, el mayor valor de un resultado, el segundo resultado o el tercero, etc.
Función Excel: =K.ESIMO.MAYOR(A2:A9;1)
 
Disponemos en la columna A una serie de valores y deseamos obtener en D1:D3 los tres mayores valores.
 ABC
1Valor  1º valor mayor:
2250 2º valor mayor:
31.510 3º valor mayor:
4475  
53  
612.620  
7456  
812  
91.231  

 

  • PRIMER VALOR MÁS ALTO
  1. Clic sobre la celda D1. Celda donde insertar el primer valor más alto.

  2. Escribir:

    =K.ESIMO.MAYOR(A2:A9;1)
    Celda D1 con función =K.ESIMO.MAYOR(A2:A9;1)
  3. Verificar como muestra el valor 12.620 (A6), como el primer valor más alto.

 
  • SEGUNDO VALOR MÁS ALTO
  1. Clic sobre la celda D2. Celda donde insertar el segundo valor más alto.

  2. Escribir:

    =K.ESIMO.MAYOR(A2:A9; 2)
    Celda D2 con función =K.ESIMO.MAYOR(A2:A9;2)
  3. Verificar como muestra el valor 1.510 (A3), como el segundo valor más alto.

 
  • TERCER VALOR MÁS ALTO
  1. Clic sobre la celda D3. Celda donde insertar el tercer valor más alto.

  2. Escribir:

    =K.ESIMO.MAYOR(A2:A9; 3)
    Celda D3 con función =K.ESIMO.MAYOR(A2:A9;3)
  3. Verificar como muestra el valor 1.231 (A9), como el tercer valor más alto.

Nivel de dificultad: Avanzado Excel Avanzado

15 comentarios en “Los tres valores mayores en Excel

    • Hola Javier,

      1. Si el rango es contiguo se podrá indicar por ejemplo A1:M50
      2. Si el rango no es contiguo lo mas sencillo es aplicar la función individual en una celda por cada rango y posteriormente volver a aplicar la función sobre las celdas resumen.

      Saludos.

  • Buen día, solicito apoyo para aplicar o encontrar (en que celdas) mas de un valor máximo o un valor máximo se repite.
    A1:D7
    NOMINA NOMBRE UNIDADES TOTAL
    5000 ANDREA DOMINGUEZ 10 $250,000.00
    5001 CRISTIAN SANTA 70 $1,750,000.00
    5002 MARIA BUITRADO 45 $19,125,000.00
    5003 PATRICIA MENDEZ 45 $19,125,000.00
    5004 CARLOS MENESES 700 $17,500,000.00
    5005 NANCY LOPERA 500 $12,500,000.00
    usando la siguiente formula k,esimo.mayor(D1;D7,1)
    Valor máximo 1 = $19,125,000 - Valor máximo 2 = $19,125,000 - Valor máximo 3 = $17,500,000
    como obtener a que NÓMINA y NOMBRE corresponden cada valor máximo
    este resultado quiero que se me refleje
    Para el Valor Máximo 1 = 5002 MARIA BUITRADO
    Para el Valor Máximo 2 = 5003 PATRICIA MENDEZ
    Para el Valor Máximo 3 = 5004 CARLOS MENESES

    con el DESREF no obtengo el resultado anterior, para el resultado del valor máximo 3 me repite lo del valor máximo 3

  • Hola, como puedo determinar, en una fila con 10 datos, las 4 celdas contiguas con la suma mas alta. Por ejemplo: 89 45 75 88 117 57 64 75 61 54, donde las 4 celdas contiguas que suman el valor mas alto son 75+88+117+57

    Saludos

      • Se puede hacer sin macros. Supongamos que tienes los 10 números en las posiciones A1:J1.
        En L1 haz la suma de las posiciones 1,2,3,4 (89+45+75+88=297), escribiendo =SUMA(A1:D1)

        Ahora selecciona la celda L1 y arrastra hasta la celda R1, con lo que te rellena las formulas cambiando ya los valores de las celdas a coger. Es decir sería el equivalente a hacer:
        En M1 haz la suma de las posiciones 2,3,4,5 (45+75+88+117=325), escribiendo =SUMA(B1:E1)
        En N1 haz la suma de las posiciones 3,4,5,6 (75+88+117+57=337), escribiendo =SUMA(C1:F1)
        En O1 haz la suma de las posiciones 4,5,6,7 (88+117+57+64=326), escribiendo =SUMA(D1:G1)
        En P1 haz la suma de las posiciones 5,6,7,8 (117+57+64+75=313), escribiendo =SUMA(E1:H1)
        En Q1 haz la suma de las posiciones 6,7,8,9 (57+64+75+61=257), escribiendo =SUMA(F1:I1)
        En R1 haz la suma de las posiciones 7,8,9,10 (64+75+61+54=254), escribiendo =SUMA(G1:J1)

        Al final en las celdas L1:R1 tendrás los siguientes valores:
        297 325 337 326 313 257 254

        Ahora ya puedes calcular el valor mas alto aplicando la siguiente fórmula a las sumas parciales que tienes en el rango L1:R1. Escribe en la celda T1 lo siguiente:
        =K.ESIMO.MAYOR(L1:R1;1)
        El resultado que obtienes es el esperado 337.

        Espero te sirva.
        Saludos

  • Hola,
    Junto con saludar le expongo mis dudas:

    Tengo 3 valores más altos que se repiten (que son diferentes personas), el problema es que puse funcion DESREF para que me entregue cuales son esos 3 valores altos, pero me entrega solo 1 de ellos ¿como lo hago para que me entregue los 3 nombres y no solo 1?

    Gracias

  • COMO PUEDO SUMAR LOS 6 MEJORES RESULTADOS DE UN TOTAL DE 8, INCLUYENDO UNO DE LOS RESULTADOS REPETIDOS COMO PEOR RESULTADO?
    38
    40
    41
    80
    36
    37
    37
    42

    • Hola Elvira,

      Aplica la fórmula:
      =K.ESIMO.MAYOR(A2:A9;1) + K.ESIMO.MAYOR(A2:A9;2) + K.ESIMO.MAYOR(A2:A9;3) + K.ESIMO.MAYOR(A2:A9;4) + K.ESIMO.MAYOR(A2:A9;5) + K.ESIMO.MAYOR(A2:A9;6) - K.ESIMO.MENOR(A2:A9;1)

      Saludos.

  • Hola estimados.

    Como puedo crear un nuevo registros o base de datos, partiendo de na base de datos. Donde pueda generar las columnas y filas de los elementos que se repiten con su valor mas alto, ademas que pueda colocar la fecha y hora cuando ocurrió la variable.
    Ejemplo del data base:
    Pad fecha hora Profund.(mts) condición tiempo
    A1 13/12/2019 04:56:40 2,17 En Cuña 0,12
    A1 13/12/2019 04:56:50 2,17 En Cuña 0,27
    A1 13/12/2019 04:57:00 2,17 En Cuña 0,42
    A1 13/12/2019 04:58:20 2,17 En Cuña 1,77
    A2 13/12/2019 05:40:30 84,63 En Cuña 4,20
    A2 13/12/2019 05:40:40 84,63 En Cuña 4,35
    A2 13/12/2019 05:40:50 84,63 En Cuña 4,55
    A2 13/12/2019 05:41:00 84,63 En Cuña 4,70

    Quisiera crear una nueva base de datos con los elementos que se repiten y su valor mas alto en tiempos:

    Pad fecha hora Profund condición tiempo
    A1 13/12/2019 04:59:40 2,17 En Cuña 3,12
    A2 13/12/2019 05:41:00 84,63 En Cuña 4,70

    Muchas gracias si me pueden ayudar en esta tarea...

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.