Los tres valores mayores en Excel (Parte 2)

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Te mostramos los tres valores mayores en Excel (Parte 2), para obtener los valores más altos así como los demás valores de su fila.

En un post anterior mostramos como obtener los tres valores más altos en un rango de Excel.

Los tres valores mayores en Excel (Parte 2)

Disponemos en la columna A las delegaciones, en la columna B su comercial y en la columna C el importe de las ventas, deseamos obtener los tres importes mayores, así como sus datos de referencia.

 ABC
1DelegaciónComercialVentas
2MadridLuis8.750,00
3SevillaAna12.375,00
4ValenciaJuan6.500,00
5BilbaoPedro21.350,00
6MálagaRosa11.200,00
7ToledoMaría9.800,00
8BurgosCarlos7.950,00
  • VALOR MÁS ALTO

  1. VENTAS. Ir a: Celda F1 / Escribir:

    =K.ESIMO.MAYOR(C2:C8;1)

    Mostrará 21.350,00. Como el valor mayor del rango C2:C8.

    Hoja Excel, celda F1 con valor mayor de ventas
  2. POSICIÓN EN FILA. Ir a: Celda F2 / Escribir:

    =COINCIDIR(F1;C2:C8;0)

    Mostrará 4. Como la fila donde se encuentra el valor mayor del rango C2:C8.

    Hoja Excel, celda F2 con posición de fila del valor mayor de ventas
  3. DELEGACIÓN. Ir a: Celda F3 / Escribir:

    =INDICE(A2:C8;F2;1)

    Mostrará Bilbao. Como la delegación con el valor mayor del rango C2:C8.

    Hoja Excel, celda F3 con delegación del valor mayor de ventas

    O también anidando funciones:

  4. Ir a: Celda G3 / Escribir:

    =INDICE(A2:C8;COINCIDIR(F1;C2:C8;0);1)

    Mostrará Bilbao. Como la delegación con el valor mayor del rango C2:C8, anidando funciones.

    Hoja Excel, celda G3 con delegación del valor mayor de ventas, funciones anidadas
  5. COMERCIAL. Ir a: Celda F4 / Escribir:

    =INDICE(A2:C8;F2;2)

    Mostrará Bilbao. Como el comercial con el valor mayor del rango C2:C8.

    Hoja Excel, celda F4 con comercial del valor mayor de ventas

    O también anidando funciones:

  6. Ir a: Celda G4 / Escribir:

    =INDICE(A2:C8;COINCIDIR(F1;C2:C8;0);2)

    Mostrará Bilbao. Como el comercial con el valor mayor del rango C2:C8, anidando funciones.

    Hoja Excel, celda G4 con comercial del valor mayor de ventas, funciones anidadas
  • RANKING: 1 POSICIÓN

  1. DELEGACIÓN. Ir a: Celda F7 / Escribir:

    =INDICE(A2:C8;COINCIDIR(K.ESIMO.MAYOR(C2:C8;1);C2:C8;0);1)

    Mostrará Bilbao. Como la delegación con el valor mayor del rango C2:C8.

  2. COMERCIAL. Ir a: Celda G7 / Escribir:

    =INDICE(A2:C8;COINCIDIR(K.ESIMO.MAYOR(C2:C8;1);C2:C8;0);2)

    Mostrará Pedro. Como la delegación con el valor mayor del rango C2:C8.

  3. VENTAS. Ir a: Celda H7 / Escribir:

    =K.ESIMO.MAYOR(C2:C8;1)

    Mostrará 21.350,00. Como el valor mayor del rango C2:C8.

Rango F7:H7 con el primer valor mayor
  • RANKING: 2 POSICIÓN

  1. DELEGACIÓN. Ir a: Celda F8 / Escribir:

    =INDICE(A2:C8;COINCIDIR(K.ESIMO.MAYOR(C2:C8;2);C2:C8;0);1)

    Mostrará Sevilla. Como la segunda delegación con el valor mayor del rango C2:C8.

  2. COMERCIAL. Ir a: Celda G8 / Escribir:

    =INDICE(A2:C8;COINCIDIR(K.ESIMO.MAYOR(C2:C8;2);C2:C8;0);2)

    Mostrará Sevilla. Como el segundo comercial con el valor mayor del rango C2:C8.

  3. VENTAS. Ir a: Celda H8 / Escribir:

    =K.ESIMO.MAYOR(C2:C8;2)

    Mostrará 12.375,00. Como el segundo importe con el valor mayor del rango C2:C8.

Rango F8:H8 con el segundo valor mayor
  • RANKING: 3 POSICIÓN

  1. DELEGACIÓN. Ir a: Celda F9 / Escribir:

    =INDICE(A2:C8;COINCIDIR(K.ESIMO.MAYOR(C2:C8;3);C2:C8;0);1)

    Mostrará Málaga. Como la tercera delegación con el valor mayor del rango C2:C8.

  2. COMERCIAL. Ir a: Celda G9 / Escribir:

    =INDICE(A2:C8;COINCIDIR(K.ESIMO.MAYOR(C2:C8;3);C2:C8;0);2)

    Mostrará Rosa. Como el tercer comercial con el valor mayor del rango C2:C8.

  3. VENTAS. Ir a: Celda H9 / Escribir:

    =K.ESIMO.MAYOR(C2:C8;3)

    Mostrará 11.200,00. Como el tercera el valor mayor del rango C2:C8.

Rango F9:H9 con el tercer valor mayor

 

– Consultar: Los tres valores mayores en Excel (Parte 1).

– Consultar: Ordenar y buscar datos con funciones.

 

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *