Limitar la entrada a la suma de varios valores Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

En ocasiones nos interesa en nuestras celdas limitar la entrada a la suma de varios valores Excel.

Limitar la entrada a la suma de varios valores Excel

En nuestra hoja, disponemos en la columna B donde insertar los valores de mano de obra, material y desplazamiento, cuya suma no puede ser superior a 1.200€.

 AB
1Mano de obra: 
2Material: 
3Desplazamiento: 

Emplearemos la siguiente función en la validación de datos:

  • Función SUMA. Suma todos los números de un rango.
 
  1. Seleccionar el rango A2:A15. O el rango deseado donde escribir una de las opciones deseadas.

  2. Ir a: cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos. Mostrará ventana de validación.

  3. Clic en Pestaña: Configuración.

    Ventana de configuración en validación de datos
  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =SUMA($B$1:$B$3)<=1200
  6. Clic en Pestaña: Mensaje de error.

    Ventana de mensaje de error en validación de datos
  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error.

  9. Ir a: Mensaje de error / Escribir: La suma de los valores no puede ser superior a 1.200 €. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica la validación.

 
  • VERIFICAR FUNCIONAMIENTO
  1. Ir a: Celda B1 / Escribir: 300. Verificar como se admite el valor escrito, al ser la suma inferior a 1.200.

  2. Ir a: Celda B2 / Escribir: 550. Verificar como se admite el valor escrito, al ser la suma inferior a 1.200.

  3. Ir a: Celda A2 / Escribir: 500. Verificar como se muestra ventana de detener con el mensaje indicado en la validación para evitar insertar una suma superior a 1.200€.

  4. Pulsar el botón Cancelar. Continuar insertando datos.

  5. Ir a: Celda B2 / Escribir: 300. Verificar como se admite el valor escrito, al ser la suma inferior a 1.200.

Limitar la entrada a la suma de varios valores Excel  

 

Nivel de dificultad: Avanzado Excel Avanzado

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.