Las condiciones en fechas con función SI en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Al evaluar las condiciones en fechas con función SI en Excel, se realiza de manera especial que con texto o números.

Las condiciones en fechas con función SI en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función FECHANUMERO. Convierte una fecha en forma de texto en un número que representa la fecha.

En la columna A disponemos de la fecha de alta de nuestros clientes y en la columna B, su ciudad.

AB
1Fecha altaCiudad
201/01/2016Madrid
305/02/2018
415/12/2016Madrid
501/11/2017
603/01/2018Sevilla
712/04/2017
810/05/2018
908/05/2018
  • MAYOR DE

Sí la fecha es mayor a 01/01/2018, mostrará el texto "Actual", en caso contrario no muestra nada.

  1. Ir a la celda D2 / Escribir:

    =SI(A2>=FECHANUMERO("01/01/2018");"Actual";"")
  2. Copiar la celda D2 / Pegar en el rango D3:D9. Verificar como muestra la condición.

Columna D mostrando cuatro resultados.
  • MENOR DE

Si la fecha es inferior al 2017, mostrará el valor "2016", en caso contrario no muestra nada.

  1. Ir a la celda E2 / Escribir:

    =SI(A2<=FECHANUMERO("31/12/2016");"2016";"")
  2. Copiar la celda E2 / Pegar en el rango E3:E9. Verificar como muestra la condición.

Columna E mostrando dos resultados.
  • IGUAL QUE

Si la fecha es del año 2017, mostrará el valor "2017", en caso contrario no muestra nada.

  1. Ir a la celda F2 / Escribir:

    =SI(Y(B14>=FECHANUMERO("01/01/2017");B14<=FECHANUMERO("31/12/2017"));2017;"")

    O tmbién:

    =SI(A2<=FECHANUMERO("31/12/2016");"2017";"")
  2. Copiar la celda F2 / Pegar en el rango F3:F9. Verificar como muestra la condición.

Columna F mostrando dos resultados.
  • DIFERENTE DE

Si la fecha es diferente a 2018, mostrará el texto "Fuera de año", en caso contrario no muestra nada.

  1. Ir a la celda G2 / Escribir:

    =SI(AÑO(A2)<>2018;"Fuera de año";"")
  2. Copiar la celda G2 / Pegar en el rango G3:G9. Verificar como muestra la condición.

Columna G mostrando cuatro resultados.
  • DEL MES

Si el mes es "Enero", mostrará el texto "Enero", en caso contrario no muestra nada.

  1. Ir a la celda H2 / Escribir:

    =SI(MES(A2)=1;"Enero";"")
  2. Copiar la celda H2 / Pegar en el rango H3:H9. Verificar como muestra la condición.

Columna H mostrando dos resultados.
  • DEL DÍA

Si el día es 1, mostrará "01", en caso contrario no muestra nada.

  1. Ir a la celda I2 / Escribir:

    =SI(DIA(A2)=1;"01";"")
  2. Copiar la celda I2 / Pegar en el rango I3:I9. Verificar como muestra la condición.

Columna I mostrando dos resultados.
  • EL DÍA DE HOY

Si es el día de hoy (considerando que es 10/05/2018), mostrará el texto "Vence hoy", en caso contrario no muestra nada.

  1. Ir a la celda J2 / Escribir:

    =SI(A2=HOY();"Vence hoy";"")
  2. Copiar la celda J2 / Pegar en el rango J3:J9. Verificar como muestra la condición.

Columna J mostrando un resultado.
  • EL DÍA DE HOY

Si la fecha vence en los próximos 15 días (considerando que es 10/05/2018), mostrará el texto "Vence hoy", en caso contrario no muestra nada.

  1. Ir a la celda K2 / Escribir:

    =SI(Y(A2-HOY()>=0;A2-HOY()<=15);"Vencerá";"")
  2. Copiar la celda K2 / Pegar en el rango K3:K9. Verificar como muestra la condición.

Columna K mostrando un resultado.
  • EL DÍA DE HOY

Si la fecha es 01/01/2016 y la ciudad es Madrid, mostrará el texto "Resultado", en caso contrario no muestra nada.

  1. Ir a la celda L2 / Escribir:

    =SI(Y(A2=FECHANUMERO("01/01/2016");A2<="Madrid");"Resultado";"")
  2. Copiar la celda L2 / Pegar en el rango L3:L9. Verificar como muestra la condición.

Columna L mostrando un resultado.
Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.