Las condiciones en fechas con función SI en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Al evaluar las condiciones en fechas con función SI en Excel, se realiza de manera especial que con texto o números.

Las condiciones en fechas con función SI en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función FECHANUMERO. Convierte una fecha en forma de texto en un número que representa la fecha.

En la columna A disponemos de la fecha de alta de nuestros clientes y en la columna B, su ciudad.

AB
1Fecha altaCiudad
201/01/2016Madrid
305/02/2018
415/12/2016Madrid
501/11/2017
603/01/2018Sevilla
712/04/2017
810/05/2018
908/05/2018
  • MAYOR DE

Sí la fecha es mayor a 01/01/2018, mostrará el texto "Actual", en caso contrario no muestra nada.

  1. Ir a la celda D2 / Escribir:

    =SI(A2>=FECHANUMERO("01/01/2018");"Actual";"")
  2. Copiar la celda D2 / Pegar en el rango D3:D9. Verificar como muestra la condición.

Columna D mostrando cuatro resultados.
  • MENOR DE

Si la fecha es inferior al 2017, mostrará el valor "2016", en caso contrario no muestra nada.

  1. Ir a la celda E2 / Escribir:

    =SI(A2<=FECHANUMERO("31/12/2016");"2016";"")
  2. Copiar la celda E2 / Pegar en el rango E3:E9. Verificar como muestra la condición.

Columna E mostrando dos resultados.
  • IGUAL QUE

Si la fecha es del año 2017, mostrará el valor "2017", en caso contrario no muestra nada.

  1. Ir a la celda F2 / Escribir:

    =SI(Y(B14>=FECHANUMERO("01/01/2017");B14<=FECHANUMERO("31/12/2017"));2017;"")

    O tmbién:

    =SI(A2<=FECHANUMERO("31/12/2016");"2017";"")
  2. Copiar la celda F2 / Pegar en el rango F3:F9. Verificar como muestra la condición.

Columna F mostrando dos resultados.
  • DIFERENTE DE

Si la fecha es diferente a 2018, mostrará el texto "Fuera de año", en caso contrario no muestra nada.

  1. Ir a la celda G2 / Escribir:

    =SI(AÑO(A2)<>2018;"Fuera de año";"")
  2. Copiar la celda G2 / Pegar en el rango G3:G9. Verificar como muestra la condición.

Columna G mostrando cuatro resultados.
  • DEL MES

Si el mes es "Enero", mostrará el texto "Enero", en caso contrario no muestra nada.

  1. Ir a la celda H2 / Escribir:

    =SI(MES(A2)=1;"Enero";"")
  2. Copiar la celda H2 / Pegar en el rango H3:H9. Verificar como muestra la condición.

Columna H mostrando dos resultados.
  • DEL DÍA

Si el día es 1, mostrará "01", en caso contrario no muestra nada.

  1. Ir a la celda I2 / Escribir:

    =SI(DIA(A2)=1;"01";"")
  2. Copiar la celda I2 / Pegar en el rango I3:I9. Verificar como muestra la condición.

Columna I mostrando dos resultados.
  • EL DÍA DE HOY

Si es el día de hoy (considerando que es 10/05/2018), mostrará el texto "Vence hoy", en caso contrario no muestra nada.

  1. Ir a la celda J2 / Escribir:

    =SI(A2=HOY();"Vence hoy";"")
  2. Copiar la celda J2 / Pegar en el rango J3:J9. Verificar como muestra la condición.

Columna J mostrando un resultado.
  • EL DÍA DE HOY

Si la fecha vence en los próximos 15 días (considerando que es 10/05/2018), mostrará el texto "Vence hoy", en caso contrario no muestra nada.

  1. Ir a la celda K2 / Escribir:

    =SI(Y(A2-HOY()>=0;A2-HOY()<=15);"Vencerá";"")
  2. Copiar la celda K2 / Pegar en el rango K3:K9. Verificar como muestra la condición.

Columna K mostrando un resultado.
  • EL DÍA DE HOY

Si la fecha es 01/01/2016 y la ciudad es Madrid, mostrará el texto "Resultado", en caso contrario no muestra nada.

  1. Ir a la celda L2 / Escribir:

    =SI(Y(A2=FECHANUMERO("01/01/2016");A2<="Madrid");"Resultado";"")
  2. Copiar la celda L2 / Pegar en el rango L3:L9. Verificar como muestra la condición.

Columna L mostrando un resultado.
Nivel de dificultad: Avanzado Excel Avanzado

12 comentarios en “Las condiciones en fechas con función SI en Excel

  • Tengo un campo de fecha real y otro de fecha teórica, si Real es inferior a teórica devuelve EN PLAZO, si no FUERA PLAZO. Pero puede ser que el campo F. real esté vacío, en este caso tiene que mirar el f.teórico y si es superior a hoy poner FUERA PLAZO, si no devolver EN PLAZO..

  • Buenas!

    Utilicé la Formula de MONTH y le agregué IFS, para tener todos los meses del año. El único problema es que si la celda está vacía me devuelve DICIEMBRE. No le encontré la vuelta, si me podes dar una mano te agradezco =)

    =IFS(MONTH(A10)=1;"ENERO";MONTH(A10)=2;"FEBRERO";MONTH(A10)=3;"MARZO";MONTH(A10)=4;"ABRIL";MONTH(A10)=5;"MAYO";MONTH(A10)=6;"JUNIO";MONTH(A10)=7;"JULIO";MONTH(A10)=8;"AGOSTO";MONTH(A10)=9;"SEPTIEMBRE";MONTH(A10)=10;"OCTUBRE";MONTH(A10)=11;"NOVIEMBRE";MONTH(A10)=12;"DICIEMBRE")

  • ESTOY HACIENDO UNAS PRUEBAS Y NECESITO AYUDA DE EXPERTOS, LES EXPLICO LA SITUACION... EJEMPLO
    SI JUAN ACUDE A LAS 11:02:58 A. M. DEL DIA 25/05/2020 Y REALIZA UN PAGO, PERO SE LE LLAMA EL DIA 26/05/2020 A LAS HORA 11:12:00, ESTE PAGO YA NO DEBE DE CONTAR POR QUE YA NO CAYO DENTRO DE LA FECHA DE LA LLAMADA, PERO SI A JUAN SE LE LLAMA EL DIA 24/05/2020 A LAS 11:12:53 A. M. Y EL HUBIESE PAGADO EL DIA 25/05/2020 11:02:58 A. M. EL PAGO LE CORRESPONTE A SUANA, COMO SE PUEDE VALIDAR QUE LA FECHA Y LA HORA LA TOME EXCEL PARA LA VALIDACION. AYUDA

  • Tengo esta fórmula para que, mediante la función SI anidada elija sumar un numero de celdas de acuerdo a su fecha (Mes) y con una condición por concepto (Que está entre comillas)
    =SI(G507=A506;SUMAR.SI($E$2:$E$503;"Crédito Hipotecario";$B$2:$B$503);SI(G507=A507;SUMAR.SI($E$2:$E$121;"Crédito Hipotecario";$B$2:$B$121);SI(G507=A508;SUMAR.SI($E$122:$E$216;"Crédito Hipotecario";$B$122:$B$216);SI(G507=A509;SUMAR.SI($E$217:$E$329;"Crédito Hipotecario";$B$217:$B$329);SI(G507=A510;SUMAR.SI($E$330:$E$425;"Crédito Hipotecario";$B$330:$B$425);SI(G507=A511;SUMAR.SI($E$426:$E$503;"Crédito Hipotecario";$B$426:$B$503);""))))))

    No se como hacer que al escribir "ene-20" este indique el mes completo y no solo el 01-01-2020.
    Con validación de datos, indico cuando es enero, cuando es febrero y así sucesivamente... y además como ven en la formula, tengo que señalar de donde hasta donde es enero, de donde hasta donde es febrero y así sucesivamente, teniendo una tabla de cada transacción con su fecha.

    Favor su ayuda para simplificar este modelo.

  • buenas tardes
    quisiera saber si hay una formula para poder determinar una condicional, si tengo el valor 9 años, 5 meses, 3 dias y quiero poner que si es menor a 2 años me ponga NO APLICA, y si es mayor o igual a 2 años me coloque APLICA

  • buenas tardes, necesito una condicion formula, donde si la columna "a" me marca fecha me diga "transito", si la columna "a y b" tienen fecha marque "pendiente descarga y si las columnas "a,b y c" marcan fechas me dica descargado, cada fecha incluye la hora tambien

    gracias

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.