La simulación del método Montecarlo en Excel (II)

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Sobre la plantilla simulación del método Montecarlo insertamos el modelo aleatorio.

La simulación del método Montecarlo en Excel (II)

Creamos un modelo de datos donde generamos una serie de números aleatorios de 1000 muestreos. Al realizarse cambios en la hoja los valores se actualizarán por el valor aleatorio.

  1. Abrir el libro de la plantilla: Montecarlo en Excel (I)

  2. Insertar una nueva hoja en Blanco / cambiar el nombre por: Modelo.

 
  • ASIGNACIÓN MUESTREOS A NÚMEROS ALEATORIOS
  1. Ir a: Celda A3 / Escribir: Nº. Como encabezado de la columna.

  2. Ir a: Celda A4 / Escribir: 1.

  3. Ir a: Celda A5 / Escribir: 2.

  4. Seleccionar el rango A4:A5 / Ir al punto inferior derecho y arrastrar hasta la celda A1003. Para realizar 1000 muestreos.

 
  1. Ir a: Celda B3 / Escribir: Unid. Como encabezado de la columna.

  2. Ir a: Celda B4 / Escribir:

    =BUSCARV(ALEATORIO();Datos!$B$4:$D$10;3;VERDADERO)+Datos!C34
  3. Copiar la celda B4 / Pegar en el rango B5:B1003.

 
  1. Ir a: Celda C3 / Escribir: Precio Venta. Como encabezado de la columna.

  2. Ir a: Celda C4 / Escribir:

    =BUSCARV(ALEATORIO();Datos!$B$15:$D$20;3;VERDADERO)+Datos!C34
  3. Copiar la celda C4 / Pegar en el rango C5:C1003.

 
  1. Ir a: Celda D3 / Escribir: Precio Compra. Como encabezado de la columna.

  2. Ir a: Celda D4 / Escribir:

    =BUSCARV(ALEATORIO();Datos!$B$25:$D$30;3;VERDADERO)+Datos!C34
  3. Copiar la celda D4 / Pegar en el rango D5:D1003.

 
  1. Ir a: Celda E3 / Escribir: Coste Compra. Como encabezado de la columna.

  2. Ir a: Celda E4 / Escribir:

    =D4+Datos!$C$34
  3. Copiar la celda E4 / Pegar en el rango E5:E1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 118
  1. Ir a: Celda F2 / Escribir: =Datos!D4-1 Como el número de unidades para la simulación.

  2. Ir a: Celda F3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda F4 / Escribir:

    =SI(F$2>$B4;(F$2-$B4)*$E4;0)
  4. Copiar la celda F4 / Pegar en el rango F5:F1003.

  5. Ir a: Celda G3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda G4 / Escribir:

    =SI(F$2<=$B4;F$2*$C4-F$2*$E4;$B4*$C4-$B4*$E4-F4)
  7. Copiar la celda G4 / Pegar en el rango G5:G1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 119
  1. Ir a: Celda H2 / Escribir: =Datos!D4. Como el día para la simulación.

  2. Ir a: Celda H3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda H4 / Escribir:

    =SI(H$2>$B4;(H$2-$B4)*$E4;0)
  4. Copiar la celda H4 / Pegar en el rango H5:H1003.

  5. Ir a: Celda I3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda I4 / Escribir:

    =SI(H$2<=$B4;H$2*$C4-H$2*$E4;$B4*$C4-$B4*$E4-H4)
  7. Copiar la celda I4 / Pegar en el rango I5:I1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 120
  1. Ir a: Celda J2 / Escribir: =Datos!D5. Como el día para la simulación.

  2. Ir a: Celda J3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda J4 / Escribir:

    =SI(J$2>$B4;(J$2-$B4)*$E4;0)
  4. Copiar la celda J4 / Pegar en el rango J5:J1003.

  5. Ir a: Celda K3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda K4 / Escribir:

    =SI(J$2<=$B4;J$2*$C4-J$2*$E4;$B4*$C4-$B4*$E4-J4)
  7. Copiar la celda K4 / Pegar en el rango K5:K1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 121
  1. Ir a: Celda L2 / Escribir: =Datos!D6. Como el día para la simulación.

  2. Ir a: Celda L3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda L4 / Escribir:

    =SI(L$2>$B4;(L$2-$B4)*$E4;0)
  4. Copiar la celda L4 / Pegar en el rango L5:L1003.

  5. Ir a: Celda M3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda M4 / Escribir:

    =SI(L$2<=$B4;L$2*$C4-L$2*$E4;$B4*$C4-$B4*$E4-L4)
  7. Copiar la celda M4 / Pegar en el rango M5:M1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 122
  1. Ir a: Celda N2 / Escribir: =Datos!D7. Como el día para la simulación.

  2. Ir a: Celda N3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda N4 / Escribir:

    =SI(N$2>$B4;(N$2-$B4)*$E4;0)
  4. Copiar la celda N4 / Pegar en el rango N5:N1003.

  5. Ir a: Celda O3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda O4 / Escribir:

    =SI(N$2<=$B4;N$2*$C4-N$2*$E4;$B4*$C4-$B4*$E4-N4)
  7. Copiar la celda O4 / Pegar en el rango O5:O1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 123
  1. Ir a: Celda P2 / Escribir: =Datos!D8. Como el día para la simulación.

  2. Ir a: Celda P3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda P4 / Escribir:

    =SI(P$2>$B4;(P$2-$B4)*$E4;0)
  4. Copiar la celda P4 / Pegar en el rango P5:P1003.

  5. Ir a: Celda Q3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda Q4 / Escribir:

    =SI(P$2<=$B4;P$2*$C4-P$2*$E4;$B4*$C4-$B4*$E4-P4)
  7. Copiar la celda Q4 / Pegar en el rango Q5:Q1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 124
  1. Ir a: Celda R2 / Escribir: =Datos!D9. Como el día para la simulación.

  2. Ir a: Celda R3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda R4 / Escribir:

    =SI(R$2>$B4;(R$2-$B4)*$E4;0)
  4. Copiar la celda R4 / Pegar en el rango R5:R1003.

  5. Ir a: Celda S3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda S4 / Escribir:

    =SI(R$2<=$B4;R$2*$C4-R$2*$E4;$B4*$C4-$B4*$E4-R4)
  7. Copiar la celda S4 / Pegar en el rango S5:S1003.

 
  • SIMULACIÓN BENEFICIOS: UNID. 125
  1. Ir a: Celda T2 / Escribir: =Datos!D10. Como el día para la simulación.

  2. Ir a: Celda T3 / Escribir: Exceso Coste. Como el encabezado de la columna.

  3. Ir a: Celda T4 / Escribir:

    =SI(T$2>$B4;(T$2-$B4)*$E4;0)
  4. Copiar la celda T4 / Pegar en el rango T5:T1003.

  5. Ir a: Celda U3 / Escribir: Beneficios. Como el encabezado de la columna.

  6. Ir a: Celda U4 / Escribir:

    =SI(T$2<=$B4;T$2*$C4-T$2*$E4;$B4*$C4-$B4*$E4-T4)
  7. Copiar la celda U4 / Pegar en el rango U5:U1003.

Plantilla simulador Montecarlos (II)

- Consultar:

Montecarlo I

 

Nivel de dificultad: Avanzado Excel Avanzado

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.