Invierte los dígitos de un número Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Podemos recurrir a funciones para invierte los dígitos de un número Excel.

Invierte los dígitos de un número Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMA. Suma todos los números del rango indicado.

  • Función EXTRAE. Devuelve los caracteres del centro de una cadena de texto, dada una posición y longitud iniciales.

  • Función ABS. Devuelve el valor absoluto de un número (sin número).

  • Función FILA. Devuelve el número dde fila de una referencia.

  • Función INDIRECTO. Devuelve una referencia especificada por un valor de texto.

  • Función LARGO. Devuelve el número de caracteres de una cadena de texto.

  • Función SIGNO. Devuelve el signo de un número.

 
  1. Ir a: Celda A1 / Escribir: 123456. Como los números que deseamos invertir.

  2. Ir a: Celda B1 / Escribir:

    =SUMA(EXTRAE(ABS(A1); FILA(INDIRECTO("1:"&LARGO(ABS(A1))));1)*10^ (FILA(INDIRECTO("1:" &LARGO(ABS(A1))))-1)) *SIGNO(A1)
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(EXTRAE(ABS(A1); FILA(INDIRECTO("1:"&LARGO(ABS(A1))));1)*10^ (FILA(INDIRECTO("1:" &LARGO(ABS(A1))))-1)) *SIGNO(A1)}.

  4. Verificar como muestra 654321. Como la inversa de los caracteres de A1 (123456).

Celda C1 con el valor invertido en Excel
Nivel de dificultad: Avanzado Excel Avanzado

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.