Fórmula matricial en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Una fórmula matricial en Excel es la que se aplica a todas las celdas de un rango o a todos los valores de una matriz.

 

Al definir una fórmula como matricial, se muestra en la barra de fórmulas encerrada entre llaves { }. Para definir la fórmula deberemos pulsar simultáneamente las teclas Mayúsculas Control y Enter.
Fórmula matricial en Excel: Celda B6 con fórmula introducida como matricial {=SUMA(B2E2*B3:E3)}
Algunas funciones de Excel, como por ejemplo SUMAPRODUCTO, trabajan con matrices de forma implícita, por lo que no es necesario introducirlas como matriciales. Otras funciones como TRANSPONER, FRECUENCIA, son funciones netamente matriciales, es decir, únicamente pueden ser usadas en una fórmula matricial (Pulsando Ctrl + Mayús + Enter), en caso contrario mostrará el error #¡VALOR!.

Algunas funciones de Excel es necesario insertarlas como fórmula matricial.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *