Filtrar por cualquier unidad de fecha en tablas dinámicas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En Excel 2016 al filtrar una fecha nos la muestra como año, trimestre y mes, pero nos puede interesar filtrar por cualquier unidad de fecha en tablas dinámicas Excel.

Filtrar por cualquier unidad de fecha en tablas dinámicas Excel
  • ORIGEN DE DATOS

Disponemos del origen de datos con los valores de país y fecha:

 AB
1PaísFecha
2España01/01/2018
3Colombia18/04/2018
4Perú18/10/2018
5Perú09/09/2018
6España31/12/2018
7México03/05/2018
8Colombia20/04/2018
9España13/08/2018
10México08/10/2018
11Colombia15/08/2018
12Perú21/07/2018
13Perú17/06/2018
14España21/03/2018
15México01/01/2019
16Colombia07/02/2018
17México12/08/2019
18Colombia12/02/2018
19México19/02/2018
20Colombia21/11/2018
  1. AÑO. Ir a: Celda C2 / Escribir:

    =TEXTO(B2; "aaaa")
  2. Copiar la celda C2. Celda con la función.

  3. Pegar en el rango C2:C10. Para aplicar al resto de fechas.

  4. SEMESTRE. Ir a: Celda D2 / Escribir:

    =REDONDEAR.MAS(MES(B2)/6;0)
  5. Copiar la celda D2. Celda con la función.

  6. Pegar en el rango D2:D10. Para aplicar al resto de fechas.

  7. CUATRIMESTRE. Ir a: Celda E2 / Escribir:

    =REDONDEAR.MAS(MES(B2)/4;0)
  8. Copiar la celda E2. Celda con la función.

  9. Pegar en el rango E2:E10. Para aplicar al resto de fechas.

  10. TRIMESTRE. Ir a: Celda F2 / Escribir:

    =REDONDEAR.MAS(MES(B2)/3;0)
  11. Copiar la celda F2. Celda con la función.

  12. Pegar en el rango F2:F10. Para aplicar al resto de fechas.

  13. BIMESTRE. Ir a: Celda G2 / Escribir:

    =REDONDEAR.MAS(MES(B2)/2;0)
  14. Copiar la celda G2. Celda con la función.

  15. Pegar en el rango G2:G10. Para aplicar al resto de fechas.

  16. MES. Ir a: Celda H2 / Escribir:

    =MES(B2)
  17. Copiar la celda H2. Celda con la función.

  18. Pegar en el rango H2:H10. Para aplicar al resto de fechas.

  19. QUINCENA. Ir a: Celda I2 / Escribir:

    =REDONDEAR.MAS((B2-FECHA(AÑO(B2);1;0))/15;0)
  20. Copiar la celda I2. Celda con la función.

  21. Pegar en el rango I2:I10. Para aplicar al resto de fechas.

  22. SEMANA DEL AÑO. Ir a: Celda J2 / Escribir:

    =NUM.DE.SEMANA(B2;1)
  23. Copiar la celda J2. Celda con la función.

  24. Pegar en el rango J2:J10. Para aplicar al resto de fechas.

  25. DÍA. Ir a: Celda K2 / Escribir:

    =TEXTO(B2; "dd")
  26. Copiar la celda K2. Celda con la función.

  27. Pegar en el rango K2:K10. Para aplicar al resto de fechas.

Hoja Excel con columnas de fechas aplicadas
  • CREAR TABLA DINÁMICA

  1. Ir a: Cinta de opciones / Pestaña: Insertar / Grupo: Tablas / Tabla dinámica. Mostrará ventana de crear tabla dinámica.

    Ventana crear tabla dinámica en Excel
  2. Ir a: Seleccione una tabla o rango / Clic sobre: Seleccione una tabla o rango.

  3. Clic en Tabla o rango / Indicar el rango: A1:C15. Rango del origen de datos.

  4. Pulsar el botón Aceptar. Cierra la ventana e inserta el área de diseño de la tabla dinámica.

  • ASIGNAR CAMPOS

  1. Clic sobre cualquier celda del área de diseño de la tabla dinámica.

  2. Ir al panel de lista de campos / Clic sobre: País / Pulsar y arrastrar al área de valores del mismo panel de campos.

    Panel de lista de campos
  3. Ir al panel de lista de campos / Clic sobre: Año / Pulsar y arrastrar al área de filas del mismo panel de campos.

  4. Ir al panel de lista de campos / Clic sobre: Semestre / Pulsar y arrastrar al área de filas (debajo de Año).

    Posteriormente añadiremos el resto de campos de fecha.

  • ASIGNAR CAMPOS

  1. Ir a la tabla dinámica / Clic sobre cualquier celda de semestre.

  2. Ir a: Cinta de opciones / Pestaña: Analizar (Herramientas de tabla dinámica) / Grupo: Campo activo / Configuración de campo. Mostrará la ventana de configuración.

  3. Pulsar el botón Formato de número. Mostrará la ventana de formato de celdas.

    Ventana de formato de celdas
  4. Clic en categoría: Personalizada.

  5. Ir a: Tipo / Escribir: 0 "Semestre". Formato personalizado para mostrar el tipo de fecha.

  6. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato.

  7. Pulsar el botón Aceptar. Cierra la ventana de configuración.

  8. Verificar como se muestra el texto de Semestre.

    Tabla dinámica con campo semestre
  9. Repetir el proceso para: Cuatrimestre, Trimestre, Bimestre, Mes, Quincena, Semana año y día. Asignar campo como filas / Aplicar formato personalizado con el nombre del tipo de fecha.

Tabla dinámica con todos los campos de fechas
Nivel de dificultad: Avanzado Excel Avanzado

Un comentario en “Filtrar por cualquier unidad de fecha en tablas dinámicas Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *