Fecha más antigua y más reciente en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Deseamos obtener la fecha más antigua y más reciente en Excel por un criterio (en una columna), según el nombre buscado como criterio.

En la columna A disponemos del nombre del comercial y en la columna B la fecha de la venta.

Emplearemos las siguientes funciones, anidándolas:

  • Función MIN. Devuelve el valor mínimo de una lista de argumentos.

  • Función SI. Especifica un texto lógico para ejecutar.

  • Función SUMAPRODUCTO. Devuelve la suma de los productos de los componentes de la matriz correspondiente.

  • Función MAX. Devuelve el valor máximo de una lista de argumentos.

Fecha más antigua y más reciente  en Excel por un criterio: Rango de datos A1:B7, D1 nombre del delegado, E1 fecha menor y E2 fecha mayor
  1. Ir a: Celda D1 / Escribir: el nombre del comercial.

  2. FÓRMULA INSERTADA COMO MATRICIAL. Ir a: Celda E1 / Escribir:

    =MIN((B2:B7)*SI(A2:A7=D1;1;2))
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fecha menor como número, para el nombre del comercial (D1).

  4. Ir a: Celda E2 / Escribir:

    =SUMAPRODUCTO(MAX((A2:A7=D1)*(B2:B7)))

    Como la fecha mayor para el nombre del comercial (E1), insertado como número.

  5. Seleccionar el rango: E1:E2 / Aplicar formato de celda tipo fecha.

En la celda D1, podemos aplicar una validación de datos tipo lista, que nos permita seleccionar el nombre de los comerciales.

Mediante funciones y fórmula matricial podemos obtener la fecha más antigua y más reciente en Excel por un criterio.

Nivel de dificultad: Avanzado Excel Avanzado

21 comentarios en “Fecha más antigua y más reciente en Excel

    • Hola Pablo,

      Si quieres ampliar la celda E2 a un rango mayor, deberás de poner la fórmula como referencia absoluta ($) el rango de A y de B, y si la referencia de la columna D es diferente no hace falta referencia absoluta.

      Valor en D diferentes:
      =SUMAPRODUCTO(MAX(($A$2:$A$7=D1)*($B$2:$B$7)))

      Valor en D igual:
      =SUMAPRODUCTO(MAX(($A$2:$A$7=$D$1)*($B$2:$B$7)))

      Un saludo,

      Trucos y cursos de Excel.

  • BUENAS TARDES AMIGOS ANDO EN BUSCA DE ESA MISMA FUNCION PERO CON LA DIFERENCIA QUE NECESITO QUE SEAN DOS CRITERIOS EJEMPLO:

    TENGO UNA TABLA IGUAL PERO EN VES DE BUSCAR SOLO ANA NECESITARIA QUE QUE TAMBIEN COINCIDIERA CON EL VALOR MAQUINA QUE SERIA UN NUMERO EJEMPLO 339 Y DE ALLI ME LANZARA LA FECHA ESO ME FALTARIA SI ALGUIEN ME PUEDE AYUDAR O INDICAR COMO HACERLO
    SE LO AGRADEZCO.

    ATENTAMENTE MANUEL MARCHEL

  • hola, realicé la formula mencionada, de hallar la fecha mas antigua, pero , no me entrega el valor exato e incluso me entrega una fecha mayor…

      • Que representan el 1, y el 2 al final? necesito traer las fecha inicial y la fecha final según un criterio, pero con esta formula no me da el dato. estoy buscando en una base de datos.

        • Hola VV,

          El 1 se aplica si se cumple la condición A2:A7=D1 y si no se cumple aplica 2.

          Recuerda que la fórmula se debe de aplicar como fórmula matricial, según se indica en el apartado 3, en caso contrario mostrará #¡VALOR!

          Saludos.

  • hola necesito una formula donde me arroje los siguientes datos, NUEVO, NOVATO Y ANTIGUO
    segun la fecha de alta
    fecha alta<=30 – novato
    fecha 3090 – nuevo
    fecha >90 – antiguo

    • Hola Klinder,

      Puedes realizarlo con la siguiente función anidada, considerando que la fecha la tienes en A1.

      =SI(A1=””;””;SI((HOY()-A1)>=90;”ANTIGUO”;SI((HOY()-A1)>=60;”NUEVO”;SI((HOY()-A1)>=30;”NOVATO”;”-“))))

      Espero te sea útil, saludos y gracias por seguirnos.

  • como puedo ejecutar este archivo si la idea es ir llenando la base de datos aun no esta definida y el se actualice solo, en el rango tendria casillas en blanco

    • Hola Cesar,

      La primera fórmula al ser matricial no permite celdas vacías, por lo que no se puede dejar predefinido.
      La segunda fórmula se puede aplicar indicando el rango como columna: =SUMAPRODUCTO(MAX((A:A=D1)*(B:B)))

      Saludos

    • Hola Ángela,

      Puedes buscar el valor más próximo mediante la función: =BUSCARV(C1;A1:A16;1;VERDADERO)

      Donde:
      – C1. Valor buscado.
      – A1:A16. Rango donde buscar (Deben de estar ordenados).

      Saludos.

  • Tengo la siguiente formula “=SI(Y(IZQUIERDA(A2;2)=”AC”;F2=”1E”);”OK”;SI(Y(IZQUIERDA(A2;2)=”BA”;F2″1E”)”OK”;”MODIFICAR TARIFA”))

    En A2, puedo tener “Activo desde: 20150424” o “Baja desde: 20170818”. En C2, tengo El numero de identificacion del cliente. Como puedo agregar a esa formula o insertar otra que me traiga la fecha mas actual. Sino me muestre el alta y baja de un cliente, entonces modifico la tarifa, o supongo que esta OK. Muchas gracias!

  • Si Tengo la siguiente tabla.
    01/06/2017 07:23 Registro de entrada
    01/06/2017 07:24 Registro de entrada
    01/06/2017 08:45 Registro de salida
    01/06/2017 09:56 Registro de entrada
    01/06/2017 12:30 Registro de salida
    02/06/2017 07:29 Registro de entrada
    02/06/2017 10:03 Registro de salida
    02/06/2017 12:14 Registro de entrada
    02/06/2017 12:35 Registro de salida

    Como calculo la fecha menor y la fecha última del día 01/06/2017 y la fecha menor y la fecha última del día 02/06/2017? Osea tendría que salir lo siguiente:

    01/06/2017 07:23 “Registro de entrada” No necesariamente este texto
    01/06/2017 12:30 “Registro de salida”
    02/06/2017 07:29 “Registro de entrada”
    02/06/2017 12:35 “Registro de salida”

    Muchas gracias

  • Buenas noches,
    como podria utilizar la Funcion VlookUp buscando un registro, que debe estar entre 2 fechas fechainicial y fecha final

  • como puedo logra esto pero con horas es decir para hizo diferentes horas y tengo el registro de ello. como hago que me traiga la hora inicial y la hora final dentro de un mismo dia. (la consulta es grande)

    Ana 7:30am
    Pedro 5:30pm
    Ana 7:15am

  • TENGO 2 COLUMNAS UNA CON LA FECHA Y OTRO UN PRECIO PARA ESA FECHA MI LISTA ES DE LO MAS RECIENTE A LO MAS ANTIGUO. NECESITO VOLTEARLA QUE EMPIEZE DEL MAS ANTIGUO AL MAS NUEVO, PERO QUE SE LLEVE EL VALOR QUE LE CORRESPONDE A ESA FECHA

    • Hola CSCS,

      Deberás ordenar los datos:
      Clic sobre cualquier celda de fecha / Ir a Pestaña: Datos / Grupo: Ordenar y filtrar / Comando: AZ.
      Moverá los datos en el orden llevándose el valor de la otra columna.

      Saludos.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *