Evitar insertar valores repetidos en una columna Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Necesitamos insertar en una columna o un rango valores únicos, para ello necesitamos evitar insertar valores repetidos en una columna Excel.

Evitar insertar valores repetidos en una columna Excel

En nuestra hoja disponemos de la columna A donde insertar el CIF de la empresa, debiendo ser cada celda un valor sin repetidos.

 ABCD
1CIF EmpresaDirecciónContacto
2

Emplearemos la siguiente función en la validación de datos:

  • Función CONTAR.SI. Cuenta las celdas en el rango que coinciden con la condición deseada.

  1. Seleccionar el rango A2:A15. O el rango deseado donde insertar valores no repetidos.

  2. Ir a: cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos. Mostrará ventana de validación.

  3. Clic en Pestaña: Configuración.

    Ventana de configuración en validación de datos
  4. Ir a: Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    =CONTAR.SI($A$2:$A$15;A2)<=1

    Con referencia absoluta ($) y relativa (sin ella).

  6. Clic en Pestaña: Mensaje de error.

    Ventana de mensaje de error en validación de datos
  7. Ir a: Estilo / Seleccionar: Detener.

  8. Ir a: Título / Escribir: Error.

  9. Ir a: Mensaje de error / Escribir: El valor escrito ya se encuentra en la columna. No se admiten valores repetidos. O el texto deseado.

  10. Pulsar el botón Aceptar. Cierra la ventana y aplica la validación.

  • VERIFICAR FUNCIONAMIENTO

  1. Ir a: Columna A / Escribir valores no repetidos.

  2. Ir a: Columna A / Escribir un valor repetido. Verificar como se muestra ventana de detener con el mensaje indicado en la validación para evitar insertar valores repetidos en una columna Excel.

  3. Pulsar el botón Cancelar. Continuar insertando datos.

Evitar insertar valores repetidos en una columna Excel

 

Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “Evitar insertar valores repetidos en una columna Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *