Escribir una fecha según el limite de edad en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En ocasiones necesitamos escribir una fecha según el limite de edad en Excel, por ejemplo para verificar la mayoría de edad, desde la fecha de nacimiento.

Escribir una fecha según el limite de edad en Excel

En nuestra hoja disponemos de la celda F1 del límite de edad asignado para las fechas. En la columna B insertamos la fecha de nacimiento que deseamos validar. En la columna C nos mostrará la edad real de la persona.

 ABCDEF
1NombreFecha de nacimientoEdad        Limite de edad:18
2   
3  

Emplearemos las siguientes funciones anidadas:

  • Función SI. Comprueba si se cumple una condición y devuelve un valor si se evalúa como VERDADERO y otro valor si se evalúa como FALSO.

  • Función HOY. Devuelve la fecha actual.

  • Función TRUNCAR. Convierte un número decimal a entero, quitando la parte decimal.

  • VALIDACIÓN DE DATOS

  1. Seleccionar el rango B2:B3. O el rango deseado.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará la ventana de validación.

    Ventana de validación con permitir fórmula
  3. Ir a: Pestaña Configuración.

  4. Ir a: Criterio de validación / Permitir / Seleccionar: Personalizada.

  5. Ir a: Fórmula / Escribir:

    = SI(B2<=(HOY() - (365*$F$1)); VERDADERO; FALSO)
  • EDAD

  1. Ir a: Celda C2 / Escribir:

    =TRUNCAR((HOY()-B2)/365;0)
  2. Copiar la celda C2 / Pegar en el rango deseado.

  • VERIFICAR LA VALIDACIÓN

  1. Ir a: Celda B2 / Escribir: 12/05/2006. Verificar como no permite la fecha, al ser inferior a 18 años.

  2. Ir a: Celda B2 / Escribir: 05/07/1985. Verificar como permite la escritura, al ser superior a 18 años.

  3. La celda C2 mostrará la edad correspondiente a la fecha de nacimiento.

  

Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “Escribir una fecha según el limite de edad en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *