Error en horas negativas o al restar horas en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En los cálculos es normal que muestre error en horas negativas o al restar horas en Excel, ya que siempre deberán de ser positivas.

Si la fórmula de horas genera un resultado negativo, mostrará #### a lo ancho de toda la celda.

Error en horas negativas o al restar horas en Excel

Emplearemos las siguientes funciones, anidándolas:

  • Función TEXTO. Convierte un valor en texto, con un formato de número específico.

  • Función ABS. Devuelve el valor absoluto de un número (número sin signo).

 

Funeción Excel anidada =TEXTO(ABS(B3-A3);'-h:mm:ss')

Disponemos en la columna A las horas de entrada y en la columna B las horas de salida. Deseamos obtener la resta de los valores.

 

 ABC
1EntradaSalidaDiferencia
210:3503:30 
312:3207:39 
    1. Ir a: Celda C2 / Escribir:

      =B2-A2
    2. Verificar como muestra el error ############. Al no poder representar el valor negativo.

      Celda C2 mostrando ##### por la diferencia de B2-A2

 

 
  1. Ir a: Celda C3 / Escribir:

    =TEXTO(ABS(B3-A3);"-h:mm:ss")
  2. Verificar como muestra -4:53:00. Como la diferencia entre las horas.

    Celda C3 mostrando -4:53:00 como la diferencia de 7:39-12:32

    También se puede obtener con la función SI. Escribir: =SI(B3>A3;B3-A3;A3+1-B3) / Aplicar formato de celda tipo hora (hh:mm:ss).

Nivel de dificultad: Básico Excel Básico

47 comentarios en “Error en horas negativas o al restar horas en Excel

  • Explicación genial.
    Mi pregunta es la siguiente.
    Cual seria la formula cuando una A o B pueden ser mayor o menor
    A B A B
    10:00 12:00 12:00 10:00

  • Hola que tal, quiero restar dos horas, la de inicio y finalización en la misma celda. O sea, en vez de poner en una celda la hora de inicio y en otra la de finalizacion y luego en una tercera celda B2-A2 por ejemplo, quiero hacer la resta en una misma celda, por ejemplo 11:45-10:15 ¿ se puede?

    • Hola Paola,

      No se puede aplicar de forma sencilla, al aplicar la hora como valor considera que es un rango de filas.

      Si se convierte la hora a números entonces no aplicará la conversión de horas, minutos, segundos,

      Saludos.

  • Por ejm al hacer el pago (5:20 - 4:20)me excedo y pago 2 hrs demas 1 hr, pero para tenerlo presente y descontar en el futuro este resultado debe salir (-1), gracias

  • Hola que formula debo aplicar para este caso
    Por ejemplo e una columna me totaliza 16:00:00 y se tiene que efectuar solo 12:00:00 el resultado seria de -4:00:00, pero en el siguiente resultado seria 8:00:00 menos 12:00.00 dando el resultado de 4:00:00

  • Hola : Como puedo restar en una celda 24:00:00 menos un tiempo escrito en otra celda. por ejemplo:
    Si escribo en A1 y A2 estos tiempos y quiero que en B1 y B2 me entregue esas diferencias. Se puede hacer??

    A1: 22:23:10 B1: 24:00:00 - 22:23:10
    A2: 12:23:11 B2: 24:00:00 - 12:23:11

    Saludos

  • Es genial
    Pero como puedo hacer para que si la resta de horas sale a mi favor (me deben horas) salga positivo y si sale a favor de la empresa (debo horas) salga negativo?
    muchas gracias

  • Buenas tardes, yo quiero saber si puedo dentro de una sumatoria de tiempo restar tiempo concreto
    Ejemplo:=(D1-D2-(60 minutos))

    Algo similar

    De antemano muchas gracias

  • Encontre una manera mas facil
    Supongamos que en la celda C6 esta el valor menor y en la C5 el valor mayor
    =SI(C6<C5;-(C5-C6);(C6-C5)

  • Si se activa el sistema de fechas de 1904 en el libro, no es necesario hacer nada.
    Si el mismo libro contiene fechas, debeis tener cuidado y desactivar el cambio automático de fechas. Lo correcto es activar este sistema antes de empezar el libro, entonces no habrá ningun problema con las fechas.

  • Perfecto, pero una consulta como creo una regla para que en el cuadro que tengo los resultados que me salen en horas en negativo me resalten de otro color; he intentado creando reglas pero no me funciona, solo aplica para formato número o texto, mas no para formato en horas

  • que hacer si yo tengo un cuadro donde tengo hora entrada hora de salida menos los minutos de comida, aplico la formula en todo el cuadro y hay casillas donde me da negativo, como puedo hacer para sumar solo las horas positivas gracias de antemano poir su atención.

  • Estimado, necesito calcular dos horas (hora inicial) (hora final) estas de 24 horas.
    Ejemplo:
    Hora Inicial Hora Final Tiempo transcurrido
    3:45:00 PM 8:35:00 AM xxxx

    Si el tiempo es mayor a 2 horas que sea Rojo y menor en Verde

    Gracias por cualquier ayuda

    • Hola Cristián,

      A1= 3:45:00; B1= 8:35:00; C1 =B1-A1.
      En C1 deberás aplicar formato condicional con fórmula (0,0833 Representa 2 horas formato numérico):
      1. =B1-A1>0,0833 Formato Rojo.
      2. =B1-A1<0,0833 Formato Verde.

      Saludos.

  • Hola, cuando tengo estos dos reportes y debo sacar la cantidad de horas trabajadas, hora de ingreso 21:35:09 y hora de salida 6:05:55 al realizar el cálculo sale valor negativo y no es posible, lo he convertido , le he dado varios formatos a la celda pero no es posible

    21:35:09 6:05:55

  • Hola, buenas tardes

    tengo una duda, necesito sumar horas positivas y negativas, por ejemplo
    la hora de la entrada es a las 7:00 am la salida a las 5:00 pm; eso me da un total de 10 horas, en otra casilla tengo esas 10:00 horas que restadas con el total debe dar 0. Pero si por ejemplo la salida de uno es 6:00 pm debe dar +1:00 o si la salida es 3:00 el debe dar -2:00. y a su ves al sumar estos negativos con positivos deberá dar -1:00.
    por favor si me puedes ayudar
    Mil gracias y quedo atenta

    • Hola Johana,

      Prueba con la fórmula: =SI(B2-A2=VALOR("10:00:00");0;SI(B2-A2>VALOR("10:00:00");(0,416666-(B2-A2))*(-1);TEXTO(10-MAX(A2:B2)-MIN(A2:B2);"-H::MM")))

      El valor negativo se mostrará con formato texto (hh:mm).

      Saludos

  • Hola, buenas tardes:
    Necesito sumar horas entre diferentes celdas con distinto valores, unos positivos y otros negativos
    Por ejemplo:
    =SI(G16< F16;"-"&TEXTO(F16-G16;"hh:mm");TEXTO(G16-F16;"hh:mm")) + 1:00
    =SI(G17< F17;"-"&TEXTO(F17-G17;"hh:mm");TEXTO(G17-F17;"hh:mm")) - 1:00
    =SI(G18< F18;"-"&TEXTO(F18-G18;"hh:mm");TEXTO(G18-F18;"hh:mm")) 0:00

    el resultado de la celta final debiera de ser =0

  • HOLA BUENAS TARDES NECESITO UNA FORMULA QUE ME DEVUELVA EL TOTAL DE HORAS YA SEAN POSITIVAS O NEGATIVAS DE UNA JORNADA DE TRABAJO DE 8 HS 7HS Y 6HS, YA QUE ME LLEGA UN ARCHIVO EXCEL CON EL HORARIO DE ENTRADA Y SALIDA DESDE UN RELOJ BIOMETRICO.- DESDE GRACIAS. HECTOR

  • Buenas tardes, necesito hacer operaciones con horas, pero ya con el resultado de la jornada, es decir sumar 1:30 + 0:20 - 1:45. El primer problema que me encuentro es que no puedo introducir en la celda el día en el que el resultado del horario es negativo, por lo que ya no he podido probar para hacer la suma de todos los días y saber si se han hecho horas de más o de menos.
    Muchas gracias

Responder a Esteban Cancelar la respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.