Error en horas negativas o al restar horas en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En los cálculos es normal que muestre error en horas negativas o al restar horas en Excel, ya que siempre deberán de ser positivas.

Si la fórmula de horas genera un resultado negativo, mostrará #### a lo ancho de toda la celda.

Error en horas negativas o al restar horas en Excel

Emplearemos las siguientes funciones, anidándolas:

  • Función TEXTO. Convierte un valor en texto, con un formato de número específico.

  • Función ABS. Devuelve el valor absoluto de un número (número sin signo).

 

Funeción Excel anidada =TEXTO(ABS(B3-A3);'-h:mm:ss')

Disponemos en la columna A las horas de entrada y en la columna B las horas de salida. Deseamos obtener la resta de los valores.

 ABC
1EntradaSalidaDiferencia
210:3503:30 
312:3207:39 
  1. Ir a: Celda C2 / Escribir:

    =B2-A2
  2. Verificar como muestra el error ############. Al no poder representar el valor negativo.

    Celda C2 mostrando ##### por la diferencia de B2-A2
  3.  

  1. Ir a: Celda C3 / Escribir:

    =TEXTO(ABS(B3-A3);"-h:mm:ss")
  2. Verificar como muestra -4:53:00. Como la diferencia entre las horas.

    Celda C3 mostrando -4:53:00 como la diferencia de 7:39-12:32

    También se puede obtener con la función SI. Escribir: =SI(B3>A3;B3-A3;A3+1-B3) / Aplicar formato de celda tipo hora (hh:mm:ss).

Nivel de dificultad: Básico Excel Básico

21 comentarios en “Error en horas negativas o al restar horas en Excel

  • Explicación genial.
    Mi pregunta es la siguiente.
    Cual seria la formula cuando una A o B pueden ser mayor o menor
    A B A B
    10:00 12:00 12:00 10:00

  • Hola que tal, quiero restar dos horas, la de inicio y finalización en la misma celda. O sea, en vez de poner en una celda la hora de inicio y en otra la de finalizacion y luego en una tercera celda B2-A2 por ejemplo, quiero hacer la resta en una misma celda, por ejemplo 11:45-10:15 ¿ se puede?

    • Hola Paola,

      No se puede aplicar de forma sencilla, al aplicar la hora como valor considera que es un rango de filas.

      Si se convierte la hora a números entonces no aplicará la conversión de horas, minutos, segundos,

      Saludos.

  • Por ejm al hacer el pago (5:20 – 4:20)me excedo y pago 2 hrs demas 1 hr, pero para tenerlo presente y descontar en el futuro este resultado debe salir (-1), gracias

  • Hola que formula debo aplicar para este caso
    Por ejemplo e una columna me totaliza 16:00:00 y se tiene que efectuar solo 12:00:00 el resultado seria de -4:00:00, pero en el siguiente resultado seria 8:00:00 menos 12:00.00 dando el resultado de 4:00:00

  • Hola : Como puedo restar en una celda 24:00:00 menos un tiempo escrito en otra celda. por ejemplo:
    Si escribo en A1 y A2 estos tiempos y quiero que en B1 y B2 me entregue esas diferencias. Se puede hacer??

    A1: 22:23:10 B1: 24:00:00 – 22:23:10
    A2: 12:23:11 B2: 24:00:00 – 12:23:11

    Saludos

  • Es genial
    Pero como puedo hacer para que si la resta de horas sale a mi favor (me deben horas) salga positivo y si sale a favor de la empresa (debo horas) salga negativo?
    muchas gracias

  • Buenas tardes, yo quiero saber si puedo dentro de una sumatoria de tiempo restar tiempo concreto
    Ejemplo:=(D1-D2-(60 minutos))

    Algo similar

    De antemano muchas gracias

  • Encontre una manera mas facil
    Supongamos que en la celda C6 esta el valor menor y en la C5 el valor mayor
    =SI(C6<C5;-(C5-C6);(C6-C5)

  • Si se activa el sistema de fechas de 1904 en el libro, no es necesario hacer nada.
    Si el mismo libro contiene fechas, debeis tener cuidado y desactivar el cambio automático de fechas. Lo correcto es activar este sistema antes de empezar el libro, entonces no habrá ningun problema con las fechas.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *