Encontrar filas duplicadas en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Al trabajar con datos siempre necesitamos encontrar filas duplicadas en Excel.

Encontrar filas duplicadas en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SI. Comprueba si se cumple una condición y devuelve un valor si se evalúa como verdadero y otro si se evalúa como falso.

  • Función SUMAPRODUCTO. Devuelve la suma de los productos de los componentes de la matriz correspondiente.

En la columna A disponemos de las fechas y en la columna B la zona y en la columna C el importe para obtener las filas repetidas.

 ABC
1Fecha ZonaImporte
201/01/2019Norte5000
301/01/2019Norte5000
401/01/2019Norte1000
501/01/2019Sur5000
612/05/2019Sur2500
7   
806/08/2019Norte3500
901/01/2019Norte5000
1012/09/2018Norte5000
 
  1. Ir a: Celda D2 / Escribir:

    =SI(SUMAPRODUCTO(($A$2:$A$10=A2)*1;($B$2:$B$10=B2)*1;($C$2:$C$10=C2)*1)>1;"Duplicado";"")
  2. Copiar la celda D2 / Pegar en el tango D3:D10.

  3. Verificar como muestra la fila 2, 3 y 9 (01/01/2019, Norte, 5000).

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.