Eliminar mensaje de error en BUSCARV de Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Si empleamos la función BUSCARV de Excel, y el valor buscado está vacío o no coincide con el valor del origen de los datos, Excel muestra el error #N/A, necesitando eliminar mensaje de error en BUSCARV.

En la columna A disponemos del nombre de las empresas y en la columna B, el importe facturado. En la Celda D2 escribiremos la empresa para que nos muestre el importe en E2.

Emplearemos las siguientes funciones, anidándolas:

  • Función BUSCARV. Busca un valor específico en la columna más a izquierda de una matriz y devuelve el valor en la misma fila de una columna especificada en la tabla.

  1. Ir a: Celda E2 / Escribir:

    =BUSCARV(D2;A2:B10;2;FALSO)

    Función sin corrección de errores.

    Eliminar mensaje de error en BUSCARV de Excel: Celda E2 con función BUSCARV sin corregir errores.
  2. Ir a: Celda D2 / Borrar el valor. Al estar vacío, en E2 se mostrará el error #N/A.

  3. Ir a: Celda D2 / Escribir: Empresa 55. Al no encontrar el valor, en E2 se mostrará el error #N/A.

Disponemos de diferentes métodos para eliminar mensaje de error en BUSCARV (#N/A).
  • Función SI. Comprueba si se cumple una condición y devuelve un valor si es verdadero y otro valor si es falso.

    – Ir a: Celda E3 / Escribir:

=SI(D2=FALSO;"";BUSCARV(D2;A2:B10;2;FALSO))

Evalúa sí D2 está vacía, mostrando la celda vacía, en caso contrario aplica BUSCARV. Evitamos mostrar error si en D2 no hay nada escrito, si el valor no corresponde con la columna A, mostrará el error.

Cualquier otro error, se mostrará en la celda E3.

  • Función TIPO. Devuelve un número (16) que indica el tipo de datos de un valor (error).

    – Ir a: Celda E4 / Escribir:

=SI(TIPO(BUSCARV(D2;A2:B10;2;FALSO))=16;"";BUSCARV(D2;A2:B10;2;FALSO))

Evalúa si al calcular BUSCARV se produce el error 16 (#N/A), mostrando celda vacía, en caso contrario aplica BUSCARV. Evitamos mostrar error si en D2 no hay nada escrito o si el valor no corresponde con la columna A.

Cualquier otro error, NO se mostrará en la celda E4.

  • Función ESNOD. Comprueba si el valor de una celda es error #N/A, mostrando VERDADERO o FALSO.

    – Ir a: Celda E5 / Escribir:

=SI(ESNOD(BUSCARV(D2;A2:B10;2;FALSO));"";BUSCARV(D2;A2:B10;2;FALSO))

Evalúa si al calcular BUSCARV se produce el error #N/A, mostrando celda vacía, en caso contrario aplica BUSCARV. Evitamos mostrar error si en D2 no hay nada escrito o si el valor no corresponde con la columna A.

Cualquier otro error, se mostrará en la celda E5.

  • Función ESERROR. Comprueba si el valor de una celda es un error, mostrando VERDADERO o FALSO.

    – Ir a: Celda E6 / Escribir:

=SI(ESERROR(BUSCARV(D2;A2:B10;2;FALSO));"";BUSCARV(D2;A2:B10;2;FALSO))

Evalúa si al calcular BUSCARV se produce un error, mostrando celda vacía, en caso contrario aplica BUSCARV. Evitamos mostrar error si en D2 no hay nada escrito o si el valor no corresponde con la columna A.

Cualquier otro error, NO se mostrará en la celda E6.

  • Función SIERROR. Devuelve el valor especificado si una fórmula se evalúa como un error; de lo contrario, devuelve el resultado de la fórmula.

    – Ir a: Celda E7 / Escribir:

=SIERROR(BUSCARV(D2;A2:B10;2;FALSO);"")

Evalúa si al calcular BUSCARV se produce un error, mostrando celda vacía, en caso contrario aplica BUSCARV. Evitamos mostrar error si en D2 no hay nada escrito o si el valor no corresponde con la columna A.

Cualquier otro error, NO se mostrará en la celda E7.

  • Función SI.ND. Devuelve el valor que se especifica, si la expresión se convierte en #N/A; de lo contrario, devuelve el resultado de la expresión.

    – Ir a: Celda E8 / Escribir:

=SI.ND(BUSCARV(D2;A2:B10);2;FALSO);""). Sólo en Excel 2013.

Evalúa si al calcular BUSCARV se produce un error, de lo contrario, devuelve el valor de BUSCARV.

Cualquier otro error, se mostrará en la celda E8.

Eliminar mensaje de error en BUSCARV de Excel: Función BUSCARV anidada con otras funciones para ocultar error #N/A.

 

– Consultar: Otras alternativas a BuscarV.

– Consultar: Diferenciar mayúsculas y minúsculas en BuscarV.

– Consultar: BuscarV en varias hojas.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *