El peso ideal con Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Deseamos realizar una plantilla que analice el peso ideal con Excel por diferentes métodos.

El peso ideal con Excel: Plantilla Excel para controlar el peso ideal
  • DATOS DE ENTRADA: SEXO

  1. Ir a: Celda AA2 / Escribir: Hombre. Primera referencia para el tipo de sexo.

  2. Ir a: Celda AA3 / Escribir: Mujer. Segunda referencia para el tipo de sexo.

    El peso ideal con Excel: Rango de datos para la validación de datos
  3. Ir a: Celda C4 / Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará cuadro de diálogo.

    El peso ideal con Excel: Cuadro de diálogo Validación: tipo lista
  4. Ir a: Permitir / Seleccionar: Lista.

  5. Ir a: Origen / Seleccionar el rango AA2:AA3. Rango con los datos para el tipo de sexo.

    Celda C4 con validación de lista para el sexo
  • DATOS DE ENTRADA: ALTURA

  1. Ir a: Celda AB2 / Escribir: 130. Como el valor mínimo de la altura en centímetros.

  2. Seleccionar el rango: AB2:AB127. Rango donde aplicar serie hasta 255 centímetros.

  3. Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Modificar / Rellenar /Series. Mostrará cuadro de diálogo.

    El peso ideal con Excel: Cuadro de diálogo Series: Tipo lineal con incrementos 1.
  4. Pulsar el botón: Aceptar. Para aplicar la serie con los valores predeterminados.

  5. Ir a: Celda E4 / Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará cuadro de diálogo.

  6. Ir a: Permitir / Seleccionar: Lista.

  7. Ir a: Origen / Seleccionar el rango AB2:AB127. Rango con los datos para seleccionar la altura.

  • DATOS DE ENTRADA: PESO

  1. Ir a: Celda AC2 / Escribir: 25. Como el valor mínimo del peso en kilogramos.

  2. Seleccionar el rango: AC2:AC189. Rango donde aplicar serie hasta 212 Kilogramos.

  3. Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Modificar / Rellenar /Series. Mostrará cuadro de diálogo.

  4. Pulsar el botón: Aceptar. Para aplicar la serie con los valores predeterminados.

  5. Ir a: Celda G4 / Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará cuadro de diálogo.

  6. Ir a: Permitir / Seleccionar: Lista.

  7. Ir a: Origen / Seleccionar el rango AC2:AC189. Rango con los datos para seleccionar el peso.

  • DATOS DE ENTRADA: AÑOS

  1. Ir a: Celda AD2 / Escribir: 17. Como el valor mínimo de los años.

  2. Seleccionar el rango: AD2:AD95. Rango donde aplicar serie hasta 110 años.

  3. Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Modificar / Rellenar /Series. Mostrará cuadro de diálogo.

  4. Pulsar el botón: Aceptar. Para aplicar la serie con los valores predeterminados.

  5. Ir a: Celda I4 / Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Herramientas de datos / Validación de datos / Validación de datos. Mostrará cuadro de diálogo.

  6. Ir a: Permitir / Seleccionar: Lista.

  7. Ir a: Origen / Seleccionar el rango AD2:AC95. Rango con los datos para seleccionar los años de la persona.

El peso ideal con Excel: Resultados para el peso ideal
  • RESULTADO: PESO IDEAL

  1. Ir a: Celda F8 / Escribir:

    =SI(C4="Hombre";AH1;SI(C4="Mujer";AH2;"Error"))
  2. Ir a: Celda AG1 / Escribir:

    =0,75*E4-62,5
  3. Ir a: Celda AH1 / Escribir:

    =E4-100-((E4-150)/AI1)
  4. Ir a: Celda AI1 / Escribir:

    4
  5. Ir a: Celda AG2 / Escribir:

    =0,675*E4-56,25
  6. Ir a: Celda AH2 / Escribir:

    =E4-100-((E4-150)/AI2)
  7. Ir a: Celda AI2 / Escribir:

    2
  • RESULTADO: SU PESO

  1. Ir a: Celda F10 / Escribir:

    =G4
  • RESULTADO: DIFERENCIA

  1. Ir a: Celda F12 / Escribir:

    =F10-F8
  • RESULTADO: SITUACIÓN

  1. Ir a: Celda F14 / Escribir:

    =AY2
  • PORCENTAJES COMPARATIVOS

  1. Ir a: Celda AL2 / Escribir: -20%

  2. Ir a: Celda AL3 / Escribir: -15%

  3. Ir a: Celda AL4 / Escribir: -10%

  4. Ir a: Celda AL5 / Escribir: -5%

  5. Ir a: Celda AL6 / Escribir: Peso ideal

  6. Ir a: Celda AL7 / Escribir: 5%

  7. Ir a: Celda AL8 / Escribir: 10%

  8. Ir a: Celda AL9 / Escribir: 15%

  9. Ir a: Celda AL10 / Escribir: 20%

    El peso ideal con Excel: Rango de comparación con porcentaje de aumento o disminución de peso.
  10. Ir a: Celda AM2 / Escribir: =AK2

  11. Copiar la celda AM2 / Pegar en el rango: AM3:AM10.

  12. Ir a: Celda AN2 / Escribir: 1

  13. Seleccionar el rango: AN2:AN10. Rango donde aplicar serie hasta 9.

  14. Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Modificar / Rellenar /Series. Mostrará cuadro de diálogo.

  15. Pulsar el botón: Aceptar. Para aplicar la serie con los valores predeterminados.

  16. Ir a: Celda AK2 / Escribir:

    =SI($S$6<=H12;"OK";"NO")
  17. Ir a: Celda AK3 / Escribir:

    =SI(Y($S$6<=H13;$S$6>H12);"OK";"NO")
  18. Copiar la celda AK3 / Pegar en el rango: AK4:AK10.

  19. Ir a: Celda AK1 / Escribir:

    =BUSCARV("OK";AK2:AN10;4;FALSO)
  20. Ir a: Celda AP1 / Escribir:

    =BUSCARV(AK1;AP2:AQ10;2;FALSO)
  21. Ir a: Celda AQ2 / Escribir: -20%

  22. Ir a: Celda AQ3 / Escribir: -15%

  23. Ir a: Celda AQ4 / Escribir: -10%

  24. Ir a: Celda AQ5 / Escribir: -5%

  25. Ir a: Celda AQ6 / Escribir: Peso ideal

  26. Ir a: Celda AQ7 / Escribir: 5%

  27. Ir a: Celda AQ8 / Escribir: 10%

  28. Ir a: Celda AQ9 / Escribir: 15%

  29. Ir a: Celda AQ10 / Escribir: 20%

  30. Ir a: Celda AP2 / Escribir: 1

  31. Seleccionar el rango: AP2:AP10. Rango donde aplicar serie hasta 9.

  32. Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Modificar / Rellenar /Series. Mostrará cuadro de diálogo.

  33. Pulsar el botón: Aceptar. Para aplicar la serie con los valores predeterminados.

  34. Ir a: Celda H8 / Escribir: =AL2

  35. Ir a: Copiar la celda H8 / Pegar en el rango H9:H17.

  36. Ir a: Celda I8 / Escribir:

    =$I$12*(-H8)+I9
  37. Ir a: Copiar la celda I8 / Pegar en el rango I9:I11 y en el rango I13:I17.

  38. Ir a: Celda I12 / Escribir:

    =F8

    Podemos aplicar formato de celda al rango J8:K16, y formato de número personalizado a K8:K16 para que muestre Kg.

  • GRÁFICO: ORIGEN DE DATOS

  1. Ir a: Celda AS2 / Escribir: =E8.

  2. Ir a: Celda AS3 / Escribir: =E10.

  3. Ir a: Celda AS4 / Escribir: =E12.

  4. Ir a: Celda AT2 / Escribir: =F8.

  5. Ir a: Celda AT3 / Escribir: =F10.

  6. Ir a: Celda AT4 / Escribir: =F12.

  7. GRÁFICO. Seleccionar el rango AS2:AT4. Rango de datos para el gráfico.

  8. Ir a: Cinta de opciones / Pestaña: Insertar / Grupo: Gráficos / Dispersión / Dispersión con líneas suaves y marcadores. Tipo deseado para el gráfico.

  9. Personalizar el gráfico, línea, marcadores, escala, línea de tendencia, etc.

    El peso ideal con Excel: Gráfico de dispersión que representa los datos de AS2:AT4
  • SITUACIÓN

  1. Ir a: Celda AV3 / Escribir:

    =F8-F10
  2. Ir a: Celda AY2 / Escribir:

    =SI(AV3=0;AZ3;SI(AV3>0;AZ2;SI(AV3<0;AZ4)))
  3. Ir a: Celda AZ2 / Escribir: Bajo Peso.

  4. Ir a: Celda BA2 / Escribir una descripción de Bajo Peso a mostrar en la celda C18.

  5. Ir a: Celda AZ3 / Escribir: Normopeso.

  6. Ir a: Celda BA3 / Escribir una descripción de Normopeso a mostrar en la celda C18.

  7. Ir a: Celda AZ4 / Escribir: Sobrepeso.

  8. Ir a: Celda BA3 / Escribir una descripción de Sobrepeso a mostrar en la celda C18.

  9. Ir a: Celda C18 / Escribir:

    =SI(F14="Normopeso";BA3;SI(F14="Sobrepeso";BA4;SI(F14="Bajo Peso";BA2;"")))
El peso ideal con Excel: Resultado de otros métodos aplicados para el peso ideal.
  • MÉTODO DEVINE

  1. El peso ideal: Fórmula método Devine

    Ir a: Celda E35 / Escribir:

    =SI(D4="Hombre";50+0,91*(F4-152,4);45,5+0,91*(F4-152,4))
  • MÉTODO ROBINSON

  1. El peso ideal con Excel: Fórmula método Robinson

    Ir a: Celda E36 / Escribir:

    =SI(D4="Hombre";50+0,75*(F4-152,4);45,5+0,67*(F4-152,4))
  • MÉTODO HAMWI

  1. El peso ideal: Fórmula método Hamwi

    Ir a: Celda E37 / Escribir:

    =SI(D4="Hombre";50+1,06*(F4-152,4);45,5+0,866*(F4-152,4))
  • MÉTODO LEMMENS

  1. El peso ideal: Fórmula método Lemmens

    Ir a: CeldaE38 / Escribir:

    =22*(F4/100*F4/100)
  • MÉTODO TRAVIA

  1. El peso ideal con Excel: Fórmula método Travia

    Ir a: Celda F39 / Escribir:

    =(1,012*F4)-107,5
  • MÉTODO METROPOLITAN LIFE INS. COMPANY

  1. El peso ideal con Excel: Fórmula método

    Ir a: Celda F40 / Escribir:

    =50+0,75*(F4-150)
  • MÉTODO LORENZ

  1. El peso ideal: Fórmula método Lorenzt

    Ir a: Celda H35 / Escribir:

    =F4-100-((F4-150)/SI(D4="Hombre";4;2,5))

    El peso ideal: Fórmula método Lorenzt

  2. CONSIDERANDO EDAD. Ir a: Celda H36 / Escribir:

    =F4-100-((F4-150)/4)+(L4-20)/SI(D4="Hombre";4;2)
  • MÉTODO PERROULT

  1. El peso ideal con Excel: Fórmula método Perroult

    Ir a: Celda H37 / Escribir:

    =F4-100+(L4/10*9/10)
  • MÉTODO ÍNDICE DE BROCCA

  1. El peso ideal con Excel: Fórmula método Broca

    Ir a: Celda H38 / Escribir:

    =SI(D4="Hombre";F4-100;F4-104)
  • MÉTODO MILLER

  1. El peso ideal con Excel: Fórmula método Miller

    Ir a: Celda H39 / Escribir:

    =SI(D4="Hombre";50+0,555*(F4-152,4);45,5+0,535*(F4-152,4))
  • MÉTODO KEYS

  1. El peso ideal con Excel: Fórmula método Keys

    Ir a: Celda H40 / Escribir:

    =SI(D4="Hombre";F4^2*22,1/10000;F4^2*20,6/10000)
  • MEJORA VISUAL

  1. OCULTAR COLUMNAS. Ocultar las columnas AA:BB con el origen de los cálculos.

  2. ADECUAR EL GRÁFICO.

  3. FORMATO VALOR DE CELDAS. Aplicamos el formato deseado a los valores, mostrando unidades, decimales, etc.

  4. DESBLOQUEAR CELDAS Y PROTEGER HOJA.

Disponiendo así de una plantilla que nos permita calcular el peso ideal con Excel.

Nivel de dificultad: Avanzado Excel Avanzado

6 comentarios en “El peso ideal con Excel

  • BUENAS NOCHES, CREO QUE LE FALTA LA DESCRIPCIÓN DE LA CELDA “BF2” QUE INDICA EL TIPO DE PESO….
    GRACIAS EXCELENTE EXPLICACION.

    • Hola Alexis,

      La celda BF2 no incluye información.

      La descripción sobre el peso se aplica en las celdas BA2 (Bajo peso), BA3 (peso saludable) y BA4 (sobrepeso). Que se mostrarán en la celda C18, según se indica en el apartado “SITUACIÖN”.

      Gracias por tu comentario.

    • La referencia que hace de la celda BF2 no es correcta me imagino es un error en lugar de llamar a esa celda debemos poner AY2, ahí si nos saldrá la situación, hice ese cambio y me salio correcta la situación.

      Y en las formulas si les marca error en lugar de poner “;” ponga solo “,”, soy de México y me marcaban error las celdas y al quitar el “punto y coma” y poner solo “coma” me aceptaban las formulas.

  • Las celdas AK2 Y AK3 hacen referencia a la celda $S$6 (puntos 16 y 17) que se encuentra en blanco.
    Saludos
    PD. Muchas gracias por el tutorial

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *