El juego de Bingo en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Si eres aficionado al bingo o quieres un momento de descanso en tu trabajo, puedes crear el juego de bingo en Excel.

Los antecedentes al juego del bingo se sitúan en la unificación de Italia en 1530 mediante un juego denominado "Il Giocco del Lotto d`Italia", juego similar al de la lotería.

Sobre 1770 en la corte francesa se popularizó un juego "Le Lotto" con las reglas similares a las conocidas en la actualidad, los cartones se dividieron en 3 filas horizontales y 9 columnas verticales y en 1800 se extendió por toda Europa.

El juego de Bingo en Excel

En 1929 en las ferias y festivales de Atlanta (Estados Unidos) el comerciante Edwin S. Lowe, identificó el juego que tenía mucho éxito denominado "BEANO".

A su regreso a Nueva York creó su propia versión, pasando a denominarse "Bingo" y popularizándose por toda la ciudad.

Fue un cura de la iglesia de Wilkes-Barre (Pennsylvania) que aplicaba el juego para recaudar fondos para la iglesia. El cura contactó con un matemático de la universidad de Columbia llamado Carl Leffler, para establecer un método para incrementar la cantidad de combinaciones en los cartones.

En los años 1940, el Bingo se expande por todo el país.

En 1977 se autorizó el bingo en España.

  

Deseamos crear un panel de bingo que simule al bombo del Bingo:

 

  • NÚMEROS SALIDOS

Mediante fórmulas y funciones creamos las referencias para identificar las bolas salidas, posteriormente se ocultarán las columnas.

  1. Ir a: Celda AO2 / Escribir:

    =SI(AQ2=" ";1;0)
  2. Ir a: Celda AO3 / Escribir:

    =SI(AQ3=" ";AO2+1;AO2)
  3. Copiar la celda AO3 / Pegar en el rango: A04:AO76.

    Hoja Excel con celda AO3 con función =SI(AQ3=" ";AO2+1;AO2)
  4. Ir a: Celda AP2 / Escribir: 1.

  5. Seleccionar la celda AP2 / situar el cursor del ratón en el punto de y arrastrar hasta la celda AP76.

  6. Pulsar sobre el botón de opciones / Seleccionar: Serie de relleno.

    Hoja Excel con celda AP2 con valor 1 del relleno
  7. Ir a: Celda AS2 / Escribir:

    =SI(M14=1;"FIN";ALEATORIO.ENTRE(1;M14))
    Hoja Excel con celda AS2 con función =SI(M14=1;"FIN";ALEATORIO.ENTRE(1;M14))
  8. Ir a: Celda AT2 / Escribir:

    =SI(M14=1;0;BUSCARV(AS2;AO2:AP76;2;FALSO))
    Hoja Excel con celda AT2 con función =SI(M14=1;0;BUSCARV(AS2;AO2:AP76;2;FALSO))
  • PANEL DE NÚMEROS

Simulamos un panel electrónico para que muestre los números aparecidos:

  1. Ir a: Celda C3 / Escribir: 1.

  2. Seleccionar la celda / situar el cursor del ratón en el punto de y arrastrar hasta la celda Q3.

  3. Pulsar sobre el botón de opciones / Seleccionar: Serie de relleno. O escribir del 1 al 15.

    Hoja Excel con celda C3 con relleno de números
  4.  

  5. Ir a: Celda C4 / Escribir: 16.

  6. Seleccionar la celda / situar el cursor del ratón en el punto de y arrastrar hasta la celda Q4.

  7. Pulsar sobre el botón de opciones / Seleccionar: Serie de relleno. O escribir del 16 al 30.

  8.  

  9. Ir a: Celda C5 / Escribir: 31.

  10. Seleccionar la celda / situar el cursor del ratón en el punto de y arrastrar hasta la celda Q5.

  11. Pulsar sobre el botón de opciones / Seleccionar: Serie de relleno. O escribir del 31 al 45.

  12.  

  13. Ir a: Celda C6 / Escribir: 46.

  14. Seleccionar la celda / situar el cursor del ratón en el punto de y arrastrar hasta la celda Q6.

  15. Pulsar sobre el botón de opciones / Seleccionar: Serie de relleno. O escribir del 46 al 60.

  16.  

  17. Ir a: Celda C7 / Escribir: 61.

  18. Seleccionar la celda / situar el cursor del ratón en el punto de y arrastrar hasta la celda Q7.

  19. Pulsar sobre el botón de opciones / Seleccionar: Serie de relleno. O escribir del 61 al 75.

  20. Ir a: Celda Y3 / Escribir:

    =SI(BUSCARV(C3;$AP$2:$AQ$76;2;FALSO)="ok";C3;0)
  21. Copiar la celda Y3 / Pegar en el rango: Y3:AM7.

    Hoja Excel con celda Y3 con función =SI(BUSCARV(C3;$AP$2:$AQ$76;2;FALSO)="ok";C3;0)
  • RESUMEN DE VALORES

  1. Ir a: Celda L10 / Escribir: Número: Como rótulo para el valor.

  2. Ir a: Celda M10 / Escribir: 0.

  3. Ir a: Celda L12 / Escribir: Números salidos: Como rótulo para el valor.

  4. Ir a: Celda M12 / Escribir:

    =75-M14
  5. Ir a: Celda L14 / Escribir: Números pendientes: Como rótulo para el valor.

  6. Ir a: Celda M14 / Escribir:

    =MAX(AO2:AO76)
  • FORMATO CONDICIONAL

Aplicamos formato condicional para que remarque en otro color el nuevo número y con otro color los números ya salidos. Es importante insertar el formato condicional en dicho orden.

  1. NÚMEROS SALIDOS. Seleccionar el rango C3:Q7. Rango donde aplicar el formato condicional.

  2. Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Estilos / Formato condicional / Nueva regla. Mostrará cuadro de diálogo de nueva regla.

  3. Ir a: Seleccionar un tipo de regla / Clic sobre: Utilice una fórmula que determine las celdas para aplicar formato. Tipo de regla deseado.

    Ventana Editar regla de formato con fórmula =Y3>0
  4. Ir a: Dar formato a los valores donde esta fórmula sea verdadera / Escribir:

    =Y3>0

    Escribir Y3 como referencia relativa (sin signo de dólar).

  5. Pulsar el botón: Formato. Mostrará el cuadro de diálogo de formato de celdas.

  6. Ir a: Pestaña Fuente / Clic sobre color amarillo. O el color deseado para los números salidos.

  7. Pulsar el botón Aceptar. Cierra la ventana de formato de celdas.

  8. Pulsar el botón Aceptar. Cierra la ventana de nueva regla de formato.

  9. NUEVO NÚMERO. Seleccionar el rango C3:Q7. Rango donde aplicar el formato condicional.

  10. Ir a: Cinta de opciones / Pestaña: Inicio / Grupo: Estilos / Formato condicional / Nueva regla. Mostrará cuadro de diálogo de nueva regla.

  11. Ir a: Seleccionar un tipo de regla / Clic sobre: Utilice una fórmula que determine las celdas para aplicar formato. Tipo de regla deseado.

    Ventana Editar regla de formato con fórmula =C3=$M$10
  12. Ir a: Dar formato a los valores donde esta fórmula sea verdadera / Escribir:

    =C3=$M$10

    Escribir C3 como referencia relativa (sin signo de dólar).

  13. Pulsar el botón: Formato. Mostrará el cuadro de diálogo de formato de celdas.

  14. Ir a: Pestaña Fuente / Clic sobre color rojo. O el color deseado para el nuevo número.

  15. Pulsar el botón Aceptar. Cierra la ventana de formato de celdas.

  16. Pulsar el botón Aceptar. Cierra la ventana de nueva regla de formato.

  • MACRO: NUEVO BINGO

Creamos una macro que borre los valores del bingo anterior, permitiendo crear un nuevo juego.

  1. Pulsar la tecla Alt y mantener pulsada / Pulsar la tecla F11. Mostrará el editor de Visual Basic.

  2. Ir a: Barra de Menú / Insertar / Módulo. Mostrará la ventana del módulo donde escribimos la macro.

  3. Escribir el código de la macro:

Sub Borra()

Sheets("Hoja1").Range("AQ2:AQ76").FormulaR1C1 = " "

Sheets("Hoja1").Range("M10").FormulaR1C1 = 0

End Sub

– Range("AQ2:AQ76"). Borra en la hoja1 la referencia a las bolas salidas en el panel bingo.

– Range("M10"). Borra en la hoja1 el último número en el panel bingo.

  • MACRO: NUEVA BOLA

Creamos una macro que muestre el valor aleatorio para la nueva bola.

  1. Escribir el código de la macro a continuación de la anterior:

Sub Bola()

Sheets("Hoja1").Range("M10").FormulaR1C1 = "=Hoja1!R2C46"

nuevabola = Sheets("Hoja1").Range("M10").Value

Sheets("Hoja1").Range("M10").Value = nuevabola

Sheets("Hoja1").Range("AQ" & 1 + nuevabola).FormulaR1C1 = "ok"

If Range("M10").Value = 0 Then

MsgBox "¡ Bingo Finalizado ! " & vbNewLine & vbNewLine & " _
Pulsar NUEVO BINGO, para una nueva partida.", vbInformation

End If

End Sub

– "=Hoja1!R2C46" Toma el valor de la celda AT2

– nuevabola Toma la variable de M10, para insertar ok en la columna AQ.

– MsgBox Muestra mensaje de bingo finalizado.

  • DISEÑO PANEL BINGO

Aplicamos el diseño al panel de bingo: formato de celdas, formato de fuentes, ocultamos las columnas Y:AT e insertamos botones para ejecutar las macros, etc.

Hoja Excel con diferentes diseños en panel de bingo
  • JUGANDO AL BINGO

Terminada la plantilla o simulador para el juego de Bingo en Excel, procedemos a ejecutar las macros para comenzar.

  1. Ir a: Cinta de Opciones / Pestaña: Programador o Desarrollador (según la versión Excel) / Grupo: Código / Macros; O también, Atajo de teclado Alt+F8. Mostrará cuadro de diálogo de macro.

  2. Ir a: Nombre de la macro / Clic sobre la macro:

    – BORRAR. O pulsar el botón de la macro. Para borrar la jugada anterior.

    – BOLA repetidas veces. O pulsar el botón de la macro, para ir mostrando los números.

  3. Pulsar el botón Ejecutar. Reproducirá la macro.

Nivel de dificultad: Experto VBA-Macros Excel Experto VBA – Macros

9 comentarios en “El juego de Bingo en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *