El doble negativo (--) en fórmulas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

El doble signo negativo en fórmulas de Excel sirve para forzar valores lógicos o booleanos a valores numéricos, es decir, convierte VERDADERO en 1 y FALSO en 0.

El doble negativo (--) en fórmulas Excel

En la celda A1 disponemos del valor 3 y en B1 del valor 2. Deseamos evaluar si A1 es mayor que B1.

  1. Ir a: Celda C1 / Escribir: =A1>B1. Mostrará VERDADERO al cumplir la condición.

  2. Ir a: Celda C2 / Escribir: = --(A1>B1). Mostrará 1 al cumplir la condición, cambiando VERDADERO por 1. O también como equivalente:

  3. Ir a: Celda C3 / Escribir: =(A1>B1)*1.

  4. Ir a: Celda C4 / Escribir: =(A1>B1)+0.

  5. Ir a: Celda C5 / Escribir: =N(A1>B1).

 
  • CASO PRÁCTICO

En el rango A2:A6 disponemos de una serie de nombres y deseamos conocer los que tienen más de 5 caracteres.

  1. Ir a: Celda C2 / Escribir:

    =SUMAPRODUCTO(LARGO(A2:A6)>5)

    Mostrará el resultado 0. Al requerir la función los valores numéricos y no lógicos.

  2. Ir a: Celda C3 / Escribir:

    =SUMAPRODUCTO(--(LARGO(A2:A6)>5))

    Mostrará el resultado 2. Como el número de nombres con más de 5 caracteres (Encarnación y Francisco), tratados como números.

Nivel de dificultad: Básico Excel Básico

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.