Día de la semana en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Día de la semana en Excel, ¿Qué día corresponde a una fecha?

Día de la semana en Excel

Emplearemos las siguientes funciones, anidándolas:

  • Función DIASEM. Convierte un número en el día de la semana correspondiente.
  • Función SI. Especifica un texto lógico para ejecutar.
  • Función TEXTO. Da formato a un número y lo convierte en texto.
La función de fecha y hora DIASEM, nos indica el día de la semana mediante un número. Suponiendo que en la celda A1 tenemos escrita la fecha 29/11/2015.
  1. Ir a: Celda C1. O la celda deseada donde insertar el resultado.

  2. Escribir la función:

    =DIASEM(A1;1)

    El número del segundo argumento indica el número que indica el día de comienzo de la semana, así si escribimos el 1: Devolverá el número 1= Domingo; 2= Lunes; 3= Martes; 4= Miércoles; 5= Jueves; 6= Viernes y 7= Sábado.

    Tipo NúmeroNúmero mostrado
    1 u omitidoNúmeros del 1 (domingo) al 7 (sábado).Igual que en versiones anteriores de Excel.
    2Números del 1 (lunes) al 7 (domingo).
    3Números del 0 (lunes) al 6 (domingo).
    11Números del 1 (lunes) al 7 (domingo).
    12Números 1 (martes) a 7 (lunes).
    13Números 1 (miércoles) a 7 (martes).
    14Números 1 (jueves) a 7 (miércoles).
    15Números 1 (viernes) a 7 (jueves).
    16Números 1 (sábado) a 7 (viernes).
    17Números del 1 (domingo) al 7 (sábado).
  3. Ir a: Celda C1 / Verificar como muestra el valor 1 (correspondiente a domingo).

diasem01

Si deseamos que nos indique el día de la semana en texto, podemos aplicar diferentes métodos:

  • FUNCIÓN SI. Anidamos la función SI anidándola.

  1. Ir a: Celda D1. Celda donde mostrar el día de la semana en texto.

  2. Escribir la función (en la misma línea):

    =SI(DIASEM(A1;1)=1;"Domingo";
    SI(DIASEM(A1;1)=2;"Lunes";
    SI(DIASEM(A1;1)=3;"Martes";
    SI(DIASEM(A1;1)=4;"Miércoles";
    SI(DIASEM(A1;1)=5;"Jueves";
    SI(DIASEM(A1;1)=6;"Viernes";
    SI(DIASEM(A1;1)=7;"Sábado";"")))))))
diasem02
  • FUNCIÓN TEXTO.
  1. Ir a: Celda D2. Celda donde mostrar el día de la semana en texto.

  2. Escribir la función:

    =TEXTO(A1;"dddd")

    Según queramos representar el día cambiamos: "d" para el día en número formato corto 1; "dd" para el día en número formato largo 01; "ddd" día en texto formato corto dom; "dddd" día en texto formato largo domingo.

  3. Ir a: Celda D2 / Verificar como muestra el valor domingo.

diasem03
  • FORMATO DE CELDA PERSONALIZADO.
  1. Ir a: Celda C1. Celda donde mostrar el día de la semana en texto que incluye la función DIASEM.

  2. Pulsar botón derecho del ratón / Formato de celdas. Mostrará el cuadro de diálogo de formato.

    diasem05
  3. Pulsar en la pestaña: Número.

  4. Ir a Categoría / Pulsar sobre: Personalizada.

  5. Ir a: Tipo / Escribir:

    dddd

    Según queramos representar el día cambiamos: "d" para el día en número formato corto 1; "dd" para el día en número formato largo 01; "ddd" día en texto formato corto dom; "dddd" día en texto formato largo domingo.

  6. Pulsar el botón Aceptar. Cierra la ventana y aplica el formato personalizado.

  7. Ir a: Celda C1 / Verificar como muestra el valor domingo.

diasem04

Mediante funciones obtenemos de una fecha el día de la semana en Excel.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.