Convertir texto de fecha en fecha de Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Deseamos convertir un valor de texto que representa una fecha con formato "martes, 05 de marzo de 2013" en formato de fecha.

  1. Seleccionar la celda B2. Celda donde representar como fecha.

  2. Escribir:

    =TEXTO(IZQUIERDA(EXTRAE(A2;ENCONTRAR(" ";A2;1)+1;30);2)&EXTRAE(EXTRAE(A2;ENCONTRAR(" ";A2;1)+1;30);6;4)&DERECHA(EXTRAE(A2;ENCONTRAR(" ";A2;1)+1;30);4 );"dd/mm/aaaa")*1
  3. Mostrará el número de la fecha, pudiendo aplicar formato tipo fecha para mostrar 05/03/2013.

Convertir texto de fecha en fecha de Excel: Celda A2 con valor texto y celda B2 con valor fecha con funciones.

Mediante las funciones TEXTO, IZQUIERDA, EXTRAER, ENCONTRAR y DERECHA podemos convertir texto de fecha en fecha de Excel.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.