Convertir los valores de un rango en una columna

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Al importar datos o copiarlos es normal tener que adaptarlos a nuestras necesidades como convertir los valores de un rango en una columna.

La función TRANSPONER cambia los valores de filas a columnas, pero mantiene el número de filas del origen.

Convertir los valores de un rango en una columna

Emplearemos las siguientes funciones anidándolas:

  • Función INDICE Devuelve un valor de la celda en la unión de fila y columna de un rango.
  • Función ENTERO Redondea un número hasta el entero inferior más próximo.
  • Función FILA Devuelve el número de fila de una referencia.
  • Función COLUMNAS Devuelve el número de columnas de una matriz o referencia.
  • Función RESIDUO Proporciona el residuo después de dividir un número por un divisor.
Función anidada para convertir los valores de un rango en una columna

Disponemos de unos datos en el rango A1:D6 de nuestra hoja de cálculo y deseamos convertir los valores de un rango en una columna única.

 ABCD
11234
25678
39101112
413141516
617181920
  1. Ir a: Ventana de Excel.

  2. Ir a: Celda F1 / Escribir:

    =INDICE($A$1:$D$7;1+ENTERO((FILA(A1)-1)/COLUMNAS($A$1:$D$7));RESIDUO(FILA(A1)-1+COLUMNAS($A$1:$D$7);COLUMNAS($A$1:$D$7))+1)
  3. Copiar la celda F1.

  4. Pegar como fórmula en el rango F2:F24.

  5. Verificar como muestra en la columna F los valores del rango A1:D6.

Columna F mostrando los valores del rango
Nivel de dificultad: Avanzado Excel Avanzado

Un comentario en “Convertir los valores de un rango en una columna

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.