Contar y extraer caracteres en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Mediante funciones podemos contar y extraer caracteres en Excel.

Contar y extraer caracteres en Excel
  1. Ir a: Celda A1 / Escribir: Las funciones en Excel. O el texto deseado.

 
  • NÚMERO DE PALABRAS.

  1. Ir a: Celda D1 / Escribir:

    =SI(LARGO(ESPACIOS(A1))=0;0;LARGO(ESPACIOS(A1))-LARGO(SUSTITUIR(A1;" ";""))+1)

  2. Verificar como muestra: 4. Como el número de palabras de la celda A1.

 
  • NÚMERO CARACTERES ESPACIOS INCLUIDOS.

  1. Ir a: Celda D2 / Escribir:

    =LARGO(A1)

  2. Verificar como muestra: 22. Como el número de caracteres de la celda A1 con espacios.

 
  • NÚMERO CARACTERES SIN ESPACIOS.

  1. Ir a: Celda D3 / Escribir:

    =LARGO(SUSTITUIR(ESPACIOS(A1);" ";""))

  2. Verificar como muestra: 19. Como el número de caracteres de la celda A1 sin espacios.

 
  • NÚMERO CONSONANTES.

  1. Ir a: Celda D4 / Escribir:

    =LARGO(A1)-SUMAPRODUCTO(LARGO(A1)-LARGO(SUSTITUIR(A1;{"a";"e";"i";"o";"u";"A";"E";"I";"O";"U";" "};"" )))

  2. Verificar como muestra: 11. Como el número de letras consonantes de la celda A1.

 
  • NÚMERO VOCALES.

  1. Ir a: Celda D5 / Escribir:

    =SUMAPRODUCTO(LARGO(A1)-LARGO(SUSTITUIR(MINUSC(A1);{"a";"e";"i";"o";"u"};"" )))

  2. Verificar como muestra: 8. Como el número de letras vocales de la celda A1.

 
  • NÚMERO VECES INCLUYE CADENA DE TEXTO DETERMINADO (DISCRIMINA MAYÚSCULAS Y MINÚSCULAS).

  1. Ir a: Celda B6/ Escribir: fun.

  2. Ir a: Celda D6 / Escribir:

    =(LARGO(A1)-LARGO(SUSTITUIR(A1;B6;"")))/LARGO(B6)

  3. Verificar como muestra: 1. Como el número de cadenas de texto de la celda A1.

 
  • NÚMERO VECES INCLUYE CARACTER DETERMINADO (DISCRIMINA MAYÚSCULAS Y MINÚSCULAS).

  1. Ir a: Celda B7 / Escribir: f.

  2. Ir a: Celda D7 / Escribir:

    =(LARGO(A1)-LARGO(SUSTITUIR(A1;B6;"")))/LARGO(B6)

  3. Verificar como muestra: 1. Como el número de caracteres de la celda B7 en la celda A1.

 
  • NÚMERO VECES INCLUYE CARACTER DETERMINADO EN RANGO (DISCRIMINA MAYÚSCULAS Y MINÚSCULAS).

  1. Ir a: Celda B8 / Escribir: f.

  2. Ir a: Celda A2 / Escribir: función.

  3. Ir a: Celda D8 / Escribir:

    =SUMAPRODUCTO(LARGO(A1:A7)-LARGO(SUSTITUIR(A1:A7;B8;"")))

  4. Verificar como muestra: 2. Como el número de caracteres de la celda B7 en el rango A1:A7.

 
  • NÚMERO LETRAS EN MAYÚSCULA.

  1. Ir a: Celda D9 / Escribir:

    =SUMAPRODUCTO(LARGO(A1)-LARGO(SUSTITUIR(A1;CARACTER(FILA(INDIRECTO("65:90")));"")))

  2. Verificar como muestra: 2. Como el número de caracteres en mayúscula de la celda A1.

 
  • NÚMERO LETRAS EN MINÚSCULA.

  1. Ir a: Celda D10 / Escribir:

    =SUMAPRODUCTO(LARGO(A1)-LARGO(SUSTITUIR(A1;CARACTER(FILA(INDIRECTO("97:122")));"")))

  2. Verificar como muestra: 17. Como el número de caracteres en minúscula de la celda A1.

 
  • EXTRAE LAS CONSONANTES.

  1. Ir a: Celda D11 / Escribir:

    =SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(A1;"a";"");"e";"");"I";"");"o";"");"u";"");"A";"");"E";"");"I";"");"O";"");"U";"");" ";"")

  2. Verificar como muestra: Lsfncinsnxcl. Como las consonantes de la celda A1.

 
  • EXTRAE LAS VOCALES (EN MINÚSCULA).

  1. Ir a: Celda D12 / Escribir:

    =SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR(A1;"b";"");"c";"");"d";"");"f";"");"g";"");"h";"");"j";"");"k";"");"l";"");"m";"");"n";"");"p";"");"q";"");"r";"");"s";"");"t";"");"v";"");"w";"");"x";"");"y";"");"z";"");"B";"");"C";"");"D";"");"F";"");"G";"");"H";"");"J";"");"K";"");"L";"");"M";"");"N";"");"P";"");"Q";"");"R";"");"S";"");"T";"");"V";"");"W";"");"X";"");"Y";"");"Z";"")

  2. Verificar como muestra: a uioe e Ee. Como las vocales de la celda A1.

 
  • EXTRAE LA PRIMERA VOCAL.

  1. Ir a: Celda D13 / Escribir:

    =EXTRAE(A1;MIN(SI.ERROR(HALLAR("a";A1;1);100);SI.ERROR(HALLAR("e";A1;1);100);SI.ERROR(HALLAR("i";A1;1);100);SI.ERROR(HALLAR("o";A1;1);100);SI.ERROR(HALLAR("u";A1;1);100));1)

  2. Verificar como muestra: a. Como la primera vocal de la celda A1.

 
  • EXTRAE LA PRIMERA LETRA.

  1. Ir a: Celda D14 / Escribir:

    =EXTRAE(SUSTITUIR(A1;{"A";"O";"U";"E";"I";"Y"};"");1;1)

  2. Verificar como muestra: L. Como la primera letra de la celda A1.

 
  • EXTRAE LA SEGUNDA LETRA.

  1. Ir a: Celda D15 / Escribir:

    =EXTRAE(SUSTITUIR(A1;{"A";"O";"U";"E";"I";"Y"};"");2;1)

  2. Verificar como muestra: a. Como la segunda letra de la celda A1.

 
  • EXTRAE LA TERCERA LETRA.

  1. Ir a: Celda D16 / Escribir:

    =EXTRAE(SUSTITUIR(A1;{"A";"O";"U";"E";"I";"Y"};"");3;1)

  2. Verificar como muestra: s. Como la tercera letra de la celda A1.

 
  • EXTRAE TRES LETRAS CENTRALES (VARIA PALABRA PAR O IMPAR).

  1. Ir a: Celda D17 / Escribir:

    =EXTRAE(A1;ENTERO(LARGO(A1)/2);3)

  2. Verificar como muestra: nes. Como las tres letras centrales de la celda A1.

 
  • EXTRAE LAS TRES PRIMERAS LETRAS.

  1. Ir a: Celda D18 / Escribir:

    =IZQUIERDA(A1;3)

  2. Verificar como muestra: Las. Como las tres primeras letras de la celda A1.

 
  • EXTRAE LAS CUATRO ÚLTIMAS LETRAS.

  1. Ir a: Celda D19 / Escribir:

    =DERECHA(A1;4)

  2. Verificar como muestra: xcel. Como las cuatro últimas letras de la celda A1.

Nivel de dificultad: Avanzado Excel Avanzado

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.