Contar valores entre dos fechas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Necesitamos contar valores entre dos fechas Excel, para obtener la suma de los elementos que cumplen con el criterio.

Contar valores entre dos fechas Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMA. Suma todos los números del rango de celdas.

  • Función FRECUENCIA. Calcula la frecuencia con la que ocurre un valor dentro de un rango y devuelve una matriz vertical de números con más de un elemento que grupos.

  • Función SI. Comprueba si se cumple una condición y devuelve un valor si evalúa como verdadero y otro si se evalúa como falso.

  • Función COINCIDIR. Devuelve la posición relativa del elemento de la matriz, que coincide con un valor dado en el orden especificado.

  • Función FILA. Devuelve el número de fila de la referencia.

Disponemos en la columna A la referencia de nuestros pedidos y en la columna A la fecha del mismo. En la celda E1 insertaremos la fecha final deseada para contar los pedidos y en la celda E2 la fecha inicial.

 ABCDE
1PedidoFecha       Fecha Final:       
2Pedido 101/01/2017Fecha inicial:
3Pedido 201/05/2017
4Pedido 312/03/2017Nº Pedidos:
5Pedido 418/08/2017
6Pedido 525/11/2017
7Pedido 618/06/2017
  1. Ir a: Celda E1 / Escribir: 01/09/2017. O la fecha final deseada.

  2. Ir a: Celda E2 / Escribir: 01/05/2017. O la fecha inicial deseada.

  3. Clic sobre la celda E4. Celda donde contar el número de pedidos.

  4. Escribir:

    =SUMA(SI (FRECUENCIA(SI (B2:B7>=E2; SI(B2:B7<=E1; COINCIDIR(B2:B7 &"-"&A2:A7; B2:B7& "-"&A2:A7; 0))); FILA(B2:B7) -FILA(B2) +1)>0; 1))
  5. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(SI (FRECUENCIA(SI (B2:B7>=E2; SI(B2:B7<=E1; COINCIDIR(B2:B7 &"-"&A2:A7; B2:B7& "-"&A2:A7; 0))); FILA(B2:B7) -FILA(B2) +1)>0; 1))}.

  6. Verificar como muestra 3 como el número de pedidos entre las fechas indicadas (01/05/2017, 12/03/2017 y 18/08/2017).

  

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *