Contar valores entre dos fechas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Necesitamos contar valores entre dos fechas Excel, para obtener la suma de los elementos que cumplen con el criterio.

Contar valores entre dos fechas Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMA. Suma todos los números del rango de celdas.
  • Función FRECUENCIA. Calcula la frecuencia con la que ocurre un valor dentro de un rango y devuelve una matriz vertical de números con más de un elemento que grupos.
  • Función SI. Comprueba si se cumple una condición y devuelve un valor si evalúa como verdadero y otro si se evalúa como falso.
  • Función COINCIDIR. Devuelve la posición relativa del elemento de la matriz, que coincide con un valor dado en el orden especificado.
  • Función FILA. Devuelve el número de fila de la referencia.

Disponemos en la columna A la referencia de nuestros pedidos y en la columna A la fecha del mismo. En la celda E1 insertaremos la fecha final deseada para contar los pedidos y en la celda E2 la fecha inicial.

ABCDE
1PedidoFechaFecha Final:
2Pedido 101/01/2017Fecha inicial:
3Pedido 201/05/2017
4Pedido 312/03/2017Nº Pedidos:
5Pedido 418/08/2017
6Pedido 525/11/2017
7Pedido 618/06/2017
  1. Ir a: Celda E1 / Escribir: 01/09/2017. O la fecha final deseada.

  2. Ir a: Celda E2 / Escribir: 01/05/2017. O la fecha inicial deseada.

  3. Clic sobre la celda E4. Celda donde contar el número de pedidos.

  4. Escribir:

    =SUMA(SI (FRECUENCIA(SI (B2:B7>=E2; SI(B2:B7<=E1; COINCIDIR(B2:B7 &"-"&A2:A7; B2:B7& "-"&A2:A7; 0))); FILA(B2:B7) -FILA(B2) +1)>0; 1))
  5. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(SI (FRECUENCIA(SI (B2:B7>=E2; SI(B2:B7<=E1; COINCIDIR(B2:B7 &"-"&A2:A7; B2:B7& "-"&A2:A7; 0))); FILA(B2:B7) -FILA(B2) +1)>0; 1))}.

  6. Verificar como muestra 3 como el número de pedidos entre las fechas indicadas (01/05/2017, 12/03/2017 y 18/08/2017).

Nivel de dificultad: Avanzado Excel Avanzado

11 comentarios en “Contar valores entre dos fechas Excel

  • Saludos amigos, primero agradecerles por tanto conocimiento a través de sus publicaciones, en esta oportunidad tengo una consulta para ver si me pueden echar una mano

    Tengo una archivo de Excel donde en la columna A se ingresa fechas no sucesivas durante todo el año (ejem. 14/02/2019, 05/03/2019, 24/08/2019, etc), quisiera crear una tabla de estos valores para CONTAR detalladamente estos días, donde el encabezado de columna sería "Mes" y el de la fila sería Día Semana" ( de lunes a domingo), he intentado pero no he podido dar con la solución, lo que he conseguido es CONTAR los días pertenecientes a cada Mes pero no logro descriminal en mi tabla si estos días son lunes, martes miércoles, etc si pueden ayudarme se los agradecería, Saludos

  • Gracias por sus aportes, presento la siguiente situacion y agradezco su respuesta, requiero identificar cuando a un vendedor se cruza las citas en intervalos de fecha y hora
    Tengo un campo NOMBRE VENDEDOR, FECHA INICIAL DE REUNION, FECHA FINAL DE REUNION, HORA INICIAL Y HORA FINAL
    He intentado con si anidando con y pero no me funciona.
    Gracias

  • Saludos amigos, muchas gracias por sus aportes, tengo una consulta y quisiera ver si podrian ayudarme.

    Tengo toda la informacion en una hoja y en otra hoja estoy haciendo un reporte gral de esos datos.
    En este tengo un listado de clientes, en la columna A, esta la fecha en que este se registra, en la columna C si este es prospecto a una venta (en toda la columna solo pongo la palabra "si" o "no").

    Lo que ocupo hacer es que en el reporte que estoy haciendo, necesito saber cuantos clientes SI son prospectos entre determinadas fechas.

    De la forma que lo he logrado ha sido con esta funcion,
    =CONTAR.SI.CONJUNTO('CONSULTAS REALIZADAS'!C2:C150; "=SI")

    Pero esta formula funciona solo manualmente, me gustaria aplicarla al determinarle ciertas fechas a esa funcion, de antemano muchas gracias

  • alguien me puede ayudar con esta formula no me funciona
    =SUMAPRODUCTO((BD!$AY9:$AY32>=SNIS!$AI$6); (BD!$AY9:$AY32="&BD!BA8;BD!$C9:$C32;"<="&BD!BB8)))

  • Buenas tardes,

    He creado un calendario con un botón que me filtra por mes, es decir, si pongo enero, me aparece el calendario del mes de enero, en la parte izquierda aparecen los nombres de los empleados.

    La cuestión es la siguiente, en una tabla en otra pestaña tengo las fechas de vacaciones de los empleados, por ejemplo, Pepe tiene vacaciones del 03/02/2020 hasta el 09/02/2020. He conseguido mediante esta fórmula:

    =SI(O(C31='Seguimiento de bajas del emp...'!$C$4:$D$11);$B31='Seguimiento de bajas del emp...'!$B$4:$B$12)

    que me aparezca en el calendario del inicio coloreados las fechas que indico en el calendario de vacaciones, identificándome al empleado, pero no me colorea el intervalo. Solo me aparecen las fechas exactas.

    Por ejemplo, si pepe tiene vacaciones del 03/02/2020 al 09/02/2020 y maría del 04/03/2020 al 07/03/2020 me identifica de la tabla a maría y a pepe y me colorea esas fechas, pero el intervalo no.

    ¿Qué tipo de formula o que modificaciones debería de aplicar para que me reconozca el intervalo?
    Un saludo y gracias.

    • Hola F,

      Selecciona el rango de todas las fechas. Cinta de opciones / Pestaña: Inicio / Grupo: Estilos / Formato condicional / Resaltar reglas de celdas / Entre.
      Aplica el rango de fechas y el formato deseado.

      Saludos.

      • Buenos días,
        gracias por la rapidez, pero al realizar lo que indicas, tengo que poner un rango de fechas fijo, por tanto se me marca ese rango en todos los empleados, no me deja seleccionar la tabla donde tengo las fechas con los empleados de vacaciones.

        Es decir, En una pestaña tengo una tabla con los nombres de los empleados y los días que se van de vacaciones. Ejemplo: Pepe de 01/02/2020 al 06/02/2020 y en otra pestaña tengo un calendario con una pestaña que puedo seleccionar el mes que quiero ver en el que me sale una lista con todos los empleados.

        al poner:
        =SI(O(C31='Seguimiento de bajas del emp...'!$C$4:$D$11);$B31='Seguimiento de bajas del emp...'!$B$4:$B$12)

        en la pestaña de formato condicional "utilice una formula" consigo que se me marquen del color que diga los días exactos de las vacaciones que he indicado en la tabla de la otra hoja.
        Es decir, si pepe tiene vacaciones del 01/02/2020 al 06/02/2020 se me marcan en el calendario de verde solamente esos dos días, no el intervalo que hay entre medias.

        Quizás es un poco lioso de entender, pero agradecería una solución.

        Un saludo y gracias.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.