Contar mayúsculas, minúsculas y números en celda Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Cuando necesitamos contar mayúsculas, minúsculas y números en celda Excel podemos recurrir a funciones.

Contar mayúsculas, minúsculas y números en celda Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMAPRODUCTO. Devuelve la suma de los productos de rangos correspondientes.

  • Función LARGO. Devuelve el número de caracteres de una cadena de texto.

  • Función SUSTITUIR. Reemplaza el texto existente con texto nuevo en una cadena.

  • Función CARACTER. Devuelve el carácter especificado por el número de código a partir del juego de caracteres establecidos en el Pc.

  • Función FILA. Devuelve el número de fila de la referencia.

  • Función INDIRECTO. Devuelve la referencia especificada por el valor de texto.

    IDENTIFICACIÓN DE CARACTERES. En la función indirecto se indican los caracteres en código ANSII (por su número correspondiente).

En la celda A1 disponemos del valor "BCD18a" que incluye caracteres con letras en mayúsculas, letras en minúsculas y números.

  • CONTAR MAYÚSCULAS

  1. Ir a: Celda D1 / Escribir:

    =SUMAPRODUCTO(LARGO(A1)-LARGO(SUSTITUIR(A1;CARACTER(FILA(INDIRECTO("65:90")));"")))
  2. Mostrará 3. Por los caracteres BCD.

  • CONTAR MINÚSCULAS

  1. Ir a: Celda D2 / Escribir:

    =SUMAPRODUCTO(LARGO(A1)-LARGO(SUSTITUIR(A1;CARACTER(FILA(INDIRECTO("97:122")));"")))
  2. Mostrará 1. Por el carácter a.

  • CONTAR NÚMEROS

  1. Ir a: Celda D3 / Escribir:

    =SUMAPRODUCTO(LARGO(A1)-LARGO(SUSTITUIR(A1;CARACTER(FILA(INDIRECTO("48:57")));"")))
  2. Mostrará 2. Por los caracteres 18.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.