Contar las coincidencias entre columnas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Necesitamos comparar los valores de dos rangos y contar las coincidencias entre columnas Excel.

Contar las coincidencias entre columnas Excel

Emplearemos la siguiente función:

  • Función SUMAPRODUCTO. Devuelve la suma de los productos del rango.

Función SUMAPRODUCTO con sus argumentos

Disponemos en la columna A la referencia de las facturas emitidas y en la columna B su importe, insertando en la columna D el importe de las facturas cuando son abonadas. Necesitando conocer el número de facturas que han sido abonadas.

 AB
1FacturaVentas
2Factura 1001000
3Factura 1011500
4Factura 1022000
5Factura 1032500
6Factura 1043000
7Factura 1053500
8Factura 1064000
9Factura 1074500
10Factura 1085000
11Factura 1095500
  1. Ir a: Celda D2 / Escribir: 1000. Como la cantidad pagada de la factura 100.

  2. Ir a: Celda D4 / Escribir: 2000. Como la cantidad pagada de la factura 102.

  3. Ir a: Celda D8 / Escribir: 4000. Como la cantidad pagada de la factura 106.

  4. Ir a: Celda D10 / Escribir: 5000. Como la cantidad pagada de la factura 108.

  5. Ir a: Celda F2 / Escribir:

    = SUMAPRODUCTO(- -(B2:B11=D2:D11))

    – – (Doble guión) Muestra el resultado como positivo.

  6. Verificar como muestra 4 como el número de valores que coinciden entre las columnas (1000, 2000, 4000 y 5000).

contarcolumnas01
  • OTRA OPCIÓN

  1. Ir a: Celda F3 / Escribir:

    =SUMAPRODUCTO((B2:B11=D2:D11)*(B2:B11<>“”))
  2. Verificar como muestra 4 como el número de valores que coinciden entre las columnas (1000, 2000, 4000 y 5000).

contarcolumnas02
Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *