Contar celdas con números pares e impares en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

En un rango de datos, necesitamos contar celdas con números pares e impares en Excel.

Contar celdas con números pares e impares en Excel

Emplearemos las siguientes funciones anidadas:

  • Función SUMA.PRODUCTO. Devuelve la suma de los productos de un rango.
  • Función RESIDUO. Muestra el residuo después de dividir un número por un divisor.
Función  SUMA.PRODUCTO y RESIDUO con sus argumentos
 

Disponemos en la columna A de una serie de valores. Necesitamos conocer cuantos son números pares e impares.

 A
1Valor
21
32
43
54
65
76
87
98
109
1010
1011
1012
1013
1014

 

  • CONTAR VALORES PARES
  1. Ir a: Celda D1 / Escribir:

    =SUMAPRODUCTO(-(RESIDUO(A2:A14;2)=0))*-1

    RESIDUO(A2:A14;2)=0 devuelve el resto después de la división, el divisor es 2, por lo RESIDUO devolverá un resto de 0 para cualquier número entero par, y un resto de 1 para los números impares.

    *-1. Muestra el resultado como positivo.

  2. Verificar como muestra 6 como el número total de valores pares (2, 4, 6, 8, 10 y 12).

Celda D1 con valor de 6, para resultados de números pares
 
  • CONTAR VALORES IMPARES

  1. Ir a: Celda D2 / Escribir:

    =SUMAPRODUCTO(-(RESIDUO(A2:A14;2)=1))*-1

    RESIDUO(A2:A14;2)=1 devuelve el resto después de la división, el divisor es 2, por lo RESIDUO devolverá un resto de 1 para cualquier número entero impar, y un resto de 0 para los números pares.

    *-1. Muestra el resultado como positivo.

  2. Verificar como muestra 7 como el número total de valores impares (1, 3, 5, 7, 9, 11 y 13).

Celda D2 con valor de 7, para resultados de números impares
Nivel de dificultad: Avanzado Excel Avanzado

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.