Comparar los valores repetidos en 2 columnas en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Mediante la función BUSCARV podemos comparar los valores repetidos en 2 columnas en Excel.

Comparar los valores repetidos en 2 columnas en Excel
  • Función SI. Comprueba si se cumple una condición y devuelve un valor si se evalúa como verdadero y otro valor si se evalúa como falso.

  • Función ESNOD. Comprueba si un valor de error es #N/A y devuelve verdadero o falso.

  • Función BUSCARV. Busca un valor en la primera columna de la izquierda del rango y devuelve un valor en la misma fila desde la columna indicada.

 

Disponemos de valores en la columna A y B, deseamos comparar cada fila en la columna D.

 AB
1Columna 1Columna 2
2EspañaEspaña
3MéxicoFrancia
4ColombiaColombia
5AlemaniaAlemania
6PerúBolivia
7ChileChile
  1. Ir a: Celda D2 / Escribir:

    =SI(ESNOD(BUSCARV(A2;$B$2:$B$7;1;0));"";"SI")
  2. Copiar la celda D2 / Pegar en el rango D3:D7.

  3. Verificar como muestra SI en las celdas que coinciden en ambas columnas.

Columna D comparando la columna A y B
Nivel de dificultad: Básico Excel Básico

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.