Comparar datos entre columnas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Podemos comparar datos entre columnas Excel para encontrar los valores duplicados. Disponiendo de otros métodos como formato condicional para la misma labor.

Emplearemos las siguientes funciones anidándolas:

  • Función SI. Especifica un texto lógico para ejecutar.

  • Función ESERROR. Devuelve VERDADERO si el valor es cualquier valor de error.

  • Función COINCIDIR. Busca los valores en una referencia o matriz.

Función anidada: =SI(ESERROR(COINCIDIR(B2;$C$2:$C$8;0));"";B2)
En la columna B disponemos de diferentes valores que deseamos comparar con los de la columna C, para identificar los datos duplicados.
Comparar datos entre columnas Excel: Columna B con valores a comparar con columna C
  1. Ir a: Celda A2 / Escribir:

    =SI(ESERROR(COINCIDIR(B2;$C$2:$C$8;0));"";B2)

    Rango C2:C8 como referencia absoluta ($).

  2. Seleccionar la celda A2 / Copiar. Celda que incluye la fórmula.

  3. Seleccionar el rango A2:A8 / Pegar como fórmula. Rango donde pegar la fórmula.

    Comparar datos entre columnas Excel: Celda A2 con función, =SI(ESERROR(COINCIDIR(B2;$C$2:$C$8;0));"";B2)
  4. Verificar como la columna A muestra los valores repetidos 100 (B2, B6 y C3), 300 (B3 y C5) y 550 (B8 y C8).

Mediante las funciones SI, ESERROR y COINCIDIR, podemos comparar datos entre columnas Excel.

 

Nivel de dificultad: Avanzado Excel Avanzado

4 comentarios en “Comparar datos entre columnas Excel

  • Realmente es un aporte muy bueno, sin duda lo utilizaremos en el trabajo diario e informes.

    Ahora mi consulta es la siguiente, existe una formula que me permita detectar que se este duplicando toda la información de una columna a otra, ej. son 30 columnas y 14 filas con números aleatorios, la idea es que ninguna columna debe ser idéntica a otra, la formula debe detectar rápidamente la duplicidad para no caer en errores en el reporte.

    Desde ya muchas gracias

    • Hola Rommel,

      El formato condicional nos permite identificar el valor de una celda en la columna.

      Para tus necesidades la única opción sería mediante macros, que identifique el valor de la columna para compararla.

      Saludos

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *