Comparar datos entre columnas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Podemos comparar datos entre columnas Excel para encontrar los valores duplicados. Disponiendo de otros métodos como formato condicional para la misma labor.

Emplearemos las siguientes funciones anidándolas:

  • Función SI. Especifica un texto lógico para ejecutar.

  • Función ESERROR. Devuelve VERDADERO si el valor es cualquier valor de error.

  • Función COINCIDIR. Busca los valores en una referencia o matriz.

Función anidada: =SI(ESERROR(COINCIDIR(B2;$C$2:$C$8;0));"";B2)
En la columna B disponemos de diferentes valores que deseamos comparar con los de la columna C, para identificar los datos duplicados.
Comparar datos entre columnas Excel: Columna B con valores a comparar con columna C
  1. Ir a: Celda A2 / Escribir:

    =SI(ESERROR(COINCIDIR(B2;$C$2:$C$8;0));"";B2)

    Rango C2:C8 como referencia absoluta ($).

  2. Seleccionar la celda A2 / Copiar. Celda que incluye la fórmula.

  3. Seleccionar el rango A2:A8 / Pegar como fórmula. Rango donde pegar la fórmula.

    Comparar datos entre columnas Excel: Celda A2 con función, =SI(ESERROR(COINCIDIR(B2;$C$2:$C$8;0));"";B2)
  4. Verificar como la columna A muestra los valores repetidos 100 (B2, B6 y C3), 300 (B3 y C5) y 550 (B8 y C8).

Mediante las funciones SI, ESERROR y COINCIDIR, podemos comparar datos entre columnas Excel.

 

Nivel de dificultad: Avanzado Excel Avanzado

10 comentarios en “Comparar datos entre columnas Excel

  • Realmente es un aporte muy bueno, sin duda lo utilizaremos en el trabajo diario e informes.

    Ahora mi consulta es la siguiente, existe una formula que me permita detectar que se este duplicando toda la información de una columna a otra, ej. son 30 columnas y 14 filas con números aleatorios, la idea es que ninguna columna debe ser idéntica a otra, la formula debe detectar rápidamente la duplicidad para no caer en errores en el reporte.

    Desde ya muchas gracias

    • Hola Rommel,

      El formato condicional nos permite identificar el valor de una celda en la columna.

      Para tus necesidades la única opción sería mediante macros, que identifique el valor de la columna para compararla.

      Saludos

  • me ayudas por favor
    si en una columna tengo el 1 y en otra columna 1 como son iguales quiero que me vote verdadero y si no son iguales que me vote falso
    gracias

  • buenas… tengo una urgencia….
    Tengo una tabla con valores “1” “2” y “3”, y otra tabla con valores “1” y “2”.
    Supongamos que la tabla de valores “1” y “2” sea “niño”y “niña”, y que la otra tabla sea “mañana”, “tarde”, “noche”.
    Cual seria formula/funcion para segmentar “niño”-“mañana,”niño- tarde, “niño”-” noche”, “niña”-“mañana”, “niña”-“tarde”, “niña”-“noche” ??????
    Llevo dos dias loco y ya me quedé bloqueado
    Me urge muchísimo!!!!!!!!!!!!!!!!

    • Hola Miguel Angel,

      Aunque falta algún dato en la explicación, creo que lo que te refieres es lo siguiente:

      – Celda A2= Jornada (1=Mañana; 2=Tarde; 3=Noche).
      – Celda C2= Niño/Niña (1=Niño; 2=Niña).

      En celda E2, escribimos la fórmula:

      =SI(A2=1;”Mañana”;SI(A2=2;”Tarde”;SI(A2=3;”Noche”;””))) & ” – ” & SI(C2=1;”Niño”;SI(C2=2;”Niña”;””))

      Saludos.

  • buenas
    mi duda es:
    Tengo 2 tablas con un campo alfanumerico en comun (ejem. tabla1,columna8 = “a df 12 ax.10”, tabla2,columna4 = “a, df, 12, ax.10”,y asi susesivamente hasta la fila 10000 y 20000 respectivamente), y quiero comparar los valores de estas 2 columnas para verificar que no existan duplicados duplicados,
    una columna esta separado por comas y la otra por espacios solamente.

  • Hola Esuarez,

    Para poder comparar los duplicados será necesario que el valor en ambas columnas sea idéntico, siendo necesario reemplazar las comas por espacios o a la inversa para unificar el criterio.

    Saludos.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *